Kernel 5.15.2 breaks LG Gram laptop

Hello.

Since the latest updates, Garuda Linux with KDE Plasma was impossible to use in my quite new LG Gram laptop. The GUI self-destructed all the time: the animations stalled, all the Plasma DE stalled for seconds at a time, the wallpaper disappeared, the windows tittle bars disappeared... Continually. It was impossible to use, so I rolled back to a previous Snapper snapshot and kept going like that.

Today I finally had some time to investigate further and this is what I found: I installed the LTS kernel and choosing it in the grub menu, everything works perfectly. Otherwise, with the 5.15.2.zen1-1 kernel, the chaos ensues. And so does with the 5.15.2.arch1-1 and the 5.16rc1-1 kernels, which I tried just to have more info.

So this post is mainly to report this.

Also, is there any way not to have to choose the LTS kernel every time I boot? I have btrfs.

Cheers.

╰─λ inxi -Faz
System:    Kernel: 5.10.79-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=899964ab-8512-415a-bad5-d5f6571a0f0f rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: LG product: 17Z90P-G.AA79B v: 0.1 serial: <filter> Chassis: type: 10 v: 0.1
serial: <filter>
Mobo: LG model: 17Z90P v: FAB1 serial: <filter> UEFI: Phoenix v: T2ZF0320 X64 date: 04/23/2021
Battery:   ID-1: CMB0 charge: 50.9 Wh (65.1%) condition: 78.2/80.0 Wh (97.7%) volts: 8.0 min: 7.7 model: LG LGC-LGC
type: Li-ion serial: <filter> status: Discharging cycles: 10
CPU:       Info: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP arch: Tiger Lake family: 6
model-id: 8C (140) stepping: 1 microcode: 8A cache: L2: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44851
Speed: 941 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 941 2: 1070 3: 1099 4: 909 5: 822 6: 1231
7: 776 8: 1141
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: LG driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:9a49 class-ID: 0300
Device-2: Realtek LG Camera type: USB driver: uvcvideo bus-ID: 3-2:2 chip-ID: 0bda:5641 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.7x16.7") s-diag: 798mm (31.4")
Monitor-1: eDP1 res: 2560x1600 hz: 60 dpi: 176 size: 370x230mm (14.6x9.1") diag: 436mm (17.2")
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: LG driver: sof-audio-pci
alternate: snd_hda_intel,snd_sof_pci bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0401
Sound Server-1: ALSA v: k5.10.79-1-lts running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:a0f0
class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:4 chip-ID: 8087:0026
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 953.87 GiB used: 23.96 GiB (2.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM001TD3JX013N size: 953.87 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 41000C20
temp: 32.9 C scheme: GPT
Partition: ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 23.91 GiB (23.9%) fs: btrfs dev: /dev/nvme0n1p8
maj-min: 259:8
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 57.5 MiB (22.4%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%) used: 23.91 GiB (23.9%) fs: btrfs
dev: /dev/nvme0n1p8 maj-min: 259:8
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%) used: 23.91 GiB (23.9%) fs: btrfs
dev: /dev/nvme0n1p8 maj-min: 259:8
ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%) used: 23.91 GiB (23.9%) fs: btrfs
dev: /dev/nvme0n1p8 maj-min: 259:8
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p7
maj-min: 259:7
ID-2: swap-2 type: zram size: 15.33 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 32.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 241 Uptime: 6m wakeups: 303 Memory: 15.33 GiB used: 3.04 GiB (19.8%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1298 lib: 327 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08
1 Like

You can do something like this.

3 Likes

Thank you very much. I will try it soon.

1 Like

This is a relatively common occurrence on kernel updates, across all distros. This is why it's important to keep an alternative kernel installed as it's unlikely (but not impossible) that the same issue would hit both linux and linux-lts kernels.

5.15.3 has been released which may fix the regression. Until that reaches your mirror, or until it is fixed, then use a working kernel instead.

Garuda devs don't develop or maintain the kernel - it's taken from Arch, and that's taken from Linus/Greg.

4 Likes

The latest 5.15.3 kernel includes many bug fixes. Also the latest 5.10.80 kernel.
Some are missing fixes are "missing" but arch did some patches for it.

Most issues with 5.15.x are right now solved. (depends on which kernel you use of course)

4 Likes

Garuda devs don't develop or maintain the kernel - it's taken from Arch, and that's taken from Linus/Greg.

I know, but as I use Garuda Linux, I just wanted to let the Garuda community know, in case somebody had a similar problem and was going crazy trying to find a solution, as I did for quite some days. Maybe my use of the verb 'report' is not right. Thank you very much for your kind answer, in any case.

1 Like

Great to know. Thank you for the info.

The reason why I still run kernel 5.10.x is because my hardware is not cutting-edge. The newest kernel should work with new hardware the best, but not always the case for old hardware.

1 Like

Kernel 5.15.3, which I just installed, does not solve the problem. I just wanted to let everybody who might be interested know. I'll keep using the LTS kernel, which works fine, and wait for a future kernel. If I find time, I'll also try to learn more so I can investigate further. The issue I think that has to do with the graphics system, because the animations stall, the wallpapers disappear, the fonts render half-way, some parts of the GUI disappear, and son on. Probably some module is the culprit or maybe there is some parameter I have to add to the new kernel, I don't know. Computers are like this. Cheers.

1 Like

Brand new laptop needs the LTS kernel for a while? I've been where you're at.

I cried a lot of crocodile tears (American euphemism?).
:rofl:

1 Like

I don't see the need for the cutting-edge kernel, unless you added new hardware that the LTS kernel don't support. You may disagree, but that is how I see it. Even the Linux developers know that newer not always means better, that is why there is such a thing as LTS kernels.

You could try the new kernel update see if it works now 5.15.4

1 Like

It's the zen component of the kernel what I like, not it being cutting-edge. The zen kernel is faster and consumes less CPU. And the zen kernel comes only in the latest kernel version. Anyway, I'm not complaining, I'm just reporting.

Just tried kernel 5.15.4 and no luck yet. Same results as before.

Kernel 5.15.5 doesn't solve the issue either. Just posting it as further info.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.