KDFONTOP: Unable to load such font with such kernel version

After waking from hibernation, system would hang at

setfont: KDFONTOP: Function not implemented

Booting older snapshots works, but when applying them and rebooting the error reappears. I used chroot to update the system, then added BINARIES=(setfont) to /etc/mkinitcpio.conf and rebuilt the initramfs. Now it hangs on

setfont: ERROR kdfontop.c:183 put_font_kdfontop: Unable to load such font with such kernel version `

I tried replacing plymouth-git with plymouth as this post suggests, but the same error occurs.

After that, I replaced plymouth with plymouth-git, then booted while temporarily disabling splash in grub. It booted, but to a black screen. I used

sudo systemctl enable --now sddm.service

in tty2, but the screen was still blank

12Kernel 6.0.2-zen1-1-zen 12arch x86_64 12bits 64 12compiler gcc 12v 12.2.0
12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda
misolabel=GARUDA_DR460NIZEDGAMING_TALON quiet systemd.show_status=1 ibt=off driver=nonfree
nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
12Console N/A 12Distro Garuda Linux 12base Arch Linux
12Type Desktop 12Mobo Gigabyte 12model B550 AORUS ELITE 12serial N/A 12UEFI American Megatrends LLC. 12v F16c
12date 03/23/2023
12Info 12model AMD Ryzen 7 3800X 12socket AM4 12bits 64 12type MT MCP 12arch Zen 2 12gen 3 12level v3 12notecheck
12built 2020-22 12process TSMC n7 (7nm) 12family 0x17 (23) 12model-id 0x71 (113) 12stepping 0
12microcode 0x8701030
12Topology 12cpus 1x 12cores 8 12tpc 2 12threads 16 12smt enabled 12cache 12L1 512 KiB
12desc d-8x32 KiB; i-8x32 KiB 12L2 4 MiB 12desc 8x512 KiB 12L3 32 MiB 12desc 2x16 MiB
12Speed (MHz) 12avg 3900 12min/max 2200/4559 12boost enabled 12base/boost 3900/4550 12scaling
12driver acpi-cpufreq 12governor performance 12volts 1.1 V 12ext-clock 100 MHz 12cores 121 3900 122 3900 123 3900
124 3900 125 3900 126 3900 127 3900 128 3900 129 3900 1210 3900 1211 3900 1212 3900 1213 3900 1214 3900 1215 3900
1216 3900 12bogomips 124562
12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
12Vulnerabilities <filter>
12Device-1 NVIDIA GA106 [Geforce RTX 3050] 12vendor eVga.com. 12driver nvidia 12v 520.56.06
12non-free 530.xx+ 12status current (as of 2023-05) 12arch Ampere 12code GAxxx 12process TSMC n7 (7nm)
12built 2020-22 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 8 12link-max 12gen 4 12speed 16 GT/s 12lanes 16
12bus-ID 06:00.0 12chip-ID 10de:2507 12class-ID 0300
12Display 12server X.org 12v 12with Xwayland 12v 23.1.2 12compositor kwin_x11 12driver 12X 12loadedN/A
12alternate intel 12gpu nvidia 12tty 80x40
12API OpenGL 12Message GL data unavailable in console for root.
12Device-1 NVIDIA GA106 High Definition Audio 12vendor eVga.com. 12driver snd_hda_intel 12v kernel 12pcie
12gen 1 12speed 2.5 GT/s 12lanes 8 12link-max 12gen 4 12speed 16 GT/s 12lanes 16 12bus-ID 06:00.1
12chip-ID 10de:228e 12class-ID 0403
12Device-2 AMD Starship/Matisse HD Audio 12vendor Gigabyte 12driver snd_hda_intel 12v kernel 12pcie 12gen 4
12speed 16 GT/s 12lanes 16 12bus-ID 08:00.4 12chip-ID 1022:1487 12class-ID 0403
12Device-3 Corsair HS80 RGB Wireless Gaming Receiver 12driver hid-generic,snd-usb-audio,usbhid
12type USB 12rev 2.0 12speed 12 Mb/s 12lanes 1 12mode 1.1 12bus-ID 1-9:8 12chip-ID 1b1c:0a6b 12class-ID 0300
12serial <filter>
12API ALSA 12v k6.0.2-zen1-1-zen 12status kernel-api 12with aoss 12type oss-emulator 12tools N/A
12Server-1 PipeWire 12v 0.3.72 12status n/a (root, process) 12with 121 pipewire-pulse 12status active
122 wireplumber 12status active 123 pipewire-alsa 12type plugin 124 pw-jack 12type plugin
12tools pactl,pw-cat,pw-cli,wpctl
12Device-1 Intel Wi-Fi 6 AX200 12driver iwlwifi 12v kernel 12pcie 12gen 2 12speed 5 GT/s 12lanes 1
12bus-ID 03:00.0 12chip-ID 8086:2723 12class-ID 0280
12IF wlp3s0 12state up 12mac <filter>
12Device-2 Realtek RTL8125 2.5GbE 12vendor Gigabyte 12driver r8169 12v kernel 12pcie 12gen 2 12speed 5 GT/s
12lanes 1 12port f000 12bus-ID 05:00.0 12chip-ID 10ec:8125 12class-ID 0200
12IF eno1 12state down 12mac <filter>
12Device-1 Intel AX200 Bluetooth 12driver btusb 12v 0.8 12type USB 12rev 2.0 12speed 12 Mb/s 12lanes 1 12mode 1.1
12bus-ID 1-6.4.2:9 12chip-ID 8087:0029 12class-ID e001
12Report bt-adapter 12ID hci0 12rfk-id 0 12state up 12address N/A
12Local Storage 12total 3.07 TiB 12used 408.96 GiB (13.0%)
12ID-1 /dev/nvme0n1 12maj-min 259:0 12vendor Samsung 12model SSD 970 EVO Plus 1TB 12size 931.51 GiB
12block-size 12physical 512 B 12logical 512 B 12speed 31.6 Gb/s 12lanes 4 12tech SSD 12serial <filter>
12fw-rev 2B2QEXM7 12temp 37.9 C
12SMART yes 12health PASSED 12on 92d 20h 12cycles 626 12read-units 732,904,183 [375 TB]
12written-units 96,649,497 [49.4 TB]
12ID-2 /dev/sda 12maj-min 8:0 12vendor Samsung 12model SSD 850 EVO 250GB 12family based SSDs
12size 232.89 GiB 12block-size 12physical 512 B 12logical 512 B 12sata 3.1 12speed 6.0 Gb/s 12tech SSD
12serial <filter> 12fw-rev 2B6Q 12temp 30 C
12SMART yes 12state enabled 12health PASSED 12on 198d 4h 12cycles 3061 12written 19.51 TiB
12ID-3 /dev/sdb 12maj-min 8:16 12vendor Western Digital 12model WD20NMVW-11EDZS6 12family Elements / My
Passport (USB, AF) 12size 1.82 TiB 12block-size 12physical 4096 B 12logical 512 B 12type USB 12rev 3.0
12spd 5 Gb/s 12lanes 1 12mode 3.2 gen-1x1 12sata 3.0 12speed 3.0 Gb/s 12tech HDD 12rpm 5200 12serial <filter>
12fw-rev 1019 12drive-rev 01.01A01 12temp 31 C
12SMART yes 12state enabled 12health PASSED 12on 3y 258d 13h 12cycles 292
12ID-4 /dev/sdc 12maj-min 8:32 12vendor Generic 12model USB3.0 CRW -SD 12size 119.25 GiB 12block-size
12physical 512 B 12logical 512 B 12type USB 12rev 3.0 12spd 5 Gb/s 12lanes 1 12mode 3.2 gen-1x1 12tech N/A
12serial <filter> 12fw-rev 1.00
12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
12ID-1 / 12raw-size 914.14 GiB 12size 914.14 GiB (100.00%) 12used 408.96 GiB (44.7%) 12fs btrfs
12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
12ID-2 /boot/efi 12raw-size 300 MiB 12size 299.4 MiB (99.80%) 12used 576 KiB (0.2%) 12fs vfat
12block-size 512 B 12dev /dev/nvme0n1p1 12maj-min 259:1
12ID-3 /home 12raw-size 914.14 GiB 12size 914.14 GiB (100.00%) 12used 408.96 GiB (44.7%) 12fs btrfs
12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
12ID-4 /var/log 12raw-size 914.14 GiB 12size 914.14 GiB (100.00%) 12used 408.96 GiB (44.7%) 12fs btrfs
12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
12ID-5 /var/tmp 12raw-size 914.14 GiB 12size 914.14 GiB (100.00%) 12used 408.96 GiB (44.7%) 12fs btrfs
12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
12Kernel 12swappiness 133 (default 60) 12cache-pressure 100 (default)
12ID-1 swap-1 12type zram 12size 15.52 GiB 12used 749 MiB (4.7%) 12priority 100 12dev /dev/zram0
12System Temperatures 12cpu 44.0 C 12mobo 29.0 C
12Fan Speeds (RPM) N/A
12Processes 366 12Uptime 9m 12wakeups 0 12Memory 12available 15.52 GiB 12used 4.76 GiB (30.7%) 12Init systemd
12v 253 12default graphical 12tool systemctl 12Compilers 12gcc 13.1.1 12clang 15.0.7 12Packages 12pm pacman
12pkgs 1931 12libs 539 12tools octopi,paru 12Client Unknown Client: slub_flushwq 12inxi 3.3.27
Garuda (2.6.16-1):
System install date:     2023-05-11
Last full system update: 2023-07-04
Is partially upgraded:   No
Relevant software:       snapper NetworkManager connman mkinitcpio nvidia-dkms
Windows dual boot:       No/Undetected
Running in chroot, ignoring command 'list-units'
Failed units:

not sure whats with the random 12s in inxi :thinking:

Did you rebuild your initramfs following this change? The plymouth package requires that. Since you are using mkinitcpio to rebuild your initramfs along with setting the boot splash to dr460nized theme here:

sudo plymouth-set-default-theme -R dr460nized

Notice the -R flag invokes rebuilding of initramfs with mkinitcpio

Yeah, I wouldn’t do that it has been confirmed that the current plymouth-git package has some bug that prevents people from going past the loading initramfs page.

Though given you had disabled plymouth while booting I don’t think it would change much but still worth a try. :person_shrugging:


Went back to using plymouth instead of plymouth-git as you said, but when installing plymouth it seems to build the initramfs automatically. I ran

sudo plymouth-set-default-theme -R dr460nized

just in case, but it still has the issue.

Booting when removing quiet from grub shows that it hangs on

Started Hostname Service

have you tried using a different kernel yet? use chroot to install the LTS kernel and see if that does something.

pacman -S linux-lts linux-lts-headers

It should be this bug:

The Arch bug report seems to focus on kernel 6.4, so with the LTS it could work, but the upstream report seems to focus on the LTS kernel as well... Just try it.
Maybe an alternative could be to downgrade kbd.


neither booting with LTS nor downgrading kbd seems to work. I also tried replacing the hooks keymap and consolefont with sd-vconsole in mkinitcpio.comf and regenerating initramfs as one of the comments on the arch bug says, but again no dice.

ok, this might not necessarily be the solution but how about switching from mkinitcpio to dracut? maybe that helps.

  1. Enter chroot
  2. Install garuda-dracut-support with
pacman -S garuda-dracut-support

It will mention conflicts with mkinitcpio and mark mkinitcpio's package for removal. Accept them all and move ahead with installing dracut.

  1. Once done although pacman hooks should have covered it just to be extra safe rebuild your initramfs with

then exit chroot and reboot to see if that makes any difference.
To know more about dracut

1 Like

Still gets stuck, though building is quicker and doesn't give me the possibly missing firmware warnings that mkinitcpio does :+1:

Can you tell me to what version of kbd did you downgrade to? I am currently on 2.6.1-1 as of updating my system on 02-jul-2023.

If that’s what you are on as well how about downgrading the kernel and it’s headers this time? Although not recommended in this situation where even snapshots don’t work I believe having a working system is of more importance.

Try downgrading both linux-zen and linux-zen-headers to version 6.3.9.zen1-1

1 Like

I tried downgrading kbd to both 2.5.1-2 and 2.6.0-1, I was on 2.6.1-1 when the issue started.

I switched back to 2.6.1-1 then downgraded the kernel and again it gets stuck while booting.

Hmm this is getting strange. I am sorry for asking this instead of just looking at your inxi but can you tell me if you have a hybrid graphics setup? I am sorry but your inxi is just... a little unreadable. I saw nvidia graphics card on your inxi and AMD CPU. So if you have a hybrid graphics setup are you using your nvidia card to boot into your system by default? If so can you try using your integrated graphics instead. This could just be a nvidia problem.

1 Like

I just have a gpu, no integrated graphics.

Yeah I am suspecting this to be a nvidia drivers

I noticed that you are using version 520.56.06 for your nvidia drivers. Unless you have specifically added the nvidia drivers to IgnorePkg for some reason. Can you try and see if upgarding your drivers does the trick. As of writing this post my nvidia driver version is at 535.54.03.

from chroot

garuda-update -- garuda-nvidia-prime-config --ignore=linux-zen,linux-zen-headers,kbd

should update your nvidia-dkms along with all the dependencies that this package has while avoiding the kernel updates.

If you had specifically blocked nvidia drivers from updating you could try to switch from your proprietary drivers to open source ones and see if that solves the issue

BTW, I completely forgot to ask this but what’s the last error you got with this one?

It still wont boot with updated drivers. I never added nvidia drivers to IgnorePkg, so its weird that my last update missed them.

I ran garuda-update before that so it removed plymouth. The every time i’ve tried boothing regardless of setup it just gets stuck at loading different things, nothing specific

Sorry pal, :pensive: can't really think of anything at this point all I can say is give a shot to the nouveau drivers. They are pre-installed you just need to search how to enable and use them instead of nvidia-dkms. If this too doesn't do anything then all I can say is switch back to nvidia-dkms (as proprietary driver works better with nvidia sadly) and wait for some updates upstream to fix it.

Nouveau didn't work either :frowning: . Anyway thank you for all your help!

Same problem here. I'm getting crazy. Anyway I'm able to boot, but I can see that error message splashing for few seconds before the login screen

Anyone with this error may want to check the links giver earlier by @filo.

I also use a custom console font, and started to get this error when booting. After replacing keymap consolefont with sd-vconsole in HOOKS, as one user suggested in the GitHub page, the error is not displayed anymore while I am still able to use my custom console font and keyboard map normally. As a bonus, it seems that setfont is not needed in BINARIES anymore. I have also replaced udev with systemd since I was going to use sd-vconsole anyway as I have read elsewhere that this also speeds up the boot, and no issues so far.


I followed the things @LFOM said, and I managed to get rid of all setfont comments, however the system still refuses to boot. Since I can't enter the tty I don't think it's because of the graphic drivers I had them broken on several occasions and tty worked just fine
I can enter the system using gurb, selecting the first position, but if I'm using refind or even another position in grub (same system) it freezes on a black screen