KdenLive does not work

Sorry guys. Have a problem again With Kdenlive.
I have installed from the software center, uninstalled and replaced by Appimage, uninstalled that again and reinstalled from software center. Why? Because it crashes as soon as I try to put one file into the project, regardless of jpg or mp4. There is a message that they want to transform to another format, but then it crashes.
This is my current Inxi:

 Kernel: 6.1.4-zen2-1-zen arch: x86_64 bits: 64
    compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=48cd2da8-53a0-4027-928a-20ce3dc707ba rw
    [email protected] quiet quiet splash
    rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=714d68c7-235d-49a0-91c3-0064a8a1074f
    loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8
    info: plank wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: P8H67-M PRO
    v: Rev X.0x serial: <superuser required>
    UEFI: American Megatrends v: 3904 date: 04/27/2013
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless
    Keyboard K270 serial: <filter> charge: 100% (should
    be ignored) rechargeable: yes status: discharging
CPU:
  Info: model: Intel Core i7-3770K bits: 64 type: MT MCP
    arch: Ivy Bridge gen: core 3 level: v2 built: 2012-15
    process: Intel 22nm family: 6 model-id: 0x3A (58)
    stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8
    smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB
    desc: 4x256 KiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3261 high: 3900 min/max: 1600/3900
    scaling: driver: intel_cpufreq governor: performance
    cores: 1: 3900 2: 3900 3: 3900 4: 3292 5: 1648 6: 3900
    7: 3900 8: 1648 bogomips: 57681
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2
    ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel IvyBridge GT2 [HD Graphics 4000]
    vendor: ASUSTeK driver: i915 v: kernel arch: Gen-7
    process: Intel 22nm built: 2012-13 ports:
    active: HDMI-A-2 empty: DP-1, DP-2, HDMI-A-1, VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0162 class-ID: 0300
  Device-2: Generalplus 808 Camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 2-1.3:7
    chip-ID: 1b3f:2002 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland
    v: 22.1.7 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa
    dri: crocus gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
    s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-2 mapped: HDMI-2 model: BenQ GW2780
    serial: <filter> built: 2017 res: 1920x1080 hz: 60
    dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23")
    diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080
    min: 720x400
  API: OpenGL v: 4.2 Mesa 22.3.2 renderer: Mesa Intel
    HD Graphics 4000 (IVB GT2) direct render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High
    Definition Audio vendor: ASUSTeK P8H67
    driver: snd_hda_intel bus-ID: 2-1.3:7 v: kernel
    bus-ID: 00:1b.0 chip-ID: 1b3f:2002 chip-ID: 8086:1c20
    class-ID: 0102 class-ID: 0403 serial: <filter>
  Device-2: Generalplus 808 Camera type: USB
    driver: snd-usb-audio,uvcvideo
  Sound API: ALSA v: k6.1.4-zen2-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit
    Ethernet vendor: ASUSTeK P8P67 and other motherboards
    driver: r8168 v: 8.051.02-NAPI modules: r8169 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full
    mac: <filter>
  Device-2: Realtek RTL88x2bu [AC1200 Techkey] type: USB
    driver: rtw_8822bu bus-ID: 7-2:3 chip-ID: 0bda:b812
    class-ID: 0000 serial: <filter>
  IF: wlp4s0u2 state: up mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI
    mode) type: USB driver: btusb v: 0.8 bus-ID: 7-1:2
    chip-ID: 0a12:0001 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no
    software: no address: <filter>
Drives:
  Local Storage: total: 5.46 TiB used: 881.42 GiB (15.8%)
  SMART Message: Unable to run smartctl. Root
    privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung
    model: SSD 870 QVO 2TB size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate
    model: ST1000DX002-2DV162 size: 931.51 GiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC41
    scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EZBX-00AYRA0 size: 1.82 TiB block-size:
    physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 1A01
    scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate
    model: ST31000528AS size: 931.51 GiB block-size:
    physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC49
    scheme: MBR
Partition:
  ID-1: / raw-size: 195.31 GiB size: 195.31 GiB (100.00%)
    used: 19.11 GiB (9.8%) fs: btrfs dev: /dev/sda2
    maj-min: 8:2
  ID-2: /boot/efi raw-size: 512 MiB
    size: 511 MiB (99.80%) used: 608 KiB (0.1%) fs: vfat
    dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 1.61 TiB size: 1.58 TiB (98.37%)
    used: 862.3 GiB (53.2%) fs: ext4 dev: /dev/sda3
    maj-min: 8:3
  ID-4: /var/log raw-size: 195.31 GiB
    size: 195.31 GiB (100.00%) used: 19.11 GiB (9.8%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 195.31 GiB
    size: 195.31 GiB (100.00%) used: 19.11 GiB (9.8%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60)
    cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 11.4 GiB
    used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 4.88 GiB
    used: 0 KiB (0.0%) priority: -2 dev: /dev/sda4
    maj-min: 8:4
Sensors:
  System Temperatures: cpu: 30.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 256 Uptime: 19m wakeups: 11 Memory: 11.4 GiB
  used: 3.35 GiB (29.3%) Init: systemd v: 252
  default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1650 libs: 412
  tools: gnome-software,octopi,pamac,paru pm: appimage
  pkgs: 0 Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.24
Garuda (2.6.14-1):
  System install date:     2023-01-05
  Last full system update: 2023-01-10 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:

Anyone have the same problem - or solved it? I'm desparate because I need to finish a project.

This looks like an application issue.
Have you already tried looking into the KDE bug report?
Attached below is a link filtered by product "kdenlive" and containing the word "crash" (you can change the filter of course), there are a few reports which might look like yours, but you are the only one who can check the details.
https://bugs.kde.org/buglist.cgi?bug_status=__open__&content=crash&no_redirect=1&order=changeddate%20DESC%2Cpriority%2Cbug_severity&product=kdenlive&query_format=specific

1 Like

Thanks for that. Until 3 weeks ago I was working fine with Kdenlive in Linux Mint. That's why I thought it could be a Garuda issue. But I will the link.

Start kadenlive in a terminal and look at the error when it crashes.
It might help when searching

4 Likes

I also experienced the same issue today, you might find that the error is something like "Cannot mix incompatible Qt library" if you try opening via the terminal. You might find that most or all qt based apps stop launching.

I did some digging on the Arch forums and it seems the issue is almost always the qt5-stylesplugin package from the chaotic-aur. As a temporary fix I decided to just simply delete the package as that seemed to work for now, at least until there's an updated version that will work fine.

2 Likes

Well, thanks for the hint. I looked for a file with that or a similar name, but it seems I don't have it on my computer. So cannot delete it.
Incidentally, I am so GUI oriented that I don't even know how to start a program from console. DoI have tocd to a specific folder first? is it the ./ or a run command? Beleive it or not, I have never done that...

You just need to type in "kdenlive" into the console and it should throw up your error message there. If it says "Cannot mix incompatible Qt library" then try typing in "sudo pacman -Rns qt5-stylesplugin" to remove that package, everything should hopefully work then. If that is the issue then those two simple commands in the terminal should hopefully solve your problem :slight_smile:

OK, I did just that, but it seems I have another kind of problem. This is the output;

Could not detect package type, probably default? App dir is "/usr/bin"
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltrtaudio.so
  (librtaudio.so.6: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden)
profilePath from KdenliveSetting::mltPath:  "/usr/share/mlt-7/profiles"
meltPath from KdenliveSetting::rendererPath:  "/usr/bin/melt-7"
Empty metadata for  "avcolour_space"
Empty metadata for  "avcolor_space"
Empty metadata for  "avdeinterlace"
Empty metadata for  "swscale"
Empty metadata for  "swresample"
Empty metadata for  "audiochannels"
Empty metadata for  "audioconvert"
Empty metadata for  "imageconvert"
Empty metadata for  "glsl.manager"
Empty metadata for  "movit.convert"
Empty metadata for  "movit.crop"
Empty metadata for  "movit.resample"
Empty metadata for  "movit.resize"
Empty metadata for  "telecide"
Empty metadata for  "deinterlace"
plugin not available: "avfilter.acompressor"
plugin not available: "avfilter.aecho"
plugin not available: "avfilter.agate"
plugin not available: "avfilter.atadenoise"
plugin not available: "avfilter.bwdif"
plugin not available: "avfilter.deblock"
plugin not available: "avfilter.dedot"
plugin not available: "avfilter.deflate"
plugin not available: "avfilter.derain"
plugin not available: "avfilter.doubleweave"
plugin not available: "avfilter.field"
plugin not available: "avfilter.framestep"
plugin not available: "avfilter.fspp"
plugin not available: "avfilter.graphmonitor"
plugin not available: "avfilter.hqdn3d"
plugin not available: "avfilter.inflate"
plugin not available: "avfilter.lagfun"
plugin not available: "avfilter.loudnorm"
plugin not available: "avfilter.mcdeint"
plugin not available: "avfilter.random"
plugin not available: "avfilter.removegrain"
plugin not available: "avfilter.separatefields"
plugin not available: "avfilter.shuffleplanes"
plugin not available: "avfilter.sofalizer"
plugin not available: "avfilter.sr"
plugin not available: "avfilter.tmix"
plugin not available: "avfilter.w3fdif"
plugin not available: "avfilter.weave"
plugin not available: "avfilter.yadif"
plugin not available: "frei0r.baltan"
plugin not available: "frei0r.bgsubtract0r"
plugin not available: "frei0r.delay0r"
plugin not available: "frei0r.delaygrab"
plugin not available: "frei0r.lightgraffiti"
plugin not available: "frei0r.lightgraffiti"
plugin not available: "frei0r.tehRoxx0r"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "movit.unsharp_mask"
plugin not available: "timewarp"
plugin not available: "region"
=== /// CANNOT ACCESS SPEECH DICTIONARIES FOLDER
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
/////////// creatclipsfromlist (QUrl("file:///home/johann/Folders-Files Projekte/Projekt MĂĽllkippe/In 12-2022.jpg")) true "-1"
/////////// createClipFromFile "/home/johann/Folders-Files Projekte/Projekt MĂĽllkippe/In 12-2022.jpg" "-1"
=== GOT DROPPED MIME:  "image/jpeg"
/////////// final xml "<producer type=\"5\" in=\"0\" length=\"125\">\n <property name=\"resource\">/home/johann/Folders-Files Projekte/Projekt MĂĽllkippe/In 12-2022.jpg</property>\n</producer>\n"
============STARTING LOAD TASK FOR:  "/home/johann/Folders-Files Projekte/Projekt MĂĽllkippe/In 12-2022.jpg" 

:::::::::::::::::::
/////////// creatclipsfromlist return false
################### ProjectClip::setproducer #################
################### ClipController::updateProducer
################### ClipController::addmasterproducer
===== 
READY FOR THUMB ClipType::Image 

=========
=======

SETTING AUDIO DATA IN MON
===== 
SEEKING THUMB PROD

=========
=== GOT THUMB FOR:  -1 x -1

end of output.
With that, it stands still. Obviously tries to do something it cannot do. Bt as I only tried tp load one jpg file, it's not that the program could be busy loading it. What I see in that output, and in the program, is that it gets stuck trying to create the thumbnail for the object Iimported.
But judging by the long list of problems my install is really a wreck. So with that command you gave me above I will erase it, and also look for some config files that needs to get eliminated.
Then I will retry to install it. I have seen that there are different versions. Kdenlive, kdenlive-git, Kdenlive appimage. And from what you wrote above, I should try not to install a version from chaotic-aur?
In the meantime I also tried, if I could install Kdenlive in a Garuda live version, running from USB installation ISO. But that also didn't work. The installation went through with hundred of errors, and the app was available in the App Launcher. But it wouldn't even start. From this experience I take that I will watch carefully what errors I get during the installation process. If I can get it, I will post that log here afterwards.

This stuck out to me: mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltrtaudio.so

I'm not an expert on this stuff as I still consider myself new to the Linux world also, but it seems your problem is definitely different to the one I had as it looks like you're missing a package/dependency or something. Though I'm honestly not sure what mlt-7 is myself, but chances are that's your cultprit and will help you narrow things down. For now, it might be best to search around the KDE/Kdenlive forums and see if anyone else has found a solution to this problem as I'm sure others have stumbled into this same issue. If not then signing up to troubleshoot your issue with the folks there to hopefully get it fixed.

Until then you're in some luck, you can download and enable flatpak and use the flatpak version of kdenlive, which will have all the dependencies it needs packed into the application itself so it can run perfectly out of the box. That should be a good temporary solution, here's a quick guide on how to set that up.

And then after those instructions you can install the flatpak version of kdenlive in your software manager, if it supports flatpak. If not then just type into the terminal "flatpak install kdenlive", go through the process and once it's downloaded you can get to work :slight_smile: You'll need flatseal to have apps access other drives, if your video files are in an external one. But if they're on the same drive as your Linux install then you can skip flatseal entirely.

Hopefully this will be a decent temporary solution until you can get the normal repo version of kdenlive fixed :+1:

Ok great! While I don't understand why this (according to the name) sound oriented dependency should interfere with the creation of a thumbnail, maybe it IS the issue. I'll follow up on any clues the console output gives.
As ro flatpack: I was told, flatpacks are "not supported" in Garuda, so hopefully I will not create other problems? Actually I was thinking of flats already, exactly because the bring all their dependencies with them.

It definitely seems to be the cause for sure, and hopefully an easily fixable problem. But like I said, if you need more support on the issue then going to the KDE/Kdenlive forums should help immensely :+1:

I believe unsupported just means Garuda doesn't have flatpak enabled out of the box, nor do the team provide support for them if anything goes wrong as it's outside of their wheelhouse. But you can still use them perfectly fine once you set it up, just like any other Linux distro, and the chances of flatpak apps breaking is very low :slight_smile:

1 Like

Some weeks ago I posted the question if it's ok to do a Semi-Clean install by leaving the /home partition unchanged. Someone said: Yes, works fine, but you might need to clean some of the config files if stuff doesn't work. This could be the case here ... und also with another app that's giving me problems: IDrive Online Backup.
So I will try to find all entries in my /home referring to kdenlive and delete them before I reinstall it.
And Flatpacks are actually quite good, sometimes better than AppImages.

Oh well, nothing helps. I have cleaned the machine completely, insalled the flatpak, but absolutely no change. I can start the app, everzthing looks fine until I try to add a file to the projects tray. Whenthe file is half loaded, i.e. the thumbnail shoud be produced (and then the loading process really finishes, the window freezes. at the last moment it show2s half a screen with the heading Warning Kdenlive, but no content in that warning. The app window then cannot be closed. When zou close it, it fives the message that the program is not responing, but youcan only close it via the systemmonitor, kill the process.
This is getting really annoying...
The console output is the same inthe bottom part:

profilePath from appDir/../share:  "/app/share/mlt-7/profiles"
meltPath from KdenliveSetting::rendererPath:  "/app/bin/melt"
Empty metadata for  "avcolour_space"
Empty metadata for  "avcolor_space"
Empty metadata for  "avdeinterlace"
Empty metadata for  "swscale"
Empty metadata for  "swresample"
Empty metadata for  "audiochannels"
Empty metadata for  "audioconvert"
Empty metadata for  "imageconvert"
Empty metadata for  "glsl.manager"
Empty metadata for  "movit.convert"
Empty metadata for  "movit.crop"
Empty metadata for  "movit.resample"
Empty metadata for  "movit.resize"
Empty metadata for  "telecide"
Empty metadata for  "deinterlace"
plugin not available: "avfilter.acompressor"
plugin not available: "avfilter.aecho"
plugin not available: "avfilter.agate"
plugin not available: "avfilter.atadenoise"
plugin not available: "avfilter.bs2b"
plugin not available: "avfilter.bwdif"
plugin not available: "avfilter.deblock"
plugin not available: "avfilter.dedot"
plugin not available: "avfilter.deflate"
plugin not available: "avfilter.derain"
plugin not available: "avfilter.doubleweave"
plugin not available: "avfilter.field"
plugin not available: "avfilter.framestep"
plugin not available: "avfilter.fspp"
plugin not available: "avfilter.graphmonitor"
plugin not available: "avfilter.hqdn3d"
plugin not available: "avfilter.inflate"
plugin not available: "avfilter.lagfun"
plugin not available: "avfilter.loudnorm"
plugin not available: "avfilter.random"
plugin not available: "avfilter.removegrain"
plugin not available: "avfilter.separatefields"
plugin not available: "avfilter.shuffleplanes"
plugin not available: "avfilter.sofalizer"
plugin not available: "avfilter.sr"
plugin not available: "avfilter.tmix"
plugin not available: "avfilter.w3fdif"
plugin not available: "avfilter.weave"
plugin not available: "avfilter.yadif"
plugin not available: "frei0r.baltan"
plugin not available: "frei0r.bgsubtract0r"
plugin not available: "frei0r.bigsh0t_eq_to_stereo"
plugin not available: "frei0r.delay0r"
plugin not available: "frei0r.delaygrab"
plugin not available: "frei0r.facebl0r"
plugin not available: "frei0r.facedetect"
plugin not available: "frei0r.lightgraffiti"
plugin not available: "frei0r.lightgraffiti"
plugin not available: "frei0r.tehRoxx0r"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "ladspa"
plugin not available: "movit.unsharp_mask"
plugin not available: "timewarp"
plugin not available: "region"
=== /// CANNOT ACCESS SPEECH DICTIONARIES FOLDER
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QGradient::setColorAt: Color position must be specified in the range 0 to 1
QGradient::setColorAt: Color position must be specified in the range 0 to 1
QGradient::setColorAt: Color position must be specified in the range 0 to 1
:::: USING TRACK COMPOSITING:  "frei0r.cairoblend"
QQmlEngine::setContextForObject(): Object already has a QQmlContext
:::: USING TRACK COMPOSITING:  "frei0r.cairoblend"
:::: USING TRACK COMPOSITING:  "frei0r.cairoblend"
:::: USING TRACK COMPOSITING:  "frei0r.cairoblend"
/////////// starting to add bin clips
kf.kio.widgets.kdirmodel: No node found for item that was just removed: QUrl("file:///home/johann/Videos/desktop.ini")
kf.kio.widgets: Cannot read information about filesystem under path "/home/johann/.var/app/org.kde.kdenlive/cache/thumbnails/"
/////////// found list (QUrl("file:///home/johann/Videos/Bildschirmaufnahme 2022-12-27 20:40:17.mp4"))
/////////// creatclipsfromlist (QUrl("file:///home/johann/Videos/Bildschirmaufnahme 2022-12-27 20:40:17.mp4")) true "-1"
virtual QStringList Solid::Backends::UPower::UPowerManager::allDevices()  error:  "org.freedesktop.DBus.Error.ServiceUnknown"
virtual QStringList Solid::Backends::UPower::UPowerManager::allDevices()  error:  "org.freedesktop.DBus.Error.ServiceUnknown"
/////////// createClipFromFile "/home/johann/Videos/Bildschirmaufnahme 2022-12-27 20:40:17.mp4" "-1"
=== GOT DROPPED MIME:  "video/mp4"
/////////// final xml "<producer>\n <property name=\"resource\">/home/johann/Videos/Bildschirmaufnahme 2022-12-27 20:40:17.mp4</property>\n</producer>\n"
============STARTING LOAD TASK FOR:  "/home/johann/Videos/Bildschirmaufnahme 2022-12-27 20:40:17.mp4" 

:::::::::::::::::::
/////////// creatclipsfromlist return false
################### ProjectClip::setproducer #################
################### ClipController::updateProducer
################### ClipController::addmasterproducer
===== 
READY FOR THUMB ClipType::Video 

=========
===== 
SEEKING THUMB PROD

=========
=======

SETTING AUDIO DATA IN MON
=== GOT THUMB FOR:  -1 x -1

Not sure what's going on there, could it be one of your videos are corrupted? Do they open fine in VLC/MPV? Could try recording another video to see how that goes down.

I cannot import anything. No jpg, no mp4. And all those files are fine in other programs :person_gesturing_no:

It look not nice in i3 but it works

There are many things missing in your log file, did you try a re-installation? Delete your kdenlive cache, settings ...

2 Likes

I tried all kinds of installs from different repos, with Appimage, Snap and Flatpack. Allways cleaning up in-between. But to no avail. That error is persistent.
As this program is essential for me, I tried Fedora in a Virtual Machine: works perfectly.
So I guess I will switch to Fedora. With lots of regrets. A like Garuda and I have a lot of time into customizing my desktop. But I have 3 issues I don't want to spend more time on: Kdenlive. Audio. IDrive. None will work properly or at all. At some point in time I need a fully functional system for my needs.
I will wait a bit if I get some hints in the KDE/Kdenlive bugzilla. But I don't expect much, so it will be good bye here. Best wishes to all!

Seems it is not a Garuda Linux Problem :slight_smile:

We say all the times to all users, use pacman.

╭─[email protected] in ~ took 1m36s
đź•™ 15:55:25
╰─λ sudo pacman -Syu kdenlive
:: Paketdatenbanken werden synchronisiert …
garuda ist aktuell
core ist aktuell
extra ist aktuell
community                       7,2 MiB  18,1 MiB/s 00:00 [-------------------------------] 100%
multilib ist aktuell
chaotic-aur                     2,2 MiB  2,67 MiB/s 00:01 [-------------------------------] 100%
:: Vollständige Systemaktualisierung wird gestartet …
Warnung: garuda-fastfetch-git: Lokale Version (1.5.5.r289.ge6447c3-1) ist neuer als garuda (r1727.bfeaf0d-1)
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Pakete (6) frei0r-plugins-2.2.0-1  gavl-1.4.0-6  libebur128-1.2.6-1  mlt-7.12.0-2
qt5-networkauth-5.15.8-1  kdenlive-22.12.1-1

Gesamtgröße des Downloads:             21,89 MiB
Gesamtgröße der installierten Pakete:  89,95 MiB

:: Installation fortsetzen? [J/n]
:: Pakete werden empfangen …
libebur128-1.2.6-1-x86_64      17,1 KiB   132 KiB/s 00:00 [-------------------------------] 100%
qt5-networkauth-5.15.8-1...    67,0 KiB   394 KiB/s 00:00 [-------------------------------] 100%
frei0r-plugins-2.2.0-1-x...   412,4 KiB  1718 KiB/s 00:00 [-------------------------------] 100%
mlt-7.12.0-2-x86_64          1516,8 KiB  5,22 MiB/s 00:00 [-------------------------------] 100%
gavl-1.4.0-6-x86_64             4,1 MiB  11,8 MiB/s 00:00 [-------------------------------] 100%
kdenlive-22.12.1-1-x86_64      15,8 MiB  23,9 MiB/s 00:01 [-------------------------------] 100%
Gesamt (6/6)                   21,9 MiB  27,1 MiB/s 00:01 [-------------------------------] 100%
(6/6) SchlĂĽssel im SchlĂĽsselbund werden geprĂĽft            [-------------------------------] 100%
(6/6) Paket-Integrität wird überprüft                      [-------------------------------] 100%
(6/6) Paket-Dateien werden geladen                         [-------------------------------] 100%
(6/6) Auf Dateikonflikte wird geprĂĽft                      [-------------------------------] 100%
:: Pre-transaction-Hooks werden gestartet …
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 260
:: Paketänderungen werden verarbeitet …
(1/6) Installiert wird qt5-networkauth                     [-------------------------------] 100%
(2/6) Installiert wird libebur128                          [-------------------------------] 100%
(3/6) Installiert wird mlt                                 [-------------------------------] 100%
Optionale Abhängigkeiten für mlt
sdl_image: SDL1 plugin [Installiert]
sdl2: SDL2 plugin [Installiert]
libsamplerate: libavresample plugin [Installiert]
sox: SOX (Audio Swiss Army Knife) plugin
ffmpeg: ffmpeg plugin [Installiert]
vid.stab: video stabilize plugin [Installiert]
qt5-svg: Qt5 plugins [Installiert]
jack: JACK sound output plugin [Installiert]
ladspa: LADSPA plugins
libexif: auto rotate plugin [Installiert]
frei0r-plugins: for additional effects [ausstehend]
movit: opengl plugin
opencv: openCV plugin
rubberband: audio pitch plugin [Installiert]
gdk-pixbuf2: gdk plugin [Installiert]
pango: gdk plugin [Installiert]
rtaudio: rtaudio plugin
python: python bindings [Installiert]
(4/6) Installiert wird gavl                                [-------------------------------] 100%
(5/6) Installiert wird frei0r-plugins                      [-------------------------------] 100%
Optionale Abhängigkeiten für frei0r-plugins
opencv: for facebl0r and facedetect plugins
(6/6) Installiert wird kdenlive                            [-------------------------------] 100%
Optionale Abhängigkeiten für kdenlive
ffmpeg: for FFmpeg plugin [Installiert]
dvgrab: for firewire capture
recordmydesktop: for screen capture
opencv: for motion tracking
plasma-desktop: theme configuration [Installiert]
opentimelineio: timeline export/import
bigsh0t: VR360 effects
mediainfo: for technical clip information
noise-suppression-for-voice: noise suppression effect
3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.