Kde wallet pop up every time when i open any app

it is so annoying that the kde wallet service pop up every time disturbs me.
please help me , how can i turn it off

For all issues, please post the output of garuda-inxi as requested by the template.

If you set up KDE Wallet correctly, it does behave the way you describe. KDE Wallet - ArchWiki

If you don't want to use it then uninstall it.

sudo pacman -Rsu kwallet kwalletmanager ksshaskpass kwallet-pam

This might a few disadvantages though as some packages rely on a secret management service to store their passwords. On the other hand, keepassxc might also be used to store them.


I agree, it can be just as much of a nuisance to have no secret manager at all. If you have a browser you are logged in to, for example, it may start asking you to sign in manually every time. Fun stuff like that. :stuck_out_tongue_winking_eye:


This may or may not work, but it's an old hack I have used in Arch for a few years. Anyway I always install the package gnome-keyring in KDE and never experience any Kwallet popups at all unless I auto-login, and I think then only once (I never auto-login anymore).


System Settings/KDE Wallet/Access Coontrol, top checkbox "Prompt when an application accesses a wallet".


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.