KDE top panel widgets overlap

I noticed Whenever a widget changes its size, other widgets stay as it is and as a result they overlap.
The overlap is mostly seen when window buttons try to display when a window is maximized. But other widgets stay at their places and buttons overlap with existing widgets.
The same behavior is seen with all widgets. I had to manually add empty spaces at their places. But I cannot add space here.

I tried to search for it on google but I only got one old bug report https://bugs.kde.org/show_bug.cgi?id=438370

My inxi

Kernel: 6.4.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3a445deb-99ca-468a-abea-361e909fa4bd rw rootflags=subvol=@
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: HP product: HP Laptop 15s-fq5xxx v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 8A20 v: 20.19 serial: <superuser required> UEFI: AMI
v: F.17 date: 10/20/2022
ID-1: BAT0 charge: 22.5 Wh (63.7%) condition: 35.3/41.0 Wh (86.1%)
volts: 11.5 min: 11.4 model: HP Primary type: Li-ion serial: <filter>
status: discharging cycles: 71
Info: model: 12th Gen Intel Core i5-1235U bits: 64 type: MST AMCP
arch: Alder Lake level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 4
microcode: 0x42A
Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 1809 high: 2500 min/max: 400/4400:3300 scaling:
driver: intel_pstate governor: powersave cores: 1: 2500 2: 935 3: 800
4: 2500 5: 2500 6: 2500 7: 2500 8: 2500 9: 805 10: 661 11: 1016 12: 2500
bogomips: 59904
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics]
vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen-12.2
process: Intel 10nm built: 2021-22+ ports: active: eDP-1 empty: DP-1,
DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:46a8
class-ID: 0300
Device-2: Quanta HP TrueVision HD Camera driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:3 chip-ID: 0408:536c
class-ID: 0e02 serial: <filter>
Display: wayland server: X.org v: with: Xwayland v: 23.1.2
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 23.1.4 renderer: Mesa Intel Graphics (ADL GT2)
direct-render: Yes
Device-1: Intel Alder Lake PCH-P High Definition Audio
vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:51c8 class-ID: 0401
API: ALSA v: k6.4.6-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.75 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8822ce v: N/A modules: rtw88_8822ce
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.0
chip-ID: 10ec:c822 class-ID: 0280
IF: wlo1 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 0bda:b00c
class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: no
address: <filter>
Local Storage: total: 476.94 GiB used: 92.91 GiB (19.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZH
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: HPS1 temp: 27.9 C scheme: GPT
ID-1: / raw-size: 56.59 GiB size: 56.59 GiB (100.00%)
used: 14.22 GiB (25.1%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 580 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p8 maj-min: 259:8
ID-3: /home raw-size: 144.14 GiB size: 144.14 GiB (100.00%)
used: 78.69 GiB (54.6%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-4: /var/log raw-size: 56.59 GiB size: 56.59 GiB (100.00%)
used: 14.22 GiB (25.1%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 56.59 GiB size: 56.59 GiB (100.00%)
used: 14.22 GiB (25.1%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.44 GiB used: 75.5 MiB (1.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 57.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 313 Uptime: 40m wakeups: 2131 Memory: total: 8 GiB note: est.
available: 7.44 GiB used: 4.6 GiB (61.8%) Init: systemd v: 253
default: graphical tool: systemctl Compilers: gcc: 13.1.1 Packages:
pm: pacman pkgs: 1735 libs: 510 tools: pamac,paru pm: flatpak pkgs: 0
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-07-25
Last full system update: 2023-07-27
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:


So its just the margin with the Window Buttons that is left to tackle?
Right click the buttons, then select Configure Window Buttons.
In the General section at the bottom there are margin settings. Click the padlock so it turns green so you can just adjust one of its margins. That way you can edit the right margin to your liking.


This is probably because you are displaying the Application Icon besides the Application Name, from the Window Title widget.

This is not Garuda default, so you have to play around with the margins as @Kayo suggested. It should work as I tested the Application Icon many times before, but let's see how yours come up first.

I just re-tested it without changing the defaults and works well, same resolution as you, 1920x1080.

But what does that mean exactly? More screenshots plz?

It appears the spacing was problem. I removed spacing. Now it is working just fine.

Also I forgot to mention Every time the widgets overlap, If I right click, go to edit mode and then exit, All widgets get alligned correctly.

This was my layout

Thanks @FGD and @Kayo for prompt reply.

But what does that mean exactly? More screenshots plz?

Network plugin also used to get overlapped


It broke again. Here is complete video. At first no buttons are seen. Then if i click edit layout, it starts to work temporarily. Same problem occurs when another window comes in front that is not maximized

I think I see what's going on, tnx for the video cuz otherwise it's very hard to grasp.
I believe it has to do with how many widgets you got in the bar and how wide space they use in certain situations, plus you got some dynamic spacers too which could alter the end result.

Your screen is 1920 wide, which seems small for how much space all your widgets can use.

I came across that issue a while back, not too sure how the widgets manage this but when a widget needs space in the bar, it claims it and sometimes overlaps with other widgets or pushes them away. Some other times it truncates and you don't see the full widget. It depends how each widget manages the dynamic space and which one wins the space claimed.

There are 2 easy ways I can think of to see if that's the issue:

  • Increase your resolution (assuming your monitor can take it - that is the best test possible if you can do it)
  • Remove widgets ONE BY ONE until you no longer see the overlap (start with the Clock on the right side, it's pretty wide to begin with)

The above tests will not fix permanently your issue, unless you accept a different screen resolution or less widgets, but usually we don't!! It's more to pinpoint whether my theory is true or not. If it is, the solution might be a compromise, cuz your monitor resolution physically limits the total potential space used by all your widgets. That is my theory at the moment.


I think I found the real culprit.
It was that sensor plugin that I had setup for monitering upload and download speed.
As @FGD mentioned, dynamically allocating widgets were causing this problem. I removed them both. Now everything works fine.
Thanks, @FGD

1 Like

Awesome!! :smiley:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.