KDE Plasma Desktop is Locked For Editing and I can't unlock it

I have gotten past all sorts of issues today in installing Garuda, and am very pleased with it. Ironically however this seemingly simple problem has stumped me. I cannot add widgets to the desktop or make changes. When I right-click on the desktop the "Enter Edit Mode" option is greyed out and I cannot figure how to unlock it to enter edit mode.

Can someone give me a hint? Thank you!

1 Like

Thank god I found it! Hope this helps someone else:

Lock Widgets

Plasma 5.18 and above has hidden the “lock widgets” toggle. It’s very easy to enter “edit mode” with a long press. If you want to get the old locked mode behavior, run the following command:

qdbus org.kde.plasmashell /PlasmaShell evaluateScript 'lockCorona(!locked)'

If you want an easier way to toggle locking widgets in Plasma 5.18, install Win7ShowDesktop widget which has a “Lock Widgets” toggle in it’s right click menu.|

2 Likes

Nice find, props to you for being so proactive on finding your own solution.

Also, a big welcome to the Garuda forum. :beers:

I marked your thread solved for you (simply add check mark at bottom)

2 Likes

Thank you! I am very pleased with Garuda so far! Been thinking of moving to Arch for a while but we never sure which door to take til I found this one. This distro should take off like a rocket. Good luck!

2 Likes

Also I want to say - I have no clue what they are talking about with "long press" on a non-touchscreen computer. Absolutely nothing worked to get into edit mode on the desktop until I found that tip listed above. Something seems very amiss at KDE if they think that this behavior isn't going to cause a LOT of questions with people who want to add new widgets.

I guess they fixed the issue in kde 5.20. So updating may be useful, as I get edit mode on right click menu.

4 Likes