KDE Plasma Crashes when adding lxc container with "lxc.mount.auto=proc:rw sys:rw"

I've started using Garuda Linux with Plasma 5.21.1 and kernel 5.11.2-zen1-1-zen

I create a new lxc container this way:

sudo lxc-create -t ubuntu -n u1 -- -r focal

Then, I add to the container config file "lxc.mount.auto=proc:rw sys:rw". After that I start the container and KDE/Plasma crashes. The container starts, but when I login again, Plasma is quite unstable and unusable. Is there any kind of incompatibilities between privileged LXC Containers and Plasma?

You'd be better checking the upstream bug trackers for that - Garuda doesn't maintain either.

Always worth trying a different kernel to check if it's kernel-related., e.g. try both linux and linux-lts.

3 Likes

Thank you. I've tried different kernels (LTS and Zen) as you suggest, and I've also tried to start the container in XFS and EXT4 filesystems, Outside my root FS in a different partition and that makes no difference. The problem seems to be "sys:rw". If use sys:ro or sys:mixed, the container starts without problems, however, this is not enough for my needs.

The container starts, but Plasma crashes even if I start the container in a different TTY (ctrl+alt+F2). If I'm not logged in Plasma, KDM also crashes.

1 Like

Ok. Finally I've got it. It was simpler than I thought. Basically, Garuda Linux forces in /etc/default/grub the option: systemd.unified_cgroup_hierarchy=1

The solution is changing that to 0, update-grub and restart.

4 Likes

This is likely a bug in LXC, i.e. it doesn't support cgroup2 yet. In contrast, Docker added support for cgroup2, e.g.:

Also have a look at e.g.

https://wiki.debian.org/LXC/CGroupV2

and

https://wiki.archlinux.org/index.php/Linux_Containers#Incompatibility_with_linux_kernel_5.10.0

2 Likes

Maybe. The only reason of trying this is to run containers (mainly docker) inside LXC -- Mainly to have a Testing and disposable environments for each kubernetes and Openstack (kolla). I'll keep an eye on your links and follow this possible bug of LXC in private. Thank you very much for your support.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.