KDE Plasma crashed and doesn't start again even after reboot

I'm using the Garuda KDE Dragonized and all of sudden randomly KDE Plasma crashed and doesn't want to work again. When I try to use the "kstart5 plasmashell" in tty I get the error:

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb,  minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

zsh: IOT instruction sudo kstart5 plasmashell

When I reboot I see the login screen and it works fine but after logging in I can only see my cursor and nothing else happens.

Somehow managed to get the garuda-inxi output into a file then move it onto drive than Windows is able to read:

  Kernel: 6.4.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=4de138a4-b46f-4c97-b1e6-f20e3baa20da
    rw rootflags=subvol=@ quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=7d1ff86f-8e16-4212-b931-39bebd0dd592 loglevel=3 ibt=off
  Console: tty 3 DM: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7B17 v: 2.0 serial: <superuser required>
  Mobo: Micro-Star model: MPG Z390 GAMING EDGE AC (MS-7B17) v: 2.0 serial: <superuser required>
    UEFI: American Megatrends v: A.B0 date: 10/12/2020
  Info: model: Intel Core i7-9700KF bits: 64 type: MCP arch: Coffee Lake gen: core 9 level: v3
    note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xC (12)
    microcode: 0xF2
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB
    L2: 2 MiB desc: 8x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3600 min/max: 800/4900 scaling: driver: intel_pstate governor: powersave
    cores: 1: 3600 2: 3600 3: 3600 4: 3600 5: 3600 6: 3600 7: 3600 8: 3600 bogomips: 57600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: ASUSTeK driver: nvidia v: 535.86.05
    alternate: nouveau,nvidia_drm non-free: 535.xx+ status: current (as of 2023-07) arch: Turing
    code: TUxxx process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1e84 class-ID: 0300
  Display: server: X.org v: with: Xwayland v: 23.1.2 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa gpu: nvidia tty: 102x38
  API: OpenGL Message: GL data unavailable in console. Try -G --display
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU104 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f8
    class-ID: 0403
  API: ALSA v: k6.4.6-zen1-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.75 status: active with: 1: pipewire-pulse status: off 2: wireplumber
    status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno2 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:7 chip-ID: 8087:0aaa class-ID: e001
  Report: bt-adapter ID: hci1 rfk-id: 1 state: up address: N/A
  Device-2: Edimax Bluetooth Adapter driver: btusb v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-9:5 chip-ID: 7392:c611 class-ID: e001 serial: <filter>
  Report: ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 3.92 TiB used: 3.38 TiB (86.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB1T0HBLR-00000 size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: EXF7201Q temp: 39.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: SanDisk model: ADATA SX6000PNP size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: V9002s09 temp: 35.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 2TB size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 2B6Q
    scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 PRO 256GB size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 1B6Q scheme: MBR
  ID-1: / raw-size: 936.46 GiB size: 936.46 GiB (100.00%) used: 633.5 GiB (67.6%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 580 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 936.46 GiB size: 936.46 GiB (100.00%) used: 633.5 GiB (67.6%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 936.46 GiB size: 936.46 GiB (100.00%) used: 633.5 GiB (67.6%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 936.46 GiB size: 936.46 GiB (100.00%) used: 633.5 GiB (67.6%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.55 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.11 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 37.0 C pch: 52.0 C mobo: N/A gpu: nvidia temp: 35 C
  Fan Speeds (RPM): N/A
  Processes: 287 Uptime: 1m wakeups: 1 Memory: total: 16 GiB available: 15.55 GiB
  used: 1.62 GiB (10.4%) Init: systemd v: 253 default: graphical tool: systemctl Compilers:
  gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman pkgs: 2106 libs: 566 tools: octopi,pamac,paru
  Shell: Zsh v: 5.9 running-in: tty 3 inxi: 3.3.28
Garuda (2.6.16-1):
  System install date:     2023-05-09
  Last full system update: 2023-07-26
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            



Or, if you have enabled Wayland:


Both didn't help, and both give errors.

startplasma-x11 gives this error:

$DISPLAY is not set or cannot connect to the X server.

And startplasma-wayland gives this error

Error: could not determine $DISPLAY.
Error: Can not contact kdeinit5!
org.kde.startup: "kdeinit5_shutdown" () exited with code 255
startplasma-wayland: Shutting down...
startplasmacompositor: Shutting down...
startplasmacompositor: Done.

I wasn't tinkering with anything as I'm using OOB settings mostly, it just happened randomly. At the time it crashed I had Firefox, 2 KCalcs, Kate, Steam and Discord opened. I had KDE Plasma crashes before but usually reboot was enough to fix it.

Have you tried restoring the latest working snapshot?
If you can boot onto a working snapshot, restore it and reboot.
Then, I'd try again a:


If you get the same problem, you should restore again and start checking the updated packages (or wait a little bit before the next update).
If restoring doesn't work in the first place, you could boot to a tty, create a new user and check if you can then log-in with it.


I've booted the oldest available snapshot which is from 25.07.2023 but the issue persists.

I've tried the startplasma commands with sudo, but it only gave me new error messages.

sudo startplasma-x11 returned:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
$DISPLAY is not set or cannot connect to the X server.

And sudo startplasma-wayland returned:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
startplasmacompositor: Could not start D-Bus. Can you call qdbus?

I'm able to login on my account in SDDM (that login screen) but after that I have only cursor on screen. No KDE Plasma shortcuts work, no KDE Plasma panels show up. I'm able to log in tty after switching to it by CTRL+ALT+F3, that's how I'm trying to use those startplasma commands.

EDIT: All right I've diagnosed the issue wrongly. The shortcuts work, I was able to launch the console via the CTRL+ALT+T and launch Firefox via it. But still I have no wallpaper and no panels and clicking on the black background does nothing.

Use live ISO, garuda-assistant, chroot, garuda-update.


Can you launch Krunner (shortcuts should be alt+space or alt+F2) and then System Settings?
From there, you could try re-applying the Dr460nized theme.
You could also try restarting Plasma with:

kquitapp5 plasmashell && kstart5 plasmashell

and kWin with:

qdbus org.kde.KWin /KWin reconfigure

But I still believe that creating a new user could be an option, since probably something went corrupted in your home settings for KDE.


garuda-assistant → restore config → all


On new user everything works fine.
garuda-assisant -> Restore config -> all haven't fixed the issue on my main user.

The qdbus org.kde.KWin /KWin reconfigure returned error:

Service 'org.kde.KWin' does not exist.

And while everything seems to be working fine on a new user, I'm not a fan of reconfiguring every single program every time KDE Plasma decides to randomly break for no apparent reason.

I know, KDE can be irritating at times, but we (Garuda) can't help it.
You could manually reset some of the old user's configurations. Unfortunately, I am not in front of the system and cannot try to go into details.
I would boot to a TTY with the old user (do not boot normal and then switch to tty, because it is better if KDE is not running).
Most of the configurations are located in ~/.config, but I think you reset those with Garuda Assistant.
So I would try something like:

mv ~/.kde4 ~/.kde4.old

Reboot and see how it goes. If not helping, restore ~/.kde4.old to ~/.kde4.
However, this is a good example of the importance of having regular backups (not snapshots) of the home folder.


I've removed (or rather renamed, but the end effect is the same) the file


And the desktop started working again. All my customisations are gone, but it works again at least. I could paste the broken config file here, but I doubt it would be of use to anyone.

Turned out that the source of the issue was the plugin "Wallpaper Engine for Kde" especially the line:


In the file


When I tried to play that video with mpv, the mpv crashed. Once I changed it to point to other video everything has been fixed. That's a pretty weird issue. I guess that's what I get for having over 500 Wallpaper Engine wallpapers...

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.