KDE crashs with new updates

System info is:

System:
Kernel: 5.18.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=13d64b3c-5c91-40e9-80ab-1ba442868878 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: Apple product: MacBookAir7,1 v: 1.0 serial: <filter>
Chassis: type: 9 v: Mac-9F18E312C5C2BF0B serial: <filter>
Mobo: Apple model: Mac-9F18E312C5C2BF0B v: MacBookAir7,1 serial: <filter>
UEFI: Apple v: 430.120.6.0.0 date: 03/16/2022
Battery:
ID-1: BAT0 charge: 33.6 Wh (97.1%) condition: 34.6/38.8 Wh (89.3%)
volts: 8.4 min: 7.6 model: SMP bq20z451 type: Li-ion serial: N/A
status: full cycles: 313
CPU:
Info: model: Intel Core i5-5250U socket: BGA1168 (U3E1) note: check
bits: 64 type: MT MCP arch: Broadwell gen: core 5 built: 2015-18
process: Intel 14nm family: 6 model-id: 0x3D (61) stepping: 4
microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1237 high: 1600 min/max: 500/2700 base/boost: 2500/1600
scaling: driver: intel_cpufreq governor: schedutil volts: 0.9 V
ext-clock: 25 MHz cores: 1: 1139 2: 1026 3: 1186 4: 1600 bogomips: 12799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 6000 vendor: Apple driver: i915 v: kernel
arch: Gen8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1626
class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: Apple Color LCD built: 2011 res: 1366x768 hz: 60
dpi: 136 gamma: 1.2 size: 256x144mm (10.08x5.67") diag: 294mm (11.6")
ratio: 16:9 modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 6000 (BDW GT3)
v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480
Sound Server-1: ALSA v: k5.18.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.54 running: yes
Network:
Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb
v: 0.8 bus-ID: 1-3.3:7 chip-ID: 05ac:828f class-ID: fe01
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 113 GiB used: 20.04 GiB (17.7%)
ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SD0128F
family: SD/SM/TS...E/F/G SSDs size: 113 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.0 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 821 temp: 74 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 100d 19h cycles: 23008
Partition:
ID-1: / raw-size: 112.7 GiB size: 112.7 GiB (100.00%)
used: 20.04 GiB (17.8%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 112.7 GiB size: 112.7 GiB (100.00%)
used: 20.04 GiB (17.8%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 112.7 GiB size: 112.7 GiB (100.00%)
used: 20.04 GiB (17.8%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 112.7 GiB size: 112.7 GiB (100.00%)
used: 20.04 GiB (17.8%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.74 GiB used: 691 MiB (18.1%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 73.0 C pch: 75.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 226 Uptime: 21m wakeups: 2 Memory: 3.74 GiB
used: 2.69 GiB (71.9%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1398 lib: 335
Shell: Bash (sudo) v: 5.1.16 running-in: konsole inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-07-07
Last full system update: 2022-07-08 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

so the issue is no matter what i do the "pacman -Syu" update breaks to much.. no errors just breaks after reboot..

so here is one of the issues: when u click on wifi, there is a big cap into the wifi and the enter wifi password... also the image are not the same, the icon shows up pink??? where u logout ur user name at the right corner area

next the style - i can't change it at all if i do the KDE will crash and loop into loop mode with docker and header docker

now i can roll back before where its good, but i can't use update or install any app due to it will auto update and break even more.. so anyone have update on when they can fix this???

garuda-update

Is used now instead of pacman -Syu

1 Like

Ah well I mean it’s any update that I do just breaks it —- the only way that won’t break is if I don’t update it at all, so am not sure what’s the best way to fix it :confused:

You tried typing garuda-update and it still breaks?
If yes can we see the entire output of that break after issuing garuda-update?

3 Likes

Or, if the update passed successfully but the system broke at the subsequent login, it would be important to start checking your pacman.log, retrieving the list of packages which were installed/upgraded/removed today.

2 Likes

I will try it again and let u know —- and thanks u guy for the support :slight_smile:

so after using the garuda-update, its a same issue, i will post the log shorty, just trying to find on how to haha :smiley:

Here is the pacman.log

https://bin.garudalinux.org/?1d5db44dac6be22e#8UVKuqEvn32ixiihxdTzz4XYZuheVGWZid1JYDAxJzqV

one of the issue is the wi-fi on how it's not normal way looking..

as u can see the blank black or gray box is somehow there, before it was not.. making the box larger and not in a normal way..

now if i use a another style ( such as white - it will be fine? )
also if i change the theme - the theme will loop into error mode where i can't access the desktop at all.. kinda like frozen workspace... but it will hang and then bring up noting but a black screen into black wallpaper.. then noting, no docker, or anything..

Don't worry about the black bar in Network Manager applet, this is a known issue that Garuda Team has raised to whoever, or Garuda Team will try to fix it downstream.
There is a thread here about this but I can't find it! I wonder if was something brought in off topic into a different one...

[2022-07-08T12:45:45-0400] [ALPM] running '70-dkms-install.hook'...
[2022-07-08T12:45:45-0400] [ALPM-SCRIPTLET] ==> dkms install --no-depmod broadcom-wl/6.30.223.271 -k 5.18.9-zen1-1-zen
[2022-07-08T12:45:50-0400] [ALPM-SCRIPTLET] /usr/bin/dkms: line 1033: sha512: command not found

Maybe you are missing a dkms package or something?
I'm not an expert much on this I'd need to play around just like you to get it on my machine if I ever encounter this, so my guess is I would give you a bunch of false advices until I get lucky and find the right one. loll Not good.

2 Likes

the funny thing is the ```
[2022-07-08T12:45:45-0400] [ALPM-SCRIPTLET] ==> dkms install --no-depmod broadcom-wl/6.30.223.271 -k 5.18.9-zen1-1-zen -- is not install by dkms but the main wl is working just fine lol...

but my main issue is the loops on any type of theme i use does not work.. just blacks out..

to get wl working i just had it auto see it, but if not use "yay broadcom-wl"

and then pick (1)

then it should work good, -- on gardua it works with wl just great..

Yeah that's a huge update log and yes there seems to be some loops in there.

It's beyond me, I hope some "update" pros can suggest something...

This issue was already reported at the themes issue tracker, it started occuring lately. You might have updated Plasma to the version which broke it.

About the other issue: can't reproduce it locally.

1 Like

dang, haha u would think they would try-before releasing it haha

anyhow thank you for this report

so i found something

Kwayland with Kwin <--- i had wayland before the kwin which worked before this new kwin... i may have to no update my system but then again it will still try to

Various ways, you can open System Settings and at the bottom left there's a ABOUT or something that will tell you.
You can open a terminal window and fastfetch will tell you besides the big "G" in red, assuming you didn't change default configuration for fastfetch.
Or in terminal plasmashell --version should display something, I believe. But in order to type that command, you need to open a terminal window, which, as said above, will tell you anyway without typing anything if you didn't change fastfetch default config. :smiley:

1 Like

so i rolled back, to the last backup, and its good, but i need to somehow disable the upgrade

this is the one works well: KDE Plasma 5.24.5 before it was i think 5.25.x??? not even sure haha.. is there a way to disable the main upgrade feature ?

I would never recommend to disable a full upgrade. One day or another you will need to install a package or upgrade and then you'll be screwed again, if not even more than now.
The longer you wait to upgrade, the harder it will be, cuz sometimes new packages arrive and dependencies change, keyrings and stuff like that and you end up manually installing/removing conflicting packages in the right order before you can finally perform the upgrade. Happened to me a couple of times on older installations that I left alone for a few months....

However someone else might suggest an approach to attack your issue, I hope, cuz blocking a full upgrade is pretty damn bad. :frowning:

ah alright haha, hmm, i will just upgrade more and hope they have a fix soon as new errors does happen haha. anyhow i thank you mate :slight_smile:

1 Like

so I found out something, I hear that KDE going into c++? idk why they would or is there something more to it?

let just hope that it can work on my air 2015 haha :smiley:

(o)

I'd like to read on that, where did you source that info?

1 Like

let me get that info as I saw it when I was reading thro my news on apple give me a few

not sure if you seen this yet

Interesting indeed. If that could bring new features to us and/or more stability/speed or whatever other positive wording we can find, then why not? :smiley: