KDE Connect crashes

Hello.
So today I have got this KDE connect error after every reboot it crashes and asks to restart application. Also it comes up with a pop up in notification Dr Konki crash
Below is the SS

garuda-inxi
System:
Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0b3ee793-04a5-4396-a397-8dbad9c6feeb rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=684fccb6-7d6a-4eda-8875-5b25dc60d985 loglevel=3 i8042.nokbd
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC
v: 0884110000385910000610100 serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: Hewlett-Packard model: 183E v: 56.32 serial: <superuser required>
UEFI: Insyde v: F.22 date: 11/22/2012
Battery:
ID-1: BAT0 charge: 15.6 Wh (100.0%) condition: 15.6/15.6 Wh (100.0%)
volts: 12.4 min: 10.8 model: Hewlett-Packard Primary type: Li-ion
serial: N/A status: full
CPU:
Info: model: Intel Core i3-3110M bits: 64 type: MT MCP arch: Ivy Bridge
family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1237 high: 1345 min/max: 1200/2400 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1345 2: 1209 3: 1197
4: 1197 bogomips: 19155
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard
driver: i915 v: kernel ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1
bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
Device-2: AMD Thames [Radeon HD 7500M/7600M Series]
vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu pcie:
gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 1002:6840 class-ID: 0300
Device-3: Suyin HP TrueVision HD Integrated Webcam type: USB
driver: uvcvideo bus-ID: 2-1.5:3 chip-ID: 064e:e263 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: modesetting,radeon alternate: fbdev,intel,vesa gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: LVDS-1 model: LG Display 0x034d built: 2012 res: 1366x768
hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
v: 4.2 Mesa 22.0.0 compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1e20 class-ID: 0403
Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard
driver: rt2800pci v: 2.3.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 07:00.0 chip-ID: 1814:3290 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 07:00.1 chip-ID: 1814:3298
class-ID: 0d11
Report: bt-service: enabled,stopped note: tool can't run
Drives:
Local Storage: total: 931.51 GiB used: 12.37 GiB (1.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM024 HN-M101MBB
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0001
scheme: GPT
Partition:
ID-1: / raw-size: 915.01 GiB size: 915.01 GiB (100.00%)
used: 12.37 GiB (1.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 915.01 GiB size: 915.01 GiB (100.00%)
used: 12.37 GiB (1.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 915.01 GiB size: 915.01 GiB (100.00%)
used: 12.37 GiB (1.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 915.01 GiB size: 915.01 GiB (100.00%)
used: 12.37 GiB (1.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.66 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda2 maj-min: 8:2
Sensors:
System Temperatures: cpu: 67.0 C mobo: N/A gpu: radeon temp: 61.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 253 Uptime: 13m wakeups: 1 Memory: 7.66 GiB
used: 2.96 GiB (38.7%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: 1377 pacman: 1373 lib: 357 flatpak: 4 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.14
Garuda (2.5.6-2):
System install date:     2022-04-02
Last full system update: 2022-04-02
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Can someone please help me with this. I have even tried reinstall KDE connect but it still crashes.

It could be this bug.
Fixed 3 weeks ago, but relevant release still not released.
https://bugs.kde.org/show_bug.cgi?id=449276
Fixed In: 22.04

2 Likes

So It says its fixed how to resolve it where is the solution. Or is it that there will be a new release and the bug will be fixed on its own?

When KDE will release kdeconnect version 22.4 and when it will arrive in arch repo, it will be fixed for us.
Assuming this is the same bug. But it has many duplicates, so occurred to many people...

4 Likes

ok thanks for helping I'll wait for the release any ETA about that ?

KDE has predefined schedules.
https://community.kde.org/Schedules
I'm afraid that if kdeconnect is part of KDE Gear, this could be 21-Apr-22. But I haven't checked in details.

1 Like

I have often found that it is an individual plugin that may crash KDE Connect. If you selectively disable the extra features you may find out if one of them is responsible for the crashes.

2 Likes

Tried a different kernel, such as the LTS?

I haven't modified any settings I'm using it as default. What exactly you want me to disable?

I have 23 different settings that can be enabled/disabled in the KDE Connect settings. Test disabling each one at a time.

No I haven't tried yet. Should I ? I mean changing kernel solves the issue but i don't want any other problems coming in if I change it. What do you suggest ?

How better to address this as a solution, then?

Look, if you wish to live a happy and fulfilled life using Linux as your operating system, then you MUST understand this: Linux is a moving target. And...

You have to be willing to move with it.

First; Linux itself is being continually updated; kernel, system, userspace, applications, etc. I mean, it is continuous.
Second; there's no such thing as "Linux." What is contained within that one word--Linux--seems to have a different meaning for every individual. Truthfully, it's the kernel and only that, but that's a topic for another (lifetime) day. For now, let's just say you run Garuda Linux. And that's more than just the kernel.
Third; you are running Garuda Linux. Garuda's package base is Arch's and it uses the Arch Linux Package Management system (alpm), and "Pacman" as its manager.
Fourth; Arch Linux uses a rolling release model...

I'm too old and too tired to give you much more than encouragement to explore your new Operating System, Garuda Linux; it's base system, structure, applications, etc. This you must all do on your own, in order to gain your own understanding of it all.

As my wife says; "Be bold, and mighty forces will come to your aid."

Happy Trails
:smiley:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.