KDE - can not remove borders/shadows

Hey guys, I have a weird issue with KDE, where windows that are in focus overlap neighboring window, and it even spills to the next monitors. I tried removing borders in settings, but it didn't help. Any ideas? I tried multiple themes. I also use Kvantum theme manager

image

System:    Host: pho7on-b450mds3h Kernel: 5.10.29-1-lts x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=8ed53bac-aff7-4011-a9e8-ccb8fb2376b8 rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop System: Gigabyte product: B450M DS3H v: N/A serial: <superuser required> 
           Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <superuser required> UEFI: American Megatrends v: F51 
           date: 07/29/2020 
CPU:       Info: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 1 stepping: 1 
           microcode: 8001138 cache: L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95807 
           Speed: 2661 MHz min/max: 1550/3000 MHz boost: enabled Core speeds (MHz): 1: 2661 2: 2711 3: 2814 4: 2638 5: 3284 
           6: 2865 7: 2556 8: 3174 9: 2560 10: 2559 11: 3313 12: 2885 13: 2557 14: 3038 15: 2673 16: 2836 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: eVga.com. driver: nvidia v: 460.67 
           alternate: nouveau,nvidia_drm bus-ID: 07:00.0 chip-ID: 10de:1b06 class-ID: 0300 
           Display: x11 server: X.org 1.20.10 compositor: kwin_x11 driver: loaded: nvidia resolution: <missing: xdpyinfo> 
           OpenGL: renderer: GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.67 direct render: Yes 
Audio:     Device-1: NVIDIA GP102 HDMI Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus-ID: 07:00.1 
           chip-ID: 10de:10ef class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus-ID: 09:00.3 chip-ID: 1022:1457 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.29-1-lts running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.25 running: no 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
           port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: b4:2e:99:19:d2:74 
Bluetooth: Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:3 chip-ID: 0b05:17cb 
           class-ID: fe01 serial: 5CF3709EC637 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 2.73 TiB used: 132.47 GiB (4.7%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 250GB size: 232.89 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: S465NF0K850759T rev: 1B2QEXE7 
           temp: 52.9 C scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB block-size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: S1DFVDHN rev: CC47 scheme: MBR 
           ID-3: /dev/sdb maj-min: 8:16 vendor: Kingston model: SKC600512G size: 476.94 GiB block-size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: 50026B768376DBC9 rev: 0104 scheme: GPT 
           ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: Z9ASSYRL rev: CC43 scheme: GPT 
           ID-5: /dev/sdd maj-min: 8:48 vendor: Kingston model: SUV500240G size: 223.57 GiB block-size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: 50026B7682876ACA rev: 56RI scheme: GPT 
Partition: ID-1: / raw-size: 232.63 GiB size: 232.63 GiB (100.00%) used: 18.57 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 546 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw-size: 232.63 GiB size: 232.63 GiB (100.00%) used: 18.57 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-4: /var/log raw-size: 232.63 GiB size: 232.63 GiB (100.00%) used: 18.57 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-5: /var/tmp raw-size: 232.63 GiB size: 232.63 GiB (100.00%) used: 18.57 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
           ID-9: swap-9 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram8 
           ID-10: swap-10 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram9 
           ID-11: swap-11 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram10 
           ID-12: swap-12 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram11 
           ID-13: swap-13 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram12 
           ID-14: swap-14 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram13 
           ID-15: swap-15 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram14 
           ID-16: swap-16 type: zram size: 1.96 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram15 
Sensors:   System Temperatures: cpu: 56.8 C mobo: N/A gpu: nvidia temp: 62 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 32% 
Info:      Processes: 395 Uptime: 25m wakeups: 0 Memory: 31.37 GiB used: 5.88 GiB (18.7%) Init: systemd v: 248 tool: systemctl 
           Compilers: gcc: 10.2.0 Packages: pacman: 911 lib: 239 Shell: Zsh v: 5.8 running-in: yakuake inxi: 3.3.03 

Have you tried a different window theme?

Or setting the window border width to match the apparent size?

4 Likes

I tried a different window theme.

I am not sure what are you referring to with this:

Or setting the window border width to match the apparent size?

I still have no fixes for this issue

any ideas?

I don't where the option for that is, but I believe that somewhere in settings.

By the way, if you want to prevent overlapping, why don't you slightly resize a window?

2 Likes

i am using snapping feature. Sure i could resize window, but that is cumbersome, especially since i tend to stack a lot of windows

It might be theme specific. Did you try switching themes?

2 Likes

Changing compositor backend or forcing smoothest animations for Kwin might be something to try as well.

3 Likes

Change your Window Decoration in system settings>Appearance to a theme that does not use shadows.

4 Likes

OK. I'm on my phone now. My laptop is at home and I'm out of station. After a week only I go home.

You have these options:

  1. Mess around with all the Window Management settings. As I remember, it has a submenu for "scripts" and many options are enabled there. You can try messing around with every option and check (it has search function too for you!). Nothing helps there, check every other settings. [Make sure you press Apply, otherwise what you do would be waste] :stuck_out_tongue_winking_eye:
  2. Try what others suggested or wait for more.
  3. Search for this first and then ask in KDE Forums
  4. If nothing helped then SearX for this.
2 Likes

That's not a good description.

Anyway, many applications do not shrink lower than a fixed window min-width value, depending on buttons or other objects.
Test this and make a better description of what you think is a bug (and not a feature) :wink:

3 Likes

Tried multiple themes. Issue still persists

already done that:

tried multiple themes, nothing seems to help

I am using 2k monitor and 50% width, so its not that, besides alongside description i posted screenshot of whats happening, i have no idea how to explain it better :slight_smile: