Kate really slow to start

Hi guys, im new so please forgive me my english in the first place and my netiquette.
Just noticed that everytime i start kate is really slow to open, tried to start it in terminal and gives me this message (i dont know if its related) QObject::connect: No such signal QDBusAbstractInterface::DeviceAdded(QString) in /home/main-builder/pkgwork/sr
c/solid/src/solid/devices/backends/upower/upowermanager.cpp:52
QObject::connect: No such signal QDBusAbstractInterface::DeviceRemoved(QString) in /home/main-builder/pkgwork/
src/solid/src/solid/devices/backends/upower/upowermanager.cpp:53
do you have any advise?

Ignore that it only a process step.
Because you are running it in terminal so it shows every process step which is running in background.
You can also check if you write something in kate then you see something changed in terminal also so never mind it only shows background process.
And welcome to forum

1 Like

Thanks for the welcome, so you have any ideas why kate needs like 10sec to start?

In my case kate take less than 3sec . It is because of it's protocol

https://bbs.archlinux.org/viewtopic.php?id=244174

Sadly there is no solution to this given in the thread, but it seems to be the same issue :eyes:
That being said, startup is almost instant for me when I launch it :thinking:
What does

systemctl status upower

return?

3 Likes

Also, Time to post your specs. You didn't read

Post

inxi -Fxxxza

as text, please.

4 Likes

This looks like a local app source, which shouldn't be a system problem. Possibly a Kate setting is responsible.
You should provide the exact terminal output, properly formatted and add your system info, as expected.

3 Likes

Hi, thanks all for the answer, the problem is the same i think cause even dolphin needs so much time to open/start.
Systemctl status upower

Loaded: loaded (/usr/lib/systemd/system/upower.service; disabled; vendor preset: disabled)
Active: activating (start) since Sun 2021-04-18 20:46:48 CEST; 1min 1s ago
Docs: man:upowerd(8)
Main PID: 3805859 (upowerd)
Tasks: 4 (limit: 38388)
Memory: 2.0M
CPU: 130ms
CGroup: /system.slice/upower.service
└─3805859 /usr/lib/upowerd

apr 18 20:46:48 llyo-garuda systemd[1]: Starting Daemon for power manageme

For the spec command

🔴] × inxi -Fxxxza
System:    Kernel: 5.11.15-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=775ed4c1-23c6-43e6-ae0a-45e511afc64d
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=058ec404-5cd9-44f9-ad30-eb8ca4fdb338 loglevel=3
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: ASRock model: X570 Phantom Gaming 4 serial: <filter>
UEFI: American Megatrends v: P3.90 date: 01/26/2021
CPU:       Info: 12-Core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2 family: 17 (23)
model-id: 71 (113) stepping: N/A microcode: 8701021 cache: L2: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 182062
Speed: 3792 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 1: 3792 2: 3801
3: 3792 4: 3792 5: 3792 6: 3792 7: 3798 8: 3793 9: 3792 10: 3793 11: 3793 12: 3793 13: 3792
14: 3792 15: 3792 16: 3793 17: 3792 18: 3793 19: 3793 20: 3792 21: 3792 22: 3792 23: 3793
24: 3793
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected

Sorry need a bit to learn how to post in the forum, have mercy.

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

2 Likes

Then it may be a bug in several places. Check at kde bug tracker

of the error messages (if any)

Is it a locally installed program?

1 Like

If I experience slowdowns in programs opening of file transfers taking longer I usually perform a full btrfs balance and that usually fixes me up.

1 Like

Its the kate installed by default, tried to balance btrfs but not resolved the problem, i will check the kde bug tracker, i can just add that the installation is relatively new .

I start to suspect you are a web bot.

/home/main-builder/pkgwork/src/solid/src/solid/devices/backends/upower/upowermanager.cpp:52

What is this thing?

If you want to just troll the forum I think it is offending. This is not a fun park.

4 Likes

According to our lorad and savoir wikipedia Upower is a power manager for Linux

Yes. Commonly installed in system, not in user's $HOME :wink:

The question was obviously towards OP and I will wait for one.

2 Likes

ye but i did not installed or copy kate, im using the preinstalled one. Im not a bot nor i want to make you lose time. Anyway i just installed a new m2 nvme and magically, maybe reconnecting some hdd (just guessing) seems to be more responsive, so i think its resolved for now at least. Can i ask you a way to clone and extend the actual btrfs disk to a bigger one (the nvme )^

What does this word mean?
If it is a "yeah", to what question confirms positive?

4 Likes

https://wiki.archlinux.org/index.php/Btrfs

2 Likes

That i understand your position but i m not using kate locally cause i never copied or downloaded it, after that if you say me that he's preinstalled in that way i can confirm your question positively. Anyway about btrfs ill follow your link, thanks

I have never said you are using kate locally.

Let's forget it.
The trolling is enough.

2 Likes