JAR files not working

I'm trying to use JOdin3 in Garuda but it doesn't work, when I click it in Dolphin it opens Ark to extract it and when I try running it from Konsole it shows this:

╭─[email protected] in ~/Downloads/JOdin3CASUAL-r1142-dist/app via  v16.0.2
╰─λ java -jar JOdin3CASUAL.jar
Error: Could not find or load main class com.casual_dev.jodin.JOdinMain
Caused by: java.lang.NoClassDefFoundError: javafx/application/Application

I've tried installing openjfx but it didn't help.

https://odinflashtool.com/tutorial/use-odin-flash-tool/

main class missing?

Best is to ask in link above with the error output.

2 Likes

Hi, that is a guide on how to use the app itself, which I know how to do and also it's for the default Windows version. That same version of JOdin3 worked fine in other distros like Manjaro after installing JRE and Heimdall.

Try Liberica JDK, it is packed with javafx as far as I know, and javafx works perfectly with this (in my usage.) (After installing make sure it is in usage because openjdk would be default.)

1 Like

How would I make it use LibreraJDK?

You can refer Java - ArchWiki
and use archlinux-java command

1 Like

What does the documentation say about how to run the application?

2 Likes

It just says install Heimdall and a Java Runtime Environment, it doesn't tell you how to run it, but I already know how to run it, just that it doesn't work in Garuda, even though it worked in other distros.

Did you tried Liberica JDK and use "archlinux-java set <JAVA_ENV_NAME>" command

2 Likes

Do you have open-javafx installed?

1 Like

Yes, of course.

It works with liberica, thanks.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.