Japanese characters are not displayed correctly

Hello.

I recently re-installed Garuda Linux and noticed that Japanese characters are no longer displayed correctly in various applications, e.g. the browser and part of Discord. It looks very pixilated and thin.

I guess it's the fault of the font, but I was unable to find any solutions on the internet.
I tried adding the locale to the /etc/locale.gen file and ran locale-gen but it didn't change anything. But it worked well in previous installations of Garuda out of the box so I don't really know what the issue is.

In the Setup-Assistant, I selected the Asian Fonts Support and the Japanese input method.

Screenshots of the issue (notice how the font is partially right in the second screenshot):
Screenshot_7
Screenshot_6_edited

Post your terminal/konsole in- and output as text (no pictures) from:

> inxi -Faz

System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=80c2edcd-71b7-4e86-becf-eebdbb6c319d
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: ASRock model: Z370 Extreme4 serial: <filter> UEFI: American Megatrends
v: P1.30 date: 11/24/2017
CPU:       Info: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Kaby Lake note: check
family: 6 model-id: 9E (158) stepping: A (10) microcode: EA cache: L2: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 88796
Speed: 4300 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 4300 2: 4300 3: 4300 4: 4300
5: 4301 6: 3016 7: 4300 8: 4300 9: 4300 10: 4300 11: 4302 12: 4300
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia v: 470.74
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c03 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia
unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.9x11.9") s-diag: 610mm (24")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") diag: 609mm (24")
OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74
direct render: Yes
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
Device-3: C-Media Blue Snowball type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 1-6:3 chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel port: N/A
bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8
bus-ID: 1-3.1:4 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 5.57 TiB used: 1.8 TiB (32.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 0A80 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37120G size: 111.79 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 71E0 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital model: WD My Passport 25E2
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B type: N/A serial: <filter> rev: 4005
scheme: GPT
Partition: ID-1: / raw-size: 1.33 TiB size: 1.33 TiB (100.00%) used: 67.73 GiB (5.0%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
ID-2: /boot/efi raw-size: 7.81 GiB size: 7.8 GiB (99.80%) used: 576 KiB (0.0%) fs: vfat
dev: /dev/sda3 maj-min: 8:3
ID-3: /home raw-size: 1.33 TiB size: 1.33 TiB (100.00%) used: 67.73 GiB (5.0%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 1.33 TiB size: 1.33 TiB (100.00%) used: 67.73 GiB (5.0%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
ID-5: /var/tmp raw-size: 1.33 TiB size: 1.33 TiB (100.00%) used: 67.73 GiB (5.0%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.56 GiB used: 2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 46 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 331 Uptime: 3h 13m wakeups: 1 Memory: 15.56 GiB used: 5.03 GiB (32.3%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1640 lib: 459 Shell: Zsh v: 5.8
running-in: konsole inxi: 3.3.07

Try changing font in firedragon settings for Japanese. Choose a bolder font there.

2 Likes

Changing the font-size also seems to work, but that's not possible in all applications.

As I already mentioned, it was working fine in previous installations. Is it the fault of the new font that is pre-installed?

You can change the default font for all the applications in the settings.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.