Jack2 and pipe-jack conflict

Hi, I've tried updating my system, and there is a conflict between jack2 and pipewire-jack. Its not teh first time this happenend and it solved itself last time. Now its not working, even through the garruda manager.
I've tried to uninstall pipewire-jack but it has a lot of dependencies, and so does jack2.
If i try to update through garuda assistant i get :

[2022-02-07 17:22:32] WARNING: failed to rate http(s) download (https://archmirror.it/repos/community/os/x86_
64/community.db): HTTP Error 403: Forbidden
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirr
orlist
# When:       2022-02-07 20:22:42 UTC
# From:       https://archlinux.org/mirrors/status/json/
# Retrieved:  2022-02-07 20:22:29 UTC
# Last Check: 2022-02-07 20:06:18 UTC

Server = https://mirror.luzea.de/archlinux/$repo/os/$arch
Server = https://archlinux.homeinfo.de/$repo/os/$arch
Server = https://archlinux.thaller.ws/$repo/os/$arch
Server = https://mirror.cyberbits.asia/archlinux/$repo/os/$arch
Server = https://archmirror.it/repos/$repo/os/$arch

:: Sincronizando a base de dados de pacotes...
core                                 136,9 KiB   120 KiB/s 00:01 [------------------------------------] 100%
extra                               1554,2 KiB   551 KiB/s 00:03 [------------------------------------] 100%
community                              6,1 MiB  2,31 MiB/s 00:03 [------------------------------------] 100%
multilib                             148,9 KiB   113 KiB/s 00:01 [------------------------------------] 100%
chaotic-aur                         1776,9 KiB  1588 KiB/s 00:01 [------------------------------------] 100%

--> Addressing jack2 conflict..
erro: alvo n√£o encontrado: jack2

I usually upade through sudo pacman -Syu but this time it gave me those errors, then i tried sudo pacman -Syyu and did something but i got the "partial upgrade is not supported" and theni tried updating there and I'm not in this situation, ive tried to update pipewire-jack like some forums told me, and it tries but doenst to anything, no error and no update.
Trying to uninstall (-Rdd or -R) jack2 manually says "target not found" and trying to -Q or -Qi returns "package not found" checking pamac shows me jack2 is not installed
I'm kind of lost here, and from what ive seen my system will likelly break next restart. from the partial upgrade

sudo pacman -Syu
[sudo] senha para gibarel:
:: Sincronizando a base de dados de pacotes...
core est√° atualizado
extra                               1554,3 KiB   810 KiB/s 00:02 [------------------------------------] 100%
community                              6,1 MiB  2,30 MiB/s 00:03 [------------------------------------] 100%
multilib est√° atualizado
chaotic-aur                         1777,0 KiB  1312 KiB/s 00:01 [------------------------------------] 100%
:: Iniciando atualização completa do sistema...
atenção: garuda-settings-manager-git: local (1.0.0.r1.g15c4106-3) é mais novo que chaotic-aur (1.0.0.r1.g15c4
106-1)
atenção: garuda-settings-manager-kcm-git: local (1.0.0.r1.g15c4106-3) é mais novo que chaotic-aur (1.0.0.r1.g
15c4106-1)
resolvendo dependências...
procurando pacotes conflitantes...
:: jack2 e pipewire-jack est√£o em conflito (jack). Remover pipewire-jack? [s/N] s
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: a remoção de pipewire-jack quebra a dependência "pipewire-jack" necessária por lib32-pipewire-jack
:: a remoção de pipewire-jack quebra a dependência "pipewire-jack" necessária por pipewire-support
sudo pacman -Syu
:: Sincronizando a base de dados de pacotes...
core est√° atualizado
extra est√° atualizado
community est√° atualizado
multilib est√° atualizado
chaotic-aur est√° atualizado
:: Iniciando atualização completa do sistema...
atenção: garuda-settings-manager-git: local (1.0.0.r1.g15c4106-3) é mais novo que chaotic-aur (1.0.0.r1.g15c4
106-1)
atenção: garuda-settings-manager-kcm-git: local (1.0.0.r1.g15c4106-3) é mais novo que chaotic-aur (1.0.0.r1.g
15c4106-1)
resolvendo dependências...
procurando pacotes conflitantes...
:: jack2 e pipewire-jack est√£o em conflito (jack). Remover pipewire-jack? [s/N]
erro: conflito de pacotes n√£o solucion√°vel detectado
erro: falha ao preparar a transação (dependências conflitantes)
:: jack2 e pipewire-jack est√£o em conflito
sudo pacman -Rdd jack2
erro: alvo n√£o encontrado: jack2
sudo pacman -S pipewire-jack
atenção: pipewire-jack-1:0.3.45-1 está atualizado -- reinstalando
resolvendo dependências...
procurando pacotes conflitantes...

Pacotes (1) pipewire-jack-1:0.3.45-1

Tamanho total instalado:  0,66 MiB
Alteração no tamanho:     0,00 MiB

:: Continuar a instalação? [S/n] 
(1/1) verificando chaves no chaveiro                              [------------------------------------] 100%
(1/1) verificando integridade do pacote                           [------------------------------------] 100%
(1/1) carregando arquivos do pacote                               [------------------------------------] 100%
(1/1) verificando conflitos de arquivos                           [------------------------------------] 100%
(1/1) verificando espaço em disco disponível                      [------------------------------------] 100%
:: Executando hooks pré-transação...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 276
:: Processando altera√ß√Ķes do pacote...
(1/1) reinstalando pipewire-jack                                  [------------------------------------] 100%
:: Executando hooks pós-transação...
(1/7) Arming ConditionNeedsUpdate...
(2/7) Foreign/AUR package notification
alvr-git 16.0.0.rc2.r225.g4471de12-1
ckb-next-git 1:0.4.4.r147.gee8ca741-1
discover-overlay 0.3.3-3
epson-inkjet-printer-escpr 1.7.17-1
epson-inkjet-printer-escpr2 1.1.45-1
epsonscan2 6.6.40.0-2
ffmpeg-vulkan 2:4.4.1-1
godot-mono-bin 3.4-1
java-openjdk-bin 17.0.1.u12-1
jdk 17.0.1-1
jre 17.0.1-1
multimc-bin 1.6-1
nuclear-player-bin 0.6.17-2
parsec-bin 150_28-3
qt5-singlecoreapplication 2.6_20170914-1
sidequest-bin 0.10.26-1
snapd 2.53.4-1
snapd-glib 1.59-1
(3/7) Orphaned package notification...
amf-headers 1.4.23-1
asciidoc 10.1.1-1
boost 1.78.0-1
celt 0.11.3-4
cmake 3.22.2-1
ffnvcodec-headers 11.1.5.1-1
flatpak 1.12.4-1
go-tools 4:0.1.9-1
itstool 1:2.0.7-1
kfiredragonhelper 5.0.6-1
memavaild 0.6-1
meson 0.61.1-1
nasm 2.15.05-1
nohang 0.2.0-1
nuget 5.10.0-1
prelockd 0.9-1
python-docutils 1:0.16-2
python-html2text 2020.1.16-5
rebuild-detector 4.4.1-1
scons 4.3.0-3
snapd 2.53.4-1
snapd-glib 1.59-1
uresourced 0.4.0-1
vala 0.54.6-1
xorg-server-xvfb 21.1.3-1
zita-alsa-pcmi 0.4.0-1
zita-resampler 1.8.0-1
(4/7) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/nsswitch.conf.pacnew
/etc/default/grub.pacnew
/etc/default/grub-btrfs/config.pacnew
/etc/pamac.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
Please check and merge
(5/7) Checking which packages need to be rebuilt
(6/7) Performing snapper post snapshots for the following configurations...
==> root: 277
(7/7) Syncing all file systems...
1 Like

Have you tried just running the update command in a terminal? From what I understand, this is the preferred command to use to update your Garuda system.

1 Like

Just search in forum.
Terminal output need three ~ in first and last line, please edit your post.

4 Likes

ive seen that post, tried everything on it and didnt work so i thought it was a different issue

i tried it, thats what yielded the output

It sounds like it's a little broken already! I would take the restart. If your situation worsened you could fall back on a snapshot; you should have gotten a new one from before you ran update.

tried a restart, nothing broke, but the problem still there

You got the same results using update command instead of sudo pacman -Syu, right? update includes a special script specifically for this pipe-jack dependency mix-up.

Please post garuda-inxi.

1 Like

It would be nice if such attempts were in the first post and not only when others have already searched for it for you.

There are more than one, try also the search function upper right.

I might try to tackle this issue tomorrow, seems like something more sinister is going on here that the automatic script can't handle :thinking:
It's 5 am right now I'll get back to you tomorrow if I don't forget :slight_smile:

4 Likes
sudo garuda-inxi
[sudo] senha para gibarel:     
System:
Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ee60ce52-3b59-4613-ab6b-43253d6b3c29 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS_BR v: Rev X.0x
serial: <filter> UEFI: American Megatrends v: 1405 date: 11/19/2019
CPU:
Info: model: AMD Ryzen 7 3700X socket: AM4 bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x71 (113) stepping: 0
microcode: 0x8701013
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3600 min/max: 2200/4426 boost: enabled
base/boost: 3600/4400 scaling: driver: acpi-cpufreq governor: performance
volts: 1.1 V ext-clock: 100 MHz cores: 1: 3600 2: 3600 3: 3600 4: 3600
5: 3600 6: 3600 7: 3600 8: 3600 9: 3600 10: 3600 11: 3600 12: 3600
13: 3600 14: 3600 15: 3600 16: 3600 bogomips: 114986
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] vendor: Gigabyte
driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm bus-ID: 09:00.0
chip-ID: 10de:1e81 class-ID: 0300
Display: server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.7x11.9")
s-diag: 1102mm (43.4")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 96
size: 509x286mm (20.0x11.3") diag: 584mm (23")
Monitor-2: DP-2 res: 1920x1080 dpi: 92 size: 531x299mm (20.9x11.8")
diag: 609mm (24")
OpenGL: renderer: NVIDIA GeForce RTX 2080 SUPER/PCIe/SSE2
v: 4.6.0 NVIDIA 510.47.03 direct render: Yes
Audio:
Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel bus-ID: 09:00.1 chip-ID: 10de:10f8 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0b:00.4 chip-ID: 1022:1487
class-ID: 0403
Device-3: Generalplus Usb Audio Device type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:2 chip-ID: 1b3f:2008
class-ID: 0300 serial: <filter>
Device-4: SteelSeries ApS Arctis Pro Wireless type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 7-1.3:6 chip-ID: 1038:1294
class-ID: 0300
Sound Server-1: ALSA v: k5.16.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus-ID: 05:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Drives:
Local Storage: total: 2.75 TiB used: 301.38 GiB (10.7%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 32B3T8EB
temp: 42.9 C scheme: GPT
SMART: yes health: PASSED on: 29d 0h cycles: 78
read-units: 4,879,290 [2.49 TB] written-units: 30,269,043 [15.4 TB]
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: A-Data model: SX6000PNP
size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: V9001c27
temp: 39.9 C scheme: GPT
SMART: yes health: PASSED on: 53d 20h cycles: 727
read-units: 17,437,860 [8.92 TB] written-units: 20,658,836 [10.5 TB]
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
family: BarraCuda 3.5 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: 0001 temp: 42 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 319d 18h cycles: 727
read: 13.93 TiB written: 45 TiB Pre-Fail: attribute: Spin_Retry_Count
value: 100 worst: 100 threshold: 97
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 301.38 GiB (63.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 301.38 GiB (63.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 301.38 GiB (63.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 301.38 GiB (63.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.32 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 56 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 36%
Info:
Processes: 407 Uptime: 33m wakeups: 0 Memory: 31.32 GiB
used: 4.95 GiB (15.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1453 lib: 390 flatpak: 0
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2021-11-29
Last full system update: 2022-02-01
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       Yes
Snapshots:               Snapper
Failed units:

Following this.

You can use the built-in feature rather than posting an empty post:

6 Likes

I think i solved it, aparently jack2-dbus was intalled ana somehow jack2 wasnt, so when it tried to update it tried to isntall jack2, and the scrip was then trying to uninstall jack2 but wasnt finding it. I had to manually uninstall jack2-dbus and then the update worked.

7 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.