Iwlwifi not loading

You will likely need to do several things. Disable MAC Address randomization (there is a setting in the Garuda networking app for this) and also add some extra driver options.

See this related post about an Intel 7265 adapter. It saves a lot of time and effort if you search your adapter model thoroughly on the forum.

Here is another thread you can refer to about Intel iwlwifi driver options:

As this is an old adapter that Intel no longer actively supports you may want to consider purchasing a replacement.