Iwlwifi not loading

I have installed Garuda Linux on my HP laptop. I used a USB and could install everything with wifi but when I reboot I have no wifi anymore. Tried several tips but with no success.

╰─λ inxi -Fxxxza
System:    Kernel: 5.11.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=d89991dd-e859-4e70-b080-6830a0aac261 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=7be651bc-1b99-4ed0-98c0-3b813d950b8b loglevel=3 
Desktop: KDE Plasma 5.21.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
Distro: Garuda Linux 
Machine:   Type: Convertible System: HP product: HP ENVY x360 Convertible v: Type1ProductConfigId 
serial: <filter> Chassis: type: 31 serial: <filter> 
Mobo: HP model: 80D0 v: 84.31 serial: <filter> UEFI: Insyde v: F.33 date: 02/26/2018 
Battery:   ID-1: BAT0 charge: 27.0 Wh condition: 27.1/27.1 Wh (100%) volts: 12.9/11.4 
model: 333-54-2A LE03048XL type: Li-ion serial: <filter> status: Unknown 
CPU:       Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake family: 6 
model-id: 4E (78) stepping: 3 microcode: E2 L2 cache: 3 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19200 
Speed: 2726 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 2726 2: 2739 3: 2747 4: 2711 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard driver: i915 v: kernel 
bus ID: 00:02.0 chip ID: 8086:1916 class ID: 0300 
Device-2: NVIDIA GM108M [GeForce 930M] vendor: Hewlett-Packard driver: nvidia v: 460.39 
alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1346 class ID: 0302 
Device-3: Chicony HP Truevision HD type: USB driver: uvcvideo bus ID: 1-4:2 chip ID: 04f2:b50d 
class ID: 0e02 serial: <filter> 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel,nvidia 
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel 
v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d70 class ID: 0403 
Sound Server: ALSA v: k5.11.1-zen1-1-zen 
Network:   Device-1: Intel Wireless 7265 driver: N/A modules: iwlwifi port: 4000 bus ID: 02:00.0 
chip ID: 8086:095a class ID: 0280 
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 chip ID: 10ec:8168 class ID: 0200 
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus ID: 1-6:4 
chip ID: 8087:0a2a class ID: e001 
Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 238.47 GiB used: 7.9 GiB (3.3%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: LITE-ON model: L8H-256V2G-HP size: 238.47 GiB block size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: SSD serial: <filter> rev: 2803
scheme: GPT
Partition: ID-1: / raw size: 229.41 GiB size: 229.41 GiB (100.00%) used: 7.9 GiB (3.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw size: 260 MiB size: 256 MiB (98.45%) used: 546 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw size: 229.41 GiB size: 229.41 GiB (100.00%) used: 7.9 GiB (3.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw size: 229.41 GiB size: 229.41 GiB (100.00%) used: 7.9 GiB (3.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw size: 229.41 GiB size: 229.41 GiB (100.00%) used: 7.9 GiB (3.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
maj-min: 8:3
ID-2: swap-2 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 46.0 C mobo: 43.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 207 Uptime: 26m wakeups: 1 Memory: 7.69 GiB used: 3.32 GiB (43.2%) Init: systemd
v: 247 Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1227 lib: 305 Shell: fish
v: 3.1.2 running in: konsole inxi: 3.3.01
╰─λ sudo dmesg | grep wifi
[    5.901081] iwlwifi 0000:02:00.0: can't change power state from D3hot to D0 (config space inaccessible)
[    5.901371] iwlwifi 0000:02:00.0: HW_REV=0xFFFFFFFF, PCI issues?
[    5.903273] iwlwifi: probe of 0000:02:00.0 failed with error -5

This kernel is several weeks old. Update using the

connection, reboot, and see if the problem is already fixed by updated packages.

1 Like

Just arrived

linux-zen-5.11.7.zen1-1  linux-zen-headers-5.11.7.zen1-1
1 Like

Tried that also but no difference. I think an older kernel is better since it works when I boot up from the iso I downloaded. (garuda-dr460nized-linux-zen-210225) I will check which kernel that is.

It's the same as I had:
System: Kernel: 5.11.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda
misolabel=GARUDA_DR460NIZED_SOARING_ quiet systemd.show_status=1 splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 driver=nonfree nouveau.modeset=0 i915.modeset=1
radeon.modeset=1

But it works when I boot from the USB:
udo dmesg | grep wifi
[ 11.128615] iwlwifi 0000:02:00.0: loaded firmware version 29.198743027.0 7265D-29.ucode op_mode iwlmvm
[ 11.388808] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[ 11.406364] iwlwifi 0000:02:00.0: base HW address: dc:53:60:ea:f3:5d
[ 11.486317] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0

My subjective impression is that KDE-Plasma boots faster with the current kernel update.
My computer definitely shuts down faster.

3 Likes

Is your BIOS the latest available?

2 Likes

I have HP with old WIFI card (Intel Centrino Advanced N6200) too.
For me it works.

Try to connect the WIFI manually,
Settings --> Connections -->Wi-Fi
+ Add new connection
Wi-Fi

SSID --> Choose your WIFI network from the list
Mode --> Infrastructure
BSSID --> click and add MAC adress should be added automatically
Restrict to Device --> click and add MAC adress should be added automatically
Cloned MAC Adress --> empty
MTU --> Automatic
Visibility --> empty

Wi-Fi Security Tab
Security --> WPA2 (Not sure but probaly yours is WPA2 too)
Password --> Your Password

Then Save it.

2 Likes

Also there is an AUR driver you can try:
iwlwifi-7265-ucode

2 Likes

Then it hasn't updated. Refresh your mirror list (e.g. reflector-simple or the upd command) and try again.

2 Likes

I updated kernel to 5.11.7 today but no change. Did some other stuff and rebooted couple of times and suddenly it worked. Rebooted again and it was back as before again....
Rebooted again and now it's working again. When I had Windows 10 on this laptop I never had any problem.

Now it's also more output in dmesg:

sudo dmesg | grep iwl
[sudo] password for jo:
[ 5.178756] iwlwifi 0000:02:00.0: Found debug destination: EXTERNAL_DRAM
[ 5.178760] iwlwifi 0000:02:00.0: Found debug configuration: 0
[ 5.179063] iwlwifi 0000:02:00.0: loaded firmware version 29.4063824552.0 7265D-29.ucode op_mode iwlmvm
[ 5.469986] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[ 5.482895] iwlwifi 0000:02:00.0: Applying debug destination EXTERNAL_DRAM
[ 5.483754] iwlwifi 0000:02:00.0: Allocated 0x00400000 bytes for firmware monitor.
[ 5.488256] iwlwifi 0000:02:00.0: base HW address: dc:53:60:ea:f3:5d
[ 5.551535] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[ 5.580289] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
[ 7.064031] iwlwifi 0000:02:00.0: Applying debug destination EXTERNAL_DRAM
[ 7.143250] iwlwifi 0000:02:00.0: Applying debug destination EXTERNAL_DRAM
[ 7.144887] iwlwifi 0000:02:00.0: FW already configured (0) - re-configuring
[ 7.176966] iwlwifi 0000:02:00.0: Applying debug destination EXTERNAL_DRAM
[ 7.260993] iwlwifi 0000:02:00.0: Applying debug destination EXTERNAL_DRAM
[ 7.262097] iwlwifi 0000:02:00.0: FW already configured (0) - re-configuring

Except that now

and

So it seems that there has been a change, and that it is "more working" than before.

Can you provide specific details about what it looks like when it's "not working"? Log output, behaviour, rfkill output, ...

2 Likes

You will likely need to do several things. Disable MAC Address randomization (there is a setting in the Garuda networking app for this) and also add some extra driver options.

See this related post about an Intel 7265 adapter. It saves a lot of time and effort if you search your adapter model thoroughly on the forum.

Here is another thread you can refer to about Intel iwlwifi driver options:

As this is an old adapter that Intel no longer actively supports you may want to consider purchasing a replacement.

4 Likes

Thread is deemed abandoned.

Thread is now closed.

PM a mod if you are the OP and wish the issue reopened.