Iwd with resolvconf

Hi, i removed networkmanager and all other dhcp clients and now only iwd is installed. Iwd uses nameresolvingservice as systemd by default. and it works with systemdalso. but when i set nameresolving service to resolvconf then iwd does not even start. i use custom selectes dns servers so please help. Thanks and sorry for garuda-inxi currently have no connection to the laptop.

What's wrong with NetworkManager? It also uses systemd, by the way.

To resolve your issue:

  • Restore a snapshot from before you removed NetworkManager.
  • Try not to remove it again. :smirk:
1 Like

Tell us the exact procedure you used to convert to IWD. I have done this numerous times without issues.

You did not even bother to mention which DE you are using. With this lack of information, n assistance is next to impossible. The garuda-inxi output can be saved and uploaded using your phone or anything else with an internet connection.


I use sway edition. I deleted networkmanager and all other dhcp clients. dhclient and others. also confirmed that only iwd is installed now. Now everything works. but according to arch wiki about iwd. i added a few options to main.conf file
Enabled iwds built in networkconfiguration. restarted iwd and everything works. then added NameResolvingService=resolvconf and restarted iwd but it failed. then i commented out nameresolvingservice option and then iwd works. so why iwd does not start when nameresolvingservice is set to resolvconf?
i want to use iwd with nameresolvingservice set to resolvconf.. because i use custom dns...

I have absolutely zero idea if this is the problem or not, I just found these online and they ring a bell:


If it's this, there's an easy workaround involving ReadWritePaths. If not, :man_shrugging: sorry.

1 Like

hey i spent some time and now i found out this. i tried to start iwd directly and it says this error..

No usable resolvconf found on system
Module resolve failed to start: -2
D-Bus disconnected, quitting...

I think iwd cannot find it.. until now this where i get on the issue. What should i do to resolve this ?

for your info.. i tried this on arch and result is the same.