Issuing a GPG key with kleopatra is returning a general error

I have been trying to issue a GPG key with Kleopatra but everytime it returns the same error

Could not create key pair: General error

Looking closer at the logs I am getting

gpg-agent[9617]: Assuan processing failed: Broken pipe

There isn't much to go on the internet about this "assuan broken pipe". Any help is much appreciated.

I can create a gpg key manually but I would rather automate the task since I do have to create a lot keys due to my line of work..

As per arch wiki gpg, I have added in my .zshrc profile but to no avail.

export GPG_TTY=$(tty)
gpg-connect-agent updatestartuptty /bye >/dev/null

gpg.conf is confured with the below

use-agent
pinentry-mode loopback

And gpg-agent.conf is configured as follow

allow-loopback-pinentry
pinentry-program /usr/bin/pinentry

I did try to use pinentry-tty and qt but same result. I decided to post as I am out of ideas.

Finally made it work as before.
Changed config in gpg.conf and removed the option 'pinentry-mode loopback'. Was added in previous config and it worked until latest update.
Added in my .zshrc
gpg-agent --options ${HOME}/.gnupg/gpg-agent.conf --daemon`

I don't know what is the diff between before and now but its working.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.