Issues With Proton

Garuda is unfortunately far from the only distro where proton has not worked for whatever reason, so I do not think it is distro-specific. Basically, I have this really odd issue in steam where I can enable proton, install a game, and then can click play. After clicking play, however, I am told the game needs to update. Interestingly, this happens even on games that haven't been updated in many years. And, when I try to see the status of the update by clicking "View Updates", nothing happens, and there is no progress bar for the update at all. This is not the first time I have asked for help on this issue before (it is the first time I have tried asking for help on this forum), so I have a feeling the issue may not be able to be fixed, and I may be forced to install windows on my other SSD.

Kernel: 6.1.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0c0810c3-3299-44f7-86fb-e6a526f9bbf5 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.0 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Dell product: OptiPlex 7020 v: 00
serial: <superuser required> Chassis: type: 6 serial: <superuser required>
Mobo: Dell model: 08WKV3 v: A01 serial: <superuser required> UEFI: Dell
v: A16 date: 06/26/2018
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M280/320/275
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i7-4790 bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1786 high: 3592 min/max: 800/4000 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 800 2: 800 3: 1695
4: 800 5: 3592 6: 3272 7: 800 8: 2532 bogomips: 57469
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] vendor: Micro-Star MSI
driver: nvidia v: 525.89.02 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2023-02) arch: Maxwell code: GMxxx
process: TSMC 28nm built: 2014-19 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:17c8 class-ID: 0300
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 92 s-size: 707x393mm (27.83x15.47")
s-diag: 809mm (31.85")
Monitor-1: DP-4 res: 2560x1440 hz: 120 dpi: 93
size: 697x392mm (27.44x15.43") diag: 800mm (31.48") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 525.89.02 renderer: NVIDIA GeForce GTX 980
Ti/PCIe/SSE2 direct-render: Yes
Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus-ID: 3-9:5 chip-ID: 0d8c:0169
bus-ID: 00:1b.0 class-ID: 0300 chip-ID: 8086:8c20 class-ID: 0403
Device-2: NVIDIA GM200 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fb0 class-ID: 0403
Device-3: C-Media USB-LCS Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.1.12-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.65 running: yes
Device-1: Intel Ethernet I217-LM vendor: Dell driver: e1000e v: kernel
port: f040 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Ralink RT3060 Wireless 802.11n 1T/1R vendor: Edimax
driver: rt2800pci v: 2.3.0 bus-ID: 04:02.0 chip-ID: 1814:3060 class-ID: 0280
IF: wlp4s2 state: up mac: <filter>
Local Storage: total: 1.3 TiB used: 61.9 GiB (4.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: HP model: SSD M700 120GB
size: 111.79 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 7B1
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3250312AS
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: JC66 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT1000MX500SSD1
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 043 scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 type: USB model: USB DISK 3.0 size: 57.77 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
rev: PMAP
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 56.72 GiB (6.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 56.72 GiB (6.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 56.72 GiB (6.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 56.72 GiB (6.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 62 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
Processes: 251 Uptime: 19m wakeups: 80 Memory: 15.57 GiB
used: 5.52 GiB (35.5%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: 1377 pm: pacman pkgs: 1371
libs: 413 tools: octopi,paru pm: flatpak pkgs: 6 Shell: fish v: 3.6.0
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.25
Garuda (2.6.14-1):
System install date:     2023-01-14
Last full system update: 2023-02-17 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Please share a Screenshot of your steam library page (installed filter) along with the full steam output log when you type "steam" into your terminal.


i had similar problem too. only thing i did was cancel the update and restart it. on other occasion i had to verify file integrity once, then it worked like charm. curiously, did you install the game in an ntfs drive?


I saw something like that, too, once or twice. But it was not the game that was updated, but steam downloaded some proton stuff.

Can you see any other downloads queued?

Also, what happens if you install proton using pacman and set a game to use system proton in steam?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.