Issues with Nvidia, intel, x11 wayland multi GPU multi screen

Dear Garuda team,
before I describe my issues, I first want to thank you for this amazing distribution. I tried to switch from Windows to linux in the past couple of years and always had a very unsatisfying experience. This distribution finally changed it - you are doing everything right! Like the Garuda center, snapper and other stuff providing a nice user experience. Thank you!!

I’m using KDE Dragonized edition.

Now to my issues :slight_smile:

  • I have an nvidia rtx 4090 and an intel integrated-gpu.
  • My main gaming monitor is connected to the nvidia card with a resolution of 5120x1440 @ 120 hz.
  • The other two monitors, 1080p each, are connected to the intel igpu with 60hz and 75 hz.

I want to start telling you what is working:

  1. If i disable the integrated GPU completely and use nvidia with x11 session all is fine.
  2. If i want to use wayland (only nvidia gpu activated) the session starts, but my screen is not recognized and i only have a 4:3 1024x768 resolution. xrandr says connected to unknown.
  3. As soon as i activate the intel integrated-gpu more problems occur.

My problems are similar to the ones in this post.

Steam kinda freezes / locks up the UI for up to 40 seconds. Launching games from Steam takes ages. This happens even without activating the monitors connected to the integrate gpu (disabled monitors in kde settings). The mere presence of the intel gpu and its driver seem to cause this?!

  1. Starting games through bottles is fine if nvidia card is running alone.
    As soon as the intel gpu is there, in-game 3d graphics start to tear and stutter.

So what is my goal?
I want to use the intel igpu to run the 2 smaller screens and handle the content for them like video decoding and stuff (Kodi for example) and accelerate them.

The nvidia card should only run the gaming monitor and my games.
I’m happy to use x11 but would prefer wayland.

I’ve looked a lot around the internet and found stuff like x11 multiseat, but that’s not really what i want…

I hope you have some advice / solutions for me :).

here comes garuda-inxi

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=69cfa927-5888-4db9-9f92-e09f791bd5c0 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=86a67afa-ea0f-4d3a-b772-92916a536b68 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG MAXIMUS XI HERO v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 1802
date: 12/01/2020
Info: model: Intel Core i9-9900K bits: 64 type: MT MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xC (12) microcode: 0xF4
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 801 high: 824 min/max: 800/5100 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800 9: 824 10: 800 11: 800 12: 800 13: 800 14: 800
15: 800 16: 800 bogomips: 115200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: HDMI-A-1,HDMI-A-2 empty: DP-1 bus-ID: 00:02.0
chip-ID: 8086:3e98 class-ID: 0380
Device-2: NVIDIA AD102 [GeForce RTX 4090] vendor: ASUSTeK driver: nvidia
v: 545.29.02 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022+ pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:2684
class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau,nvidia
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 7040x2520 s-dpi: 80 s-size: 2235x800mm (87.99x31.50")
s-diag: 2374mm (93.46")
Monitor-1: DP-2 pos: primary,bottom-l res: 5120x1440 hz: 120 dpi: 130048
size: 1x1mm (0.04x0.04") diag: 1mm (0.06") modes: N/A
Monitor-2: HDMI-1-1 pos: bottom-r res: 1920x1080 hz: 60 dpi: 94
size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
Monitor-3: HDMI-1-2 pos: top-center res: 1920x1080 dpi: 93
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
Monitor-4: None-2-1 size-res: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: kms_swrast
surfaceless: drv: nvidia x11: drv: nvidia inactive: wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.02
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 4090/PCIe/SSE2
memory: 23.43 GiB
API: Vulkan v: 1.3.269 layers: 10 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 4090 driver: nvidia v: 545.29.02
device-ID: 10de:2684 surfaces: xcb,xlib device: 1 type: integrated-gpu
name: Intel UHD Graphics 630 (CFL GT2) driver: mesa intel
v: 23.2.1-arch1.2 device-ID: 8086:3e98 surfaces: xcb,xlib device: 2
type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA AD102 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:22ba
class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Local Storage: total: 11.03 TiB used: 208.76 GiB (1.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Crucial model: CT4000P3PSSD8
size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR40A temp: 35.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Crucial model: CT4000P3PSSD8
size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR40A temp: 42.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 2B6Q scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 2B6Q scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Crucial model: M4-CT128M4SSD2
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 040H scheme: GPT
ID-6: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WDS100T3 XHC-00SJG0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.2 spd: 10 Gb/s lanes: 1 mode: 3.2 gen-2x1
tech: N/A serial: <filter> fw-rev: 3106 scheme: GPT
ID-1: / raw-size: 84.65 GiB size: 84.65 GiB (100.00%)
used: 19.56 GiB (23.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
ID-3: /home raw-size: 84.65 GiB size: 84.65 GiB (100.00%)
used: 19.56 GiB (23.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-4: /var/log raw-size: 84.65 GiB size: 84.65 GiB (100.00%)
used: 19.56 GiB (23.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-5: /var/tmp raw-size: 84.65 GiB size: 84.65 GiB (100.00%)
used: 19.56 GiB (23.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.18 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.3 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdc3 maj-min: 8:35
System Temperatures: cpu: 45.0 C mobo: 29.0 C gpu: nvidia temp: 53 C
Fan Speeds (rpm): cpu: 0 gpu: nvidia fan: 0%
Processes: 327 Uptime: 30m wakeups: 0 Memory: total: 32 GiB
available: 31.18 GiB used: 4.01 GiB (12.9%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: 1542
pm: pacman pkgs: 1536 libs: 501 tools: octopi,pamac,paru pm: flatpak pkgs: 6
Shell: fish v: 3.6.1 default: Bash v: 5.2.15 running-in: konsole
inxi: 3.3.31
Garuda (2.6.17-1):
System install date:     2023-11-02
Last full system update: 2023-11-02
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Are there more recent BIOS updates for your rig? There should be.

Thanks for your reply.
The “bios internal” bios internet update didn’t find anything new. So i went to the support myself and installed the latest 2004 bios.

But no changes to my described issues.

Don’t get this statement wrong - in windows the stuff works flawlessly, so I didn’t expect it to be bios based problem.

But you never know when you don’t try :wink:

You did not downgrade your 9th Gen machine’s BIOS from 2020 to a 2004 BIOS. Your CPU architecture didn’t exist prior to late 2018. So what did you do?

I have the same 9th Gen architecture, but only a lowly Core i5. A computer BIOS (basic input/output system) is a chip on your mainboard that is powered by a watch cell battery and contains information about your hardware. It’s the brains of your computer and never shuts off. But hardware flaws, inconsistencies, and security issues mean most BIOS computer/manufacturers update them regularly for a number of years. Example: My 9th Gen’s BIOS was updated again just a couple of weeks ago, if I recall correctly. There have been several since I purchased it in late 2018.

Keeping your machine’s BIOS current is a normal housekeeping duty. It’s a very important troubleshooting step, also. Updating may or may not have any bearing on your problem, but it is something that needs to be a non-issue.

Forgive me if this is information you already know. :smiley:

The old bios version was:

UEFI: American Megatrends v: 1802

The new is:

UEFI: American Megatrends v: 2004

LOL, now that I can understand. You upgraded from BIOS version 1802 to 2004. I was confusing dates with versions. :rofl: So now you can check that off of your troubleshooting list. It’s just one of many. Thanks. :smiley:

1 Like

Have you tried using the LTS kernel

1 Like

Hi - I used the Garuda kernel manager to install the lts kernel 6.1.61-1.
It boots into a black screen.

I did some testing here:
Only Nvidia enabled.
Connected the other 2 monitors to my nvidia GPU.
3D gaming becomes impossible. The screen stutters and the frametime curve in mangohud looks like a rollercoaster.

X / nvidia don’t like multiple screens it seems…

Some more testing:

Disabled KDE compositor.
Stuttering was removed, but ugly screen tearing happened…

I managed to get LTS Kernel running by having garuda-update building nvidia dkms module.
But the issues stay the same sadly.