Issues with Lutris: Wine and Steam (Native)

Hello im new to Linux and Having some problems with Lutris while installing the Epic games store, the path i download it is on /home/skoody/Epic-games-store But after it tries setpriority to control niceness in the [-11,11] range it says wine: Read access denied for device L"\??\2:\", FS volume label and serial are not available. twice!

and for steam it says:[56255]: Running Steam on garuda Soaring 64-bit[56255]: STEAM_RUNTIME is enabled automatically[56327]: Steam runtime environment up-to-date![56255]: Can’t find ‘steam-runtime-check-requirements’, continuing anyway

heres my garuda-inxi:

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=45530e2a-5df3-4615-aa8b-221e7af814f4 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: MSI model: Z87-G45 GAMING (MS-7821) v: 1.0 serial: N/A
UEFI: American Megatrends v: 1.9 date: 07/21/2014
Info: model: Intel Core i7-4790 socket: BGA1155 bits: 64 type: MT MCP
arch: Haswell gen: core 4 level: v3 note: check built: 2013-15
process: Intel 22nm family: 6 model-id: 0x3C (60) stepping: 3
microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3953 high: 3984 min/max: 800/4000 base/boost: 3600/3800
scaling: driver: intel_cpufreq governor: performance volts: 1.2 V
ext-clock: 100 MHz cores: 1: 3945 2: 3984 3: 3967 4: 3968 5: 3922 6: 3970
7: 3972 8: 3901 bogomips: 57596
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ASUSTeK driver: nvidia
v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
(as of 2023-10; EOL~2026-12-xx) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-2021 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1c82 class-ID: 0300
Display: server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 46 s-size: 1059x596mm (41.69x23.46")
s-diag: 1215mm (47.84")
Monitor-1: HDMI-0 pos: primary res: 1920x1080 dpi: 69
size: 708x398mm (27.87x15.67") diag: 812mm (31.98") modes: N/A
Monitor-2: None-1-1 size-res: N/A modes: N/A
API: EGL v: 1.5 platforms: device: 1 drv: swrast gbm: drv: kms_swrast
surfaceless: drv: swrast inactive: wayland,x11,device-0
API: OpenGL v: 4.5 vendor: mesa v: 23.2.1-arch1.2 note: incomplete (EGL
sourced) renderer: llvmpipe (LLVM 16.0.6 256 bits)
API: Vulkan Message: No Vulkan data available.
Device-1: Intel 8 Series/C220 Series High Definition Audio
vendor: Micro-Star MSI 8 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:8c20 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.84 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet
vendor: Micro-Star MSI driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 1969:e091 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac:
Local Storage: total: 3.64 TiB used: 87.95 GiB (2.4%)
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
family: based SSDs size: 465.76 GiB block-size: physical: 512 B
logical: 512 B sata: 3.3 speed: 6.0 Gb/s tech: SSD serial:
fw-rev: 1B6Q temp: 31 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 148d 19h cycles: 654
written: 7.65 TiB
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD5003AZEX-00RKKA0 family: Caviar Black size: 465.76 GiB block-size:
physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s tech: N/A
serial: fw-rev: 0A80 temp: 36 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 1y 169d 2h cycles: 1781
Old-Age: UDMA CRC errors: 1090 alert: Bad cable/connection?
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD30NDZW-11A8JS0 size: 2.73 TiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
sata: 3.1 speed: 6.0 Gb/s tech: HDD rpm: 5400 serial:
fw-rev: 1034 drive-rev: 01.01A01 temp: 33 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 186d 3h cycles: 347
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 19.29 GiB (4.1%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 19.29 GiB (4.1%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 19.29 GiB (4.1%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 19.29 GiB (4.1%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.56 GiB used: 52.8 MiB (0.3%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
dev: /dev/zram0
System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 38 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 26%
Processes: 305 Uptime: 3h 51m wakeups: 0 Memory: total: 16 GiB
available: 15.56 GiB used: 6.76 GiB (43.4%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1881 libs: 552 tools: octopi,pamac,paru Shell: fish (sudo)
v: 3.6.1 running-in: fish inxi: 3.3.31
Garuda (2.6.17-1):
System install date: 2023-11-04
Last full system update: 2023-11-04 ↻
Is partially upgraded: No
Relevant software: snapper NetworkManager dracut nvidia-dkms
Windows dual boot: No/Undetected
Failed units:

I once installed the Epic Game Launcher via Lutris, was waaay too buggy and didn’t work well.

I would rather suggest using Heroic Game Launcher. You can sign in with your Epic and it downloads the games and installs them. I have - except for Steam - no good experiences with those launchers (GOG Galaxy neither) on Linux.

1 Like

ah ok didnt know that app thx

1 Like

but now i get the problem that heroic games starts the game but no window pops out is this normal? i even changed wine version and tried proton

What game is it?

Rocket League

seems to be an issue with rocket league; doesn’t work here either right now. Did work a few weeks back.

Stuff like that sometimes happens with Gaming on Linux. The last patch of Baldur’s Gate 3 broke my Linux-support for that game until the next hotfix a few hours later. Either just wait or contact the Heroic people in their discord.

but yesterday it worked with the lutris epic games and today i needed to install garuda cuz i did a stupid mistake

Is that a small white window while the games tries to launch with an “okay” or “cancel” button underneath it?

it says in the dependencies while i install epic games store and ubisoft i think

And then the installation aborts or what? Can you copy the exact log of what happens there?

From what I’ve read it’s an error that could just be ignored: Read access denied for device L"\\??\\f:\\", FS volume label and serial are not available. - WineHQ Forums

how can i send you the logs? the dependencies will close after a second

Sorry, I don’t quite understand.

I suppose you went to this website: Rocket League - Lutris

Then clicked on the “Epic Games version”, then launch Lutris via Browser. Then click install and install again, and then it starts installing (“Installing depencies”). That closes after a second? And then what?

no i do it on the pre installed lutris app not on the website i download epic games store it does and at last it says the error and the insttalling dependencies windows get away and a new window is there that says it failed, im gonna go off for now i come back later and test the infos from you/others

i got a new error since reboot now and the installing dependency log is not closing i can now send you the full process wanna see?

Looks like a yes :slight_smile:



About the error it is solved now somehow it works now idk why im so confused rn,
But thx for the link i will use it for another problems ^^

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.