Issues with Intel CometLake integrated graphics

Hello all,

I have trouble trying to boot into Garuda XFCE on my recently acquired Dell optiplex 9070 micro station. After choosing to boot into Gardua (either free or nonfree drivers) I just get a black screen.

Secure boot and fast boot are disabled, as well as most of Intel advanced features in BIOS. I tried iommu=soft to no avail. I tried i915.modeset=0 and removing quiet, which gets me a bit further but ultimately fails to start X. I have absolute faith in my live USB as I used it to install garuda on multiple other platforms without issues.

I successfully booted into Gardua KDE Dragonized and even installed it painlessly, and succeeded in booting a Xubuntu 20.04.3 live USB.

After hours of research, I read somewhere (Sorry I don´t have the link) about some bug or incompatibility with Intel CometLake graphics which was resolved in kernel 5.11...
As Garuda xfce is loaded with linux-lts kernel running 5.10, Gardua KDE is running linux-zen 5.15 and Xubuntu running 5.11, I guess that might be the root of my problem.

Is there a way to get my hands on a Garuda XFCE based off linux-zen 5.15 kernel to try it out ?

Also, for general information, why does the xfce version comes with linux-lts instead of linux-zen as the other versions ?

Thanks for your help,


Bump :slight_smile:

I've seen that for a quite similar case, someone was able to provide a linux-lts version of dragonized (Request for Garuda KDE Dr460nized ISO with Linux LTS kernel - #7)

Would it be possible to get a linux-zen version of xfce ?

Thanks in advance :slight_smile:

The developer of the Xfce version of Garuda is primarily after a more reliable, less developmental version of a desktop. That is why he uses the LTS kernel. It is unlikely the dev is intending to run any other kernel than the LTS kernel.

Have you tried booting to run level 3, and installing a new kernel manually?


Unfortunately I'm stuck at the live boot. I cant live boot to run level 3 but can't install without the graphical interface (as in i don´t know how to), let alone install with another kernel.

Maybe in a few days/weeks/months with a release of an updated lts kernel I will be able to boot into live XFCE then.

Thanks for your help


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.