Issues updating Garuda

Hi,

Today I began updating my Garuda installation after 2 weeks or so..

During the update process I got an error message and the update didn't proceed.. I tried updating the mirrorlist but that didn't help..

I was updating using "sudo pacman -Syyu"

Error message:
error: failed retrieving file 'garuda-setup-assistant-1.0.10-1-any.pkg.tar.zst.sig' from repo.jkanetwork.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

How to solve this issue?

thanks,

Update your mirrors.

2 Likes

No it didn't work..

I tired updating the mirrors and after that the downloading process did progress beyond the last part..

However this time I got a new error..

gpg: key : no user ID for key signature packet of class 10

The message is showing for every single application on my system.. It's asking whether i want to update the gpg key.. should i confirm?

4 Likes

@Naman

Hey.. this resource was really helpful and I finally know what went wrong...

A few days back I was cleaning up my system, and most likely I deleted all the keys when using bleachbit!

Can I recover from that situation? I tired using btrfs snapshot restore, but it doesn't look like it work!

What to do know?

Do I need to uninstall all programs and reinstall them??????

Copy and paste in your terminal:

sudo pacman -S archlinux-keyring &&  sudo pacman-key --refresh-keys && upd

I would not recommend to use bleachbit though, but that's just my opinion

4 Likes

@Stardust

Noted.. Which app would you recommend for cleaning and maintaining the system?

My opinion is none. You don't need that in 99% of cases. Just run a btrfs full balance when you feel you need that.

Did my suggestion solved your issue?

4 Likes

@Stardust

hey,

No luck..

while running the command you gave me, it is still showing Error: Could not update key....

Okay..

No.. still facing issues!

Please post the full output of your errors

1 Like

It's really long.. should i paste the complete thing?

If it's too long, use the privatebin and just post the link in your post

1 Like

@Stardust

Here:

https://bin.garudalinux.org/?e918d6ff933598c9#CzXqvQHo5XeDtJFDuef1v7w7hALfscRRKH6vk9cLNLcZ

Did you try the part of the tutorial:
If you have any other errors, there's the "final option"...
?

1 Like

No..

nothing is working..

[[email protected] ~]$ sudo rm /var/cache/pacman/pkg/*.part
[sudo] password for dibakarg:           
rm: cannot remove '/var/cache/pacman/pkg/*.part': No such file or directory
[[email protected] ~]$ sudo pacman -U /var/cache/pacman/pkg/{archlinux,chaotic}-keyring*.pkg.tar.zst
loading packages...
error: '/var/cache/pacman/pkg/archlinux-keyring*.pkg.tar.zst': could not find or read package
error: '/var/cache/pacman/pkg/chaotic-keyring*.pkg.tar.zst': could not find or read package
[[email protected] ~]$ 

Why do you want to install from cache? Just do

sudo pacman -Sy chaotic-keyring archlinux-keyring && sudo pacman -Su 
9 Likes

What I meant is:
sudo rm -fr /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate archlinux chaotic
sudo pacman-key --refresh-keys
sudo pacman -Syyu

3 Likes

Probably there's something I'm missing.
Have you tried the suggested steps in their order or simply reminding the deletion problem you skept them?

1 Like

Hey,

No, it finally worked!

So what happened is that I skipped the part where I had to delete the cache.. I just went ahead with running the provided commands in order...

So then when you recommended running the "if you are still getting errors" part, I thought I need to run the delete commands...

However, after deleting the Pacman cache, I tried to install the keyrings from the cache.. which was wrong as pointed out by @dr460nf1r3...

So after running the command he gave, the system updated perfectly and everything is working now...

Thanks, guys for all the help...
@c00ter thanks :slight_smile:
@Naman thanks :slight_smile:
@Stardust thanks :slight_smile:
@filo thanks :slight_smile:
@dr460nf1r3 thank you very very much :slight_smile:

Thanks, guys... really! Thank you so very much! :heartpulse:

4 Likes