Issues showing correct time

So I updated my system the other day, but only just noticed that my time is out, my timezone data is correct still, but some reason it doesnt sync, having a look at the arch wiki i tried some things to fix it, no luck, ignores hardware time and manual inputted time, running tzselect gives me this output, which I of course say yes to since the information is correct, but it doesnt correct the time data which in this instance is universal time that is shown.

The following information has been given:

Australia
Western Australia (most areas)

Therefore TZ='Australia/Perth' will be used.
Selected time is now:   Wed 29 Sep 2021 05:01:56 AWST.
Universal Time is now:  Tue 28 Sep 2021 21:01:56 UTC.
Is the above information OK?
1) Yes
2) No
System:    Kernel: 5.14.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
           root=UUID=c3868d62-fbad-48e3-95fd-3cc8bbdf84a6 rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
           Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP Pavilion TS 15 Notebook PC 
           v: 0881100000305E00000620100 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Hewlett-Packard model: 216C v: 30.26 serial: <filter> UEFI: Insyde v: F.19 
           date: 07/14/2016 
Battery:   ID-1: BAT0 charge: 14.7 Wh (100.0%) condition: 14.7/14.7 Wh (100.0%) volts: 16.9 
           min: 14.8 model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Full 
CPU:       Info: Quad Core model: AMD A10-5745M APU with Radeon HD Graphics bits: 64 type: MCP 
           arch: Piledriver family: 15 (21) model-id: 13 (19) stepping: 1 microcode: 6001119 
           cache: L2: 2 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 16769 
           Speed: 2096 MHz min/max: 1100/2100 MHz boost: enabled Core speeds (MHz): 1: 2096 
           2: 2096 3: 2063 4: 2035 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Richland [Radeon HD 8610G] vendor: Hewlett-Packard driver: radeon 
           v: kernel bus-ID: 00:01.0 chip-ID: 1002:990f class-ID: 0300 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] 
           vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu bus-ID: 01:00.0 
           chip-ID: 1002:6660 class-ID: 0380 
           Device-3: Realtek HP Truevision HD type: USB driver: uvcvideo bus-ID: 2-4:2 
           chip-ID: 0bda:571a class-ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: ati,radeon 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
           s-diag: 414mm (16.3") 
           Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6") 
           diag: 394mm (15.5") 
           OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 5.14.8-zen1-1-zen LLVM 12.0.1) 
           v: 4.3 Mesa 21.2.2 compat-v: 3.1 direct render: Yes 
Audio:     Device-1: AMD Trinity HDMI Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus-ID: 00:01.1 chip-ID: 1002:9902 class-ID: 0403 
           Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.8-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.37 running: yes 
Network:   Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard 
           driver: rt2800pci v: 2.3.0 port: 3000 bus-ID: 02:00.0 chip-ID: 1814:3290 class-ID: 0280 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard 
           driver: r8169 v: kernel port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200 
           IF: eno1 state: down mac: <filter> 
           IF-ID-1: anbox0 state: down mac: <filter> 
Bluetooth: Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A bus-ID: 02:00.1 
           chip-ID: 1814:3298 class-ID: 0d11 
           Report: bt-service: enabled,stopped note: tool can't run 
Drives:    Local Storage: total: 931.51 GiB used: 21.66 GiB (2.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM024 HN-M101MBB 
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s type: HDD 
           rpm: 5400 serial: <filter> rev: 0002 scheme: GPT 
Partition: ID-1: / raw-size: 292.97 GiB size: 292.97 GiB (100.00%) used: 21.64 GiB (7.4%) 
           fs: btrfs dev: /dev/sda5 maj-min: 8:5 
           ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 25.7 MiB (26.8%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 292.97 GiB size: 292.97 GiB (100.00%) used: 21.64 GiB (7.4%) 
           fs: btrfs dev: /dev/sda5 maj-min: 8:5 
           ID-4: /var/log raw-size: 292.97 GiB size: 292.97 GiB (100.00%) used: 21.64 GiB (7.4%) 
           fs: btrfs dev: /dev/sda5 maj-min: 8:5 
           ID-5: /var/tmp raw-size: 292.97 GiB size: 292.97 GiB (100.00%) used: 21.64 GiB (7.4%) 
           fs: btrfs dev: /dev/sda5 maj-min: 8:5 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 6.97 GiB used: 768 KiB (0.0%) priority: 100 
           dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 51.6 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: radeon temp: 49.0 C device: radeon temp: 48.0 C 
Info:      Processes: 224 Uptime: 19m wakeups: 5 Memory: 6.97 GiB used: 2.32 GiB (33.3%) 
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 
           pacman: 1806 lib: 511 Client: Unknown Client: garuda-assistant inxi: 3.3.06 

What does timedatectl show?

1 Like

Just in case... Have you checked the Archwiki here?
https://wiki.archlinux.org/title/System_time

In nothing helps above, do you use systemd-timesyncd and is enabled/active as per:
https://wiki.archlinux.org/title/Systemd-timesyncd
?

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.