Issues installing bootloader in 2019 Macbook Pro


I am trying to install Garuda LInux as a second OS on my 2019 Macbook Pro 16" using this guide.

However, I am not able to get past the installation from Live USB. The guides I have followed all suggest that I should be able to leave the default EFI partition as is and just install the base system on a free partition. When I tried doing this (using guided disk install), the installer makes it all the way to 91% and then hangs at the step of "Installing bootloader". At this point, the whole system is frozen, fans are at 100%, and nothing is responsive. I've left it here for 10 minutes with no progress.

After doing a reboot, and using rEFInd, I selected the Garuda install but I was thrown into a grub-rescue shell and I was unable to find any boot directory on the partition.

My second attempt at installing Garuda, I did a manual disk partition and I selected the main partition for Garuda and I did not make a partition for EFI and as such the bootloader install was skipped.

Doing this, I was able to finally complete the full install to 100%. However, upon restart, I am brought to a grub shell, and again, there are no boot files to use. I tried to issue a "boot" command, but grub keeps telling me: you need to load kernel first. However, I am still unable to find any vmlinuz or initrd files to supply grub. At this point, I am stuck and don't know how to move forward. All guides I've read online for Ubuntu say that their installer is okay with just using the main macOS EFI.

My third attempt, as with the second I did a manual partition install and put the base OS on my main partition. However, I also allocated a second partition with 300mb, FAT32, boot flag, mount point at: /boot/efi

Doing this, I actually got stuck at 89% for "configuring GRUB" and it froze here.

Did you do Guide: Running Arch on a 2018 MacBook Pro · GitHub step 4?

1 Like

Thanks for your response. I have not tried step 4 as I was not able to finish the install process and boot into the OS. However, if I do another install and skip bootloader, I can finish the install. Should I then do step 4 from the terminal in the live USB ?

No, I'd ignore the majority of the guide as it's intended for Arch.

Arch installation is a "from the ground up" fully custom approach - you perform each step manually.

Garuda takes the opposite approach and provides an opinionated pre-configured desktop installation.

If the bootloader step is failing then that's what needs to be looked at (but also keep in mind that Apple is not known for its Linux support).

If you have completed the installation up to the point of bootloader installation then you could try those steps manually:


Hi there, welcome to forums.

Straightforward answer: Garuda Linux can not run on your MacBook model.

Not only Garuda Linux, but most of Linux can not be installed on Macbook with T2 chips. There are some specificly designed Linux operating systems and kernels(like Linux-mpb) that can be installed on T2 chips.

Actually, the reason behind hanging on 91% is that at that point, installation of bootloader occurs. As T2 chips prevent installation of bootloader except Apple ones, it is struck and cannot be carried on further.

For further information, search on search engines.

Sorry for inconvenience.


Hello @Naman, and thank you and @jonathon both for your responses.

After spending much time, I was actually able to get Garuda starting the boot process on my macbook. I did this by skipping bootloader install and finishing the install process. I then chroot'd into my install and installed the "linux-mbp" kernel and headers as well as running "mkinitcpio -p linux-mbp". I also enabled "btrfs" in the mkinitcpio "hooks" section. I had to do a bunch of configuration changes for rEFInd to get it working, as well as installing the Apple T2 bridge driver which should in theory allow me to access SSD and keyboard/trackpad.

I think I'm almost at the finish line, however, I'm running into one more issue that I think may be btrfs related, as I am no btrfs expert. After doing a reboot, I was able to start booting into Garduda but I am stuck at the initial eagle photo with the white spinning dots underneath. As the OS has yet to load in the T2 bridge driver, I am unable to use keyboard to press "ESC" and see where it is getting stuck. As a result, I have updated some grub configs to boot me straight into the kernel without tty and I can see that it is stuck with the following error message:

ERROR: Root device mounted successfully, but /sbin/init does not exist.

sh:can't access tty; job control turned off

[rootfs /]#

At this point I am not sure how to proceed. I have gone back into the Live USB and chroot'd back into my install and verified that /sbin/init does indeed exist and it is correctly a symlink to systemd. I've also verified that my EFI config is correctly pointing to the root PARTUUID of the Garuda partition. I'm wondering if anything special needs to be done for btrfs? Are either of you able to offer any help on this?


1 Like

Dam, I was about to get a 2019 Mac Pro but did not even know they even added T2 chips..

now my question if the T2 is not able to work with all linux, what about m1 / m1 chips?

asking due to I may get a newer Mac / iMac but unsure if they can handle linux

  1. Check post date.
  2. Linux on M1 is alpha yet works. See
1 Like