Issues following a clean install

Nope, if I’m not mistaken, optimus-manager conflicts with garuda-nvidia-prime-config. You shouldn’t change that.

Looks like Optimus Manager is no longer a recommended option.

Quite happy that TV output worked at all; the integrated graphics have no access to HDMI output!

I used to have an issue with Hybrid mode causing high CPU usage when using TV output so I used NVIDIA mode; let’s see if I encounter that problem again.

Try installing envycontrol:

sudo pacman -S envycontrol

Works similarly to optimus-manager - you can find more information here:

btw I’m setting up VFIO GPU pass-through again, and when I run this, I get that

sudo mkinitcpio -g /boot/linux-custom.img
mkinitcpio: command not found

sudo pacman -S mkinitcpio
mkinitcpio-39.2-2 and garuda-dracut-support-1.1.0-1 are in conflict. Remove garuda-dracut-support?

What’s the deal between mkinitcpio and dracut?

1 Like

ok there’s good stuff in that Wiki; and various software I hadn’t used yet.

Is there a reason Hyprland isn’t installed by default?

Edit: oh Hyprland is an alternative to KDE?

Hmm, I’m going to say “yes”. I’m not sure what you think Hyprland is, but an oversimplified explanation would be it’s a window manager like Sway or i3. It would be something you install instead of KDE.

1 Like

For the boot freeze when BIOS is set to Optane, where should that be reported? Kernel issues look really complex to report, need to know what module, what specific department.

Does only Garuda behave that way? All Linux kernels?

Adding a more graceful way of handling the unsupported situation is definitely something that could be done.


What steps need to be taken to enable the Intel® Optane™ memory in Linux*?


System acceleration with Intel® Optane™ memory is supported on the Windows 10 64-bit operating system. It is not supported on any other operating systems, including Linux.

I guess you could report that to Intel, although from the documentation it doesn’t sound like they are interested in adding Linux support.

1 Like

Linux rejected Intel patches because they were hacks with many flaws to just allow EOMs to continue selling crappy HDDs with tiny flash drives.

If Linux doesn’t want to support it, better just handle it more gracefully. Let the user know to change BIOS settings.

The problem is that it’s a hidden setting in some BIOS, that require a specific hack to unlock. And then the user thinks the issue is with Linux and spends his time trying to figure out what’s wrong with Linux.

No, this is a case of user error. If you want your hardware to be fully compatible with Linux, do some research before you buy it.


Changing the fish config used to be a thing iirc, I’ll look into why it was changed soon.

1 Like

I just got to look into this. IMO this should be working:

We have the dr460nized preset here:

and this thing here to change the default:

… but: I now remember that fastfetch changed the flag a while ago. As we can see here, the sed no longer applies:

So we changed nothing intentionally other than something that broke over time.

Should be fixed with this commit:



Nice one, I was wondering where that custom flag was coming from!

Gotta love the self-destructing setup scripts. :boom: :sunglasses: :boom:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.