Issues after sleep or hibernate

Each time I bring my computer back up from sleep or hibernate, the desktop is blank, the windows are missing the title bar info, it’s there but no words or buttons. The selection box at the bottom of the main screen is blank and the icons only show up when I hover over them. I have to log out and back in to fix the issue. I have attached my journal errors. The password is garuda

System:
Kernel: 6.9.3-AMD-znver3 arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd-znver3
root=UUID=aec83d4b-e37e-4f72-b6ea-5c4d04c66879 rw rootflags=subvol=@
quiet resume=UUID=68203e8d-b3d1-404d-b55c-2c324445eb76 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: G10DK v: 1.0 serial: <superuser required>
uuid: <superuser required> UEFI: ASUSTek v: 310 date: 09/29/2022
CPU:
Info: model: AMD Ryzen 7 5700G with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000C
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 2105 high: 4300 min/max: 400/5288 scaling:
driver: amd-pstate-epp governor: performance cores: 1: 400 2: 4293 3: 400
4: 400 5: 4296 6: 4300 7: 400 8: 400 9: 400 10: 400 11: 400 12: 4299
13: 4297 14: 400 15: 4299 16: 4299 bogomips: 137652
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ASUSTeK
driver: nvidia v: 550.78 alternate: nvidia_drm non-free: 550.xx+
status: current (as of 2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none
off: DP-1,DP-2 empty: DP-3,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2504
class-ID: 0300
Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s ports: active: HDMI-A-2
empty: DP-4,DVI-D-1 bus-ID: 0c:00.0 chip-ID: 1002:1638 class-ID: 0300
temp: 42.0 C
Device-3: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 046d:0825
class-ID: 0102 serial: <filter>
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: nvidia,amdgpu d-rect: 4920x3000 display-ID: 0
Monitor-1: DP-1 pos: bottom-c res: 1920x1080 size: N/A modes: N/A
Monitor-2: DP-2 pos: bottom-r res: 1920x1080 size: N/A modes: N/A
Monitor-3: HDMI-A-2 pos: primary,top-left res: 1080x1920 size: N/A
modes: N/A
API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
drv: nvidia device: 2 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: nvidia x11: drv: zink
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
memory: 11.72 GiB display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 14 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3060 driver: nvidia v: 550.78 device-ID: 10de:2504
surfaces: xcb,xlib,wayland device: 1 type: integrated-gpu name: AMD
Radeon Graphics (RADV RENOIR) driver: mesa radv v: 24.1.1-arch1.1
device-ID: 1002:1638 surfaces: xcb,xlib,wayland device: 2 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.1.1-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:228e
class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 0c:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 0c:00.6 chip-ID: 1022:15e3
class-ID: 0403
Device-4: SteelSeries ApS Arctis Pro Wireless
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-2.3:6 chip-ID: 1038:1294 class-ID: 0300
Device-5: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 046d:0825
class-ID: 0102 serial: <filter>
API: ALSA v: k6.9.3-AMD-znver3 status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Lite-On driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 08:00.0 chip-ID: 10ec:c822
class-ID: 0280
IF: wlp8s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: c000 bus-ID: 0a:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Lite-On Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:7 chip-ID: 04ca:4005
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 2.05 TiB used: 774.87 GiB (36.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
SDBPNPZ-256G-1002 size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 21106000 temp: 39.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A8S0 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WDBNCE5000PNC
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 00RL scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WDBNCE5000PNC
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 00RL scheme: GPT
Partition:
ID-1: / raw-size: 187.18 GiB size: 187.18 GiB (100.00%)
used: 61.95 GiB (33.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 187.18 GiB size: 187.18 GiB (100.00%)
used: 61.95 GiB (33.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 187.18 GiB size: 187.18 GiB (100.00%)
used: 61.95 GiB (33.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 187.18 GiB size: 187.18 GiB (100.00%)
used: 61.95 GiB (33.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 46.37 GiB used: 6.9 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
ID-2: swap-2 type: partition size: 50.99 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 51.0 C mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (rpm): cpu: 900
Info:
Memory: total: 48 GiB note: est. available: 46.37 GiB used: 5.04 GiB (10.9%)
Processes: 406 Power: uptime: 1d 16m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 18.51 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2184 libs: 549 tools: octopi,paru Compilers:
clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-03-17
Last full system update: 2024-06-07 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:            NetworkManager-wait-online.service

garuda-inxi

journal errors

```text
System:
  Kernel: 6.9.3-AMD-znver3 arch: x86_64 bits: 64 compiler: gcc v: 14.1.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd-znver3
    root=UUID=aec83d4b-e37e-4f72-b6ea-5c4d04c66879 rw rootflags=subvol=@ quiet
    resume=UUID=68203e8d-b3d1-404d-b55c-2c324445eb76 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: G10DK v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: ASUSTek v: 310 date: 09/29/2022
CPU:
  Info: model: AMD Ryzen 7 5700G with Radeon Graphics bits: 64 type: MT MCP arch: Zen 3 gen: 4
    level: v3 note: check built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80)
    stepping: 0 microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 3324 high: 4326 min/max: 400/5288 scaling: driver: amd-pstate-epp
    governor: performance cores: 1: 4300 2: 4300 3: 4293 4: 400 5: 4264 6: 4300 7: 4299 8: 400 9: 400
    10: 4300 11: 4304 12: 4300 13: 4300 14: 400 15: 4326 16: 4298 bogomips: 137652
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ASUSTeK driver: nvidia v: 550.78
    alternate: nvidia_drm non-free: 550.xx+ status: current (as of 2024-04; EOL~2026-12-xx)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none off: DP-1,DP-2
    empty: DP-3,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2504 class-ID: 0300
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series] vendor: ASUSTeK
    driver: amdgpu v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: HDMI-A-2
    empty: DP-4,DVI-D-1 bus-ID: 0c:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 44.0 C
  Device-3: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 046d:0825 class-ID: 0102
    serial: <filter>
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0 compositor: kwin_wayland
    driver: X: loaded: amdgpu,nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
    dri: radeonsi gpu: nvidia,amdgpu d-rect: 4920x3000 display-ID: 0
  Monitor-1: DP-1 pos: bottom-c res: 1920x1080 size: N/A modes: N/A
  Monitor-2: DP-2 pos: bottom-r res: 1920x1080 size: N/A modes: N/A
  Monitor-3: HDMI-A-2 pos: primary,top-left res: 1080x1920 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0 drv: nvidia device: 2
    drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland:
    drv: nvidia x11: drv: zink inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78 glx-v: 1.4 direct-render: yes
    renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2 memory: 11.72 GiB display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 14 device: 0 type: discrete-gpu name: NVIDIA GeForce RTX 3060
    driver: nvidia v: 550.78 device-ID: 10de:2504 surfaces: xcb,xlib,wayland device: 1
    type: integrated-gpu name: AMD Radeon Graphics (RADV RENOIR) driver: mesa radv
    v: 24.1.1-arch1.1 device-ID: 1002:1638 surfaces: xcb,xlib,wayland device: 2 type: cpu
    name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.1-arch1.1 (LLVM 17.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
  Device-1: NVIDIA GA106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1
    chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK drive
r: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 0c:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 0c:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Device-4: SteelSeries ApS Arctis Pro Wireless driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2.3:6 chip-ID: 1038:1294
    class-ID: 0300
  Device-5: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 046d:0825 class-ID: 0102
    serial: <filter>
  API: ALSA v: k6.9.3-AMD-znver3 status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lite-On
    driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 08:00.0 chip-ID: 10ec:c822 class-ID: 0280
  IF: wlp8s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: c000 bus-ID: 0a:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Lite-On Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-8:7 chip-ID: 04ca:4005 class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.1 lmp-v: 10 status:
    discoverable: no pairing: no class-ID: 6c0104
Drives:
  Local Storage: total: 2.05 TiB used: 775.44 GiB (36.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530 SDBPNPZ-256G-1002
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD
    serial: <filter> fw-rev: 21106000 temp: 38.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA100 size: 931.51 GiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter> fw-rev: A8S0
    scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WDBNCE5000PNC size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 00RL scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WDBNCE5000PNC size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 00RL scheme: GPT
Partition:
  ID-1: / raw-size: 187.18 GiB size: 187.18 GiB (100.00%) used: 62.52 GiB (33.4%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 584 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 187.18 GiB size: 187.18 GiB (100.00%) used: 62.52 GiB (33.4%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 187.18 GiB size: 187.18 GiB (100.00%) used: 62.52 GiB (33.4%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 187.18 GiB size: 187.18 GiB (100.00%) used: 62.52 GiB (33.4%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 46.37 GiB used: 6.9 MiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 
50.99 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 54.8 C mobo: N/A gpu: amdgpu temp: 45.0 C
  Fan Speeds (rpm): cpu: 900
Info:
  Memory: total: 48 GiB note: est. available: 46.37 GiB used: 4.8 GiB (10.3%)
  Processes: 437 Power: uptime: 1d 9m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 18.51 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 2184 libs: 549 tools: octopi,paru Compilers: clang: 17.0.6
    gcc: 14.1.1 Client: shell wrapper v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-03-17
  Last full system update: 2024-06-07 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            NetworkManager-wait-online.service 

 The template above should be deleted before posting your help request.

kwin produces openGL errors and your nvidia card produces shader errors…Try switching to x11, wayland and nvidia don’t really like each other.

1 Like

Yes, either try x11, Remove the timers for sleep/hibernate an manually just shut off the screen. You can try the new beta 555 drivers too if you wish. I cant say 100% this driver will solve it as i haven’t tested it personally with sleep/hibernate.

You can also follow @BluishHumility steps here Mouse pointer corrupt after sleep - #4 by BluishHumility

2 Likes

These journal logs cannot show the real source of the problem.
Try to collect logs from a clean boot session, after suspending and waking up the system.

  1. Reboot
  2. Login KDE Wayland
  3. After a couple of minutes, suspend (sleep or hibernate)
  4. After a minute, wake it up and get full logs (journalctl -b ), keep the part just before suspend to now
  5. Disable (password) locking on suspend (in System Settings somewhere)
  6. Suspend, wake up and get logs from the new suspend point to now

Post logs and include the journalctl command you used.

1 Like