Issues about Japanese character input(im japanese im new here)

Hello. Nice to meet you, my name is Kenyu. I am Japanese. I’m still learning English, so I use translation. I love Garuda Linux and use it often. I recently deleted Windows and switched to Garuda. I’m currently having multiple issues. The first one is about Japanese input. I am using japanese (fcitx5). As I type in Roman letters, Japanese pops up and I enter them, but perhaps in a browser, when I enter characters, certain Roman alphabets are written in the text input field instead of being input in Japanese. Masu. For example, if you try to enter {ohayou} in Japanese, a pop-up will start inputting the Japanese word Good morning, but it often won’t be possible to input all of the characters, and multiple letters of the alphabet will be input directly. (ohayou=oaou) etc. Kate allows you to input normally. It seems weird when using a browser. (I will post a photo of when Kate and the browser did gravity.)

I did a lot of research, but couldn’t figure it out.
It would be very helpful if you could tell me how to deal with it. please.

PSI have screenshots


What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed

We know that :wink: Spam filter.

1 Like

Hello. nice to meet you. Thank you for your reply
Sorry for posting in the wrong way
I edited it a little. Is this okay?



He is asking you to stick to the issue template.
Could you please provide the output of the garuda-inxi command?


Hi there, welcome to the forum.
The request was related to the output from terminal of garuda-inxi (basically our system specs), formatted as terminal text, like this:
paste the output of garuda-inxi

output appears like this
<╭─rodorin@rodorinPC in ~
╰─λ garuda-inxi
Kernel: 6.7.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=dc0b2e6a-ab9f-426d-bbcd-eafc233813db rw rootflags=subvol=@
quiet resume=UUID=45b71144-8e18-4fd0-9fe5-79293cefb5ae loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.1 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop Mobo: ASRock model: B660 Pro RS serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends LLC. v: 6.03
date: 01/14/2022
Info: model: 12th Gen Intel Core i5-12600KF bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 2
microcode: 0x32
Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled
cache: L1: 864 KiB desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB
L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB L3: 20 MiB desc: 1x20 MiB
Speed (MHz): avg: 799 high: 800 min/max: 800/4900:3600 scaling:
driver: intel_pstate governor: powersave cores: 1: 794 2: 800 3: 800 4: 800
5: 796 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800
15: 800 16: 800 bogomips: 117964
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: ASUSTeK
driver: nvidia v: 550.54.14 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2024-02; EOL~2026-12-xx) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-2022 pcie: gen: 3 speed: 8 GT/s
lanes: 16 ports: active: none off: DP-2,HDMI-A-1
empty: DP-1,HDMI-A-2,Unknown-2 bus-ID: 01:00.0 chip-ID: 10de:1e07
class-ID: 0300
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting,nouveau
alternate: fbdev,nv,vesa gpu: nvidia,nvidia-nvswitch display-ID: :0
screens: 1
Screen-1: 0 s-res: 5760x2160 s-dpi: 103 s-size: 1420x533mm (55.91x20.98")
s-diag: 1517mm (59.71")
Monitor-1: DP-2 note: disabled pos: primary,left
model: Philips PHL 436M6VBR serial: <filter> built: 2018 res: 3840x2160
hz: 60 dpi: 104 gamma: 1.2 size: 941x529mm (37.05x20.83")
diag: 1080mm (42.5") ratio: 16:9 modes: max: 3840x2160 min: 640x480
Monitor-2: HDMI-A-1 mapped: HDMI-0 note: disabled pos: right
model: Idek Iiyama PL3291 serial: <filter> built: 2016 res: 1920x1080 hz: 60
dpi: 70 gamma: 1.2 size: 698x393mm (27.48x15.47") diag: 801mm (31.5")
ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.54.14
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 2080 Ti/PCIe/SSE2
memory: 10.74 GiB
API: Vulkan v: 1.3.279 layers: 14 device: 0 type: discrete-gpu name: NVIDIA
GeForce RTX 2080 Ti driver: nvidia v: 550.54.14 device-ID: 10de:1e07
surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe (LLVM 17.0.6 256
bits) driver: mesa llvmpipe v: 24.0.2-arch1.2 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Alder Lake-S HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:7ad0 class-ID: 0403
Device-2: NVIDIA TU102 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f7 class-ID: 0403
Device-3: Logitech G733 Gaming Headset
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-4.4:9 chip-ID: 046d:0ab5 class-ID: 0300
API: ALSA v: k6.7.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1a1d class-ID: 0200
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager,systemd-timesyncd
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:5
chip-ID: 0a12:0001 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 2.1
lmp-v: 4 status: discoverable: no pairing: no class-ID: 6c0104
Local Storage: total: 5.48 TiB used: 200.72 GiB (3.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 2B2QEXE7 temp: 27.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A750 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDH3 1T00
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 40RL scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT525MX300SSD1
size: 489.05 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: R060 scheme: GPT
ID-5: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD30EZRZ-00GXCB0 size: 2.73 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 0A80 scheme: GPT
ID-1: / raw-size: 431.16 GiB size: 431.16 GiB (100.00%)
used: 200.72 GiB (46.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 431.16 GiB size: 431.16 GiB (100.00%)
used: 200.72 GiB (46.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 431.16 GiB size: 431.16 GiB (100.00%)
used: 200.72 GiB (46.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 431.16 GiB size: 431.16 GiB (100.00%)
used: 200.72 GiB (46.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 34.3 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 31.18 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
System Temperatures: cpu: 28.0 C mobo: N/A gpu: nvidia temp: 34 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 25%
Memory: total: 32 GiB available: 31.18 GiB used: 11.46 GiB (36.8%)
Processes: 434 Power: uptime: 20m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.43 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2223 libs: 606 tools: octopi,pamac,paru,trizen
pm: appimage pkgs: 0 Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi
default: fish v: 3.7.0 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-02-12
Last full system update: 2024-03-11
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:            vmware.service

Hello. nice to meet you. It would be helpful if you could let me know. I sent him the results of the AI command. Does it match?

thank you so much tell me^^

1 Like

hello and welcome Kenyuu-san :wave:t3:


I actually have no experience for these aspects (I hope maybe some Japanese users will jump in), but I just try to link you some articles to read:
Fcitx5 - ArchWiki (starting point)
Localization/Japanese - ArchWiki (probably no so useful in this case)
Issues · fcitx/fcitx5 · GitHub (maybe you’ll find some of your issues)


thank you so much^^ im glad meet you BruceLakeriver san^^

1 Like

thank you so much i will reading^^


I think you’ve read this, but in case you didn’t find it, I hope it helps
Fcitx5 - ArchWiki
Fcitx5 - ArchWiki (jp)

Input method - ArchWiki
インプットメソッド - ArchWiki

Localization/Japanese - ArchWiki
ローカリゼーション - ArchWiki

Mozc - ArchWiki
Mozc - ArchWiki

Setting up Japanese Romaji keyboard [SOLVED] / Newbie Corner / Arch Linux Forums

but I have no experience with input methods (nor Japanese language)


ArchLinuxで日本語入力 #Linux - Qiita
新・自分用 Arch Linux 設定メモ
all I find say

sudo pacman -S fcitx5-im fcitx5-mozc

(edit: I forgot the ‘5’ before, copy-paste from outdated information)


Hello. Thank you for providing me with various referral links.
I tried reading, but I couldn’t find anyone with the same symptoms as me.
I’m thinking of continuing the search or using it as is, although it’s difficult to use.

1 Like

I add 日本語 to the Languages categories, hope it helps a little. :slight_smile:

And was translate well bei deepl :smiley:

thank you very much.^^
I like garuda and would like to continue using it.^^
On other Linux distributions you can especially type normally
I think there’s something
I have a question. I still have a question, uuoo should I create a new thread and ask it? (One question per location thread)

Yes please :slight_smile:

1 Like

thank you very much.^^
I will do my best

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.