Issue with Zed and libldap

Hello, i've some problems after reinstall Garuda Linux with zed free.

I've installed it with the debian package first and get this error.

zed_free: error while loading shared libraries: libldap_r-2.4.so.2: cannot open shared object file: No such file or directory

So i've tried to reinstall openldap and libldap but nothing.

Someone can help me for this error ? thank's

let see

inxi -Faz
1 Like

Don't install package archives intended for different distributions. It will expect a different version of libraries and/or the local system will have no idea how to handle dependencies.

Instead, use the AUR package: AUR (en) - zedfree

5 Likes

Thank's for your reply

The command inxi -Faz
System:    Kernel: 5.15.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=f2ddd5b6-40b5-49da-8251-4c4b7455fac5
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=e319ff5a-ce39-4ce7-a73b-3795275a09e4 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: HP product: HP ProBook 450 G6 v: N/A serial: <superuser required> Chassis:
type: 10 serial: <superuser required>
Mobo: HP model: 8538 v: KBC Version 51.1E.00 serial: <superuser required> UEFI: HP
v: R71 Ver. 01.03.00 date: 04/29/2019
Battery:   ID-1: BAT0 charge: 41.6 Wh (100.0%) condition: 41.6/41.6 Wh (100.0%) volts: 13.0 min: 11.6
model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Full
CPU:       Info: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Kaby Lake note: check
family: 6 model-id: 8E (142) stepping: B (11) microcode: EA cache: L1: 256 KiB L2: 1024 KiB
L3: 8 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999
Speed: 4272 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 4272 2: 4384 3: 3182 4: 4402
5: 4240 6: 4520 7: 4442 8: 3913
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Hewlett-Packard driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300
Device-2: Lite-On HP HD Camera type: USB driver: uvcvideo bus-ID: 1-2:2 chip-ID: 04ca:7095
class-ID: 0e02
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: i915
note: n/a (using device driver) display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:9dc8 class-ID: 0403
Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:9df0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard
driver: r8169 v: kernel port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8
bus-ID: 1-10:4 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block:
hardware: no software: no address: <filter>
Drives:    Local Storage: total: 700.51 GiB used: 25.11 GiB (3.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB512HAJQ-000H1 size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: EXA73H1Q temp: 29.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G size: 223.57 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 5A scheme: GPT
Partition: ID-1: / raw-size: 206.22 GiB size: 206.22 GiB (100.00%) used: 25.11 GiB (12.2%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 580 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 206.22 GiB size: 206.22 GiB (100.00%) used: 25.11 GiB (12.2%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 206.22 GiB size: 206.22 GiB (100.00%) used: 25.11 GiB (12.2%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 206.22 GiB size: 206.22 GiB (100.00%) used: 25.11 GiB (12.2%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.05 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
maj-min: 8:3
ID-2: swap-2 type: zram size: 15.5 GiB used: 1.3 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 49.0 C pch: 37.0 C mobo: 0.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 348 Uptime: 2h 8m wakeups: 2 Memory: 15.5 GiB used: 5.17 GiB (33.4%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 2015 note: see --pkg
apt: 1 pacman: 2014 lib: 358 Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole
inxi: 3.3.09

So i've installed the debian package and after remove to install the Aur zedfree but it's the same

Just tried on a VM.
It wants 2.4, installed is 2.6.

3 Likes

i want understand your problem,
when this error occured ? on boot ..., in installation garuda process ...,
have you install garuda yet

1 Like

The error is comming when i launch the zed_free command.

Installation is ok.

And sure i'm already on Garuda

I have not inspected it, but you may be able to make a small change in the PKGBUILD.

3 Likes

libldap24 is in the AUR - the Zed PKGBUILD should likely include it as a dependency.

It will be worth reporting this to the AUR package maintainer so it can be fixed for everyone.

4 Likes

This appears to resolve the dependency. The application does launch, beyond that :woman_shrugging:

3 Likes

So how i can install it with the dependency ?
i've just added that to the pkgbuild

depends=("libxslt" "qt5-base" "hicolor-icon-theme" "libldap24")

But same error after makepkg -si

Ok so, here are the commands to make zed work

git clone https://aur.archlinux.org/libldap24.git
cd libldap24
gpg --recv-keys 7F67D5FD1CE1CBCE
makepkg -si
git clone https://aur.archlinux.org/zedfree.git
cd zedfree
makepkg -si

Thank's all for your help !

1 Like

Did you report the need for the additional dependency to the AUR package maintainer? If not, please do so.

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.