Issue with World of Warcraft Legion using Lutris

Post your terminal/konsole in- and output as text (no pictures) from:

System:
Kernel: 5.16.0-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9f4256fc-0f6b-4148-bbb6-deed31deeacc rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: A320M Pro4-F serial: <superuser required>
UEFI-[Legacy]: American Megatrends v: P2.20 date: 07/27/2020
CPU:
Info: model: AMD Ryzen 3 3100 bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3535 high: 3796 min/max: 2200/3906 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3592 2: 3285
3: 3366 4: 3796 5: 3626 6: 3430 7: 3596 8: 3595 bogomips: 57492
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Baffin [Radeon RX 550 640SP / RX 560/560X] driver: amdgpu
v: kernel bus-ID: 06:00.0 chip-ID: 1002:67ff class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 96
size: 510x290mm (20.1x11.4") diag: 587mm (23.1")
OpenGL: renderer: AMD Radeon RX 550 Series (POLARIS11 DRM 3.44.0
5.16.0-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.3 direct render: Yes
Audio:
Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X]
driver: snd_hda_intel v: kernel bus-ID: 06:00.1 chip-ID: 1002:aae0
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel bus-ID: 08:00.4 chip-ID: 1022:1487
class-ID: 0403
Sound Server-1: ALSA v: k5.16.0-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel port: f000 bus-ID: 05:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 2.04 TiB used: 75.25 GiB (3.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: PNY model: CS900 240GB SSD
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0615 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000VN004-2E4164
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5900 serial: <filter> rev: SC60 scheme: MBR
Partition:
ID-1: / raw-size: 223.54 GiB size: 223.54 GiB (100.00%)
used: 15.04 GiB (6.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 60.21 GiB (3.2%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-3: /var/log raw-size: 223.54 GiB size: 223.54 GiB (100.00%)
used: 15.04 GiB (6.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 223.54 GiB size: 223.54 GiB (100.00%)
used: 15.04 GiB (6.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.55 GiB used: 359.8 MiB (2.3%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 40.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 312 Uptime: 1h 37m wakeups: 0 Memory: 15.55 GiB
used: 2.62 GiB (16.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1799 lib: 541 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.11

Hello! First to say I was using Manjaro before Garuda and this problem was with Manjaro too.

In World of Warcraft, when I use my mouse and keyboard the screen blinks and monitor shows like changing resolution to same resolution. I've tried running in virtual desktop from Lutris settings and that doesn't help. It happens when game is on fullscreen or borderless. If i play windowed there is no problem. I am using my video card with DVI-VGA dongle.

I am not very advanced Linux user, so i don't know how to fix that. Thanks in advance :slight_smile:

Hi there, welcome!
I'm not a gamer, so I cannot help much here...
In the past I read (and the suggestion sometimes helped) that palying games with steam can have an effect on the compositor.
So you may want to try to make a alt+shift+f12 before playing (to disable it) and then again to re-enable it after playing.

1 Like

I've just tried this, but it doesn't fix the issue :frowning:

Since you said it only effects full screen and not windowed, it sounds like a frame rate issue (since window modes are usually forced to vsync). I don't play WoW, but a lot of games have issues with adaptive vsync (make sure that is off). Try turning on regular vsync or set a hard cap on frames if the game's options allow it (something like 60 frames or below since your monitor is reporting 60 hz).

1 Like

Enabling vsync + limiting the FPS to 60 doesn't help too :frowning:

What is the game's full screen resolution set to? Also, are you experiencing this issue in any other games in full screen?

It's set to 1080p. I don't play any other games. If i set fullscreen at lower resolution for example, the problem still persists.

What are you using for a runner? I was just searching the Lutris reddit and people had a better time using the latest Proton GE for WoW.

If that doesn't fix it, could you try a free game of some sort that can run in full screen for troubleshooting purposes?

1 Like

I am using lutris-fshack-6.21-6. With older versions the problem still persists.

I have 2 questions:

  1. How to run through that Proton GE? I am very new to Linux.

  2. How to check if that adaptive sync is turned off?


I've searched and found that I can use Proton as custom runner in Lutris and I am using Gaming edition of Garuda which I think includes the Proton. The question is how to set that up in Lutris?

latest proton-GE

How to use it: Method to use Proton-GE with Lutris - r/wine_gaming

(sorry I couldn't find you better sources of information. The Lutris site is down at the moment)


Adaptive sync was just something I wanted you to check in the game's options. Not all games have this option.

1 Like

I've tested with lutris-ge-7.0rc3-1 and wine 6.3-8-proton and that "ge" version really improves the performance, but the problem with screen blinking still persists with both of the new runners :frowning: .

Maybe find a free game on Steam to test something else fullscreen?

(At this point I think we need to troubleshoot this at a different angle because I could not find a similar issue on the Lutris reddit for WoW.)

I think it's something with refresh rate. Is there a way to force my monitor to work at 59Hz?

If it isn't listed in the drop down in KDE's System Settings > Display Configuration ; you can manual configure Xorg Xorg - ArchWiki (although newer versions of Xorg are auto-configuring, so manual configuration should not be needed. That and your regular desktop isn't blinking outside of a game)

That being said, I don't think that is the issue or you would be experiencing the flashing all the time and not just in a game. And hard forcing refresh rates on monitors can be risky.

I can only assume this is an odd screen tearing issue without testing other games. In the game's options try vertical sync on with triple buffing on as well. if that doesn't work, match up the foreground and background FPS to something just below 60, and keep tinkering with it to you find your best setting. Source: [Solved] Screen Tearing in WOW | Mos Tech Tips (Method 1 and 2 are the only ones applicable here)

What model is your monitor, by the way?

My monitor is Samsung SMB2330HD, It's TV/Monitor connected through VGA.

I've found something! Some WoW wiki says to set Option "UseFastTLS" "2" in /etc/X11/xorg.conf but i think this is outdated. How to set that in this newer version of Linux and will it help, what do you think?

Since that page lists its outdated on the wow wiki and I can't find any info about it on AMDGPU - ArchWiki , I can only guess that is the case that is outdated information. Sadly, I have zero experience using an AMD card with Garuda yet (I know, I know... blame the current GPU market though lol), so I can only point you to Arch Wiki for more information on that.

I have looked down the PDF for your monitor at https://downloadcenter.samsung.com/content/UM/201008/20100820090207453/BN59-01091B-01Eng.pdf and found it is indeed a 60 hz monitor, so auto configs are doing their job fine there. I would recommend trying to connect to your monitor by HDMI as the next troubleshooting step.

1 Like

The problem is that only the VGA port works like "monitor". The HDMIs doesn't wake up on signal, when pc go to sleep, the monitor turns off.

I have another idea. Can you tell me how to remove the border of that specific window, so i can play on 1920x1080 windowed not maximized and this will be a fix i think.

Edit: I've made too many posts for first day, so I edit this one.

I've found something interesting. The issue happens (the blinking) when there is a FPS drop! Let's say I play with ~190 fps and there is some new object on the map that drops the frames to ~130, then the blinking happens.

alt+F3 , More Actions, No Border. (can use the same steps to re-enable them if you need to)