Issue with emulators

Hello, new to garuda. I'm sure i'm just missing a hotkey or command, but my citra and ryujinx windows seem to be missing an important part of them. The top bar where you can select options like "file" and "options".

Again!

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

Welcome :slight_smile:

1 Like
System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=f986ecbf-ab7e-4c90-b777-3ea809b23e9c
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: OVERPOWERED product: OP-LP3 v: Standard serial: <filter>
Mobo: OVERPOWERED model: GK7CN6S v: Standard serial: <filter> UEFI: American Megatrends
v: N.1.08 date: 11/28/2018
Battery:   ID-1: BAT0 charge: 18.7 Wh (39.0%) condition: 47.9/46.7 Wh (102.4%) volts: 12.6 min: 11.4
model: standard type: Li-ion serial: <filter> status: Charging
CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake note: check
family: 6 model-id: 9E (158) stepping: A (10) microcode: EA cache: L2: 9 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52799
Speed: 4000 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 4000 2: 4001 3: 4001 4: 4000
5: 4000 6: 4000 7: 4001 8: 4001 9: 4001 10: 4043 11: 4102 12: 4097
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Tongfang Hongkong Limited
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c20 class-ID: 0300
Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:5 chip-ID: 04f2:b68b
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 dpi: 128 size: 382x215mm (15.0x8.5") diag: 438mm (17.3")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Tongfang Hongkong Limited driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348
class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 10de:10f1 class-ID: 0403
Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Tongfang Hongkong Limited driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8
bus-ID: 1-14:6 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 5060
bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:    Local Storage: total: 2.05 TiB used: 68.83 GiB (3.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20SPZX-22UA7T0 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 1A01 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Motile model: SSM28256GPTCB3B-S112612 size: 238.47 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 61.2
scheme: GPT
Partition: ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 68.83 GiB (28.9%) fs: btrfs
dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 68.83 GiB (28.9%) fs: btrfs
dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 68.83 GiB (28.9%)
fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 68.83 GiB (28.9%)
fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.48 GiB used: 34.2 MiB (0.2%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 58.0 C mobo: 55.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 355 Uptime: 48m wakeups: 1 Memory: 15.48 GiB used: 5.24 GiB (33.8%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1657 lib: 476
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Check KDE settings.
Update needed too, Kernel: 5.15.4 in moment.

Not all apps support the KDE global appmenu. Some use a Gnome style hamburger menu, some default to it being integrated in the window. In the latter case usually pressing alt hides/unhides it. But since this is according to my brief research "An experimental Switch emulator", I would open an issue in its Github if you have further problems.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.