Issue: Fish konsole; Error when (tab) autofill attempt: pacman -S pcg

Hey!

When typing sudo pacman -S <pcg_name>, if I will use tab to fill/get package names I will get:

╰─λ sudo pacman -S chromerror: Invalid value "rules" for '--style <components>': Unknown style, 'rules'

For more information try --help

I removed fish, then .config, installed - everything works fine,
but when I will reset Fish config through Garuda Assistant

The problem seems to be in 107 line of ~/.config/fish/config.fish

I couldn't find much on google...
What could be the reason?

garuda inxi:

╭─[email protected] in ~
╰─λ garuda-inxi
System:
Kernel: 5.19.7-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=589bcf4e-e73a-4e0a-8427-81e783d93a99 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Laptop 15s-eq2xxx v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 887A v: 59.11 serial: <superuser required> UEFI: AMI
v: F.15 date: 08/17/2021
Battery:
ID-1: BAT0 charge: 38.5 Wh (99.2%) condition: 38.8/38.8 Wh (100.0%)
volts: 12.9 min: 11.3 model: HP Primary type: Li-ion serial: <filter>
status: not charging
CPU:
Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x68 (104) stepping: 1 microcode: 0x8608103
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 2041 high: 2100 min/max: 1400/4056 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2100 2: 1397
3: 2100 4: 2100 5: 2100 6: 2100 7: 2100 8: 2100 9: 2100 10: 2100 11: 2100
12: 2100 bogomips: 50307
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
protection
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Lucienne vendor: Hewlett-Packard driver: amdgpu v: kernel
arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie:
gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: HDMI-A-1,eDP-1 empty: none bus-ID: 03:00.0 chip-ID: 1002:164c
class-ID: 0300
Device-2: Luxvisions Innotech HP TrueVision HD Camera type: USB
driver: uvcvideo bus-ID: 1-3:3 chip-ID: 30c9:0035 class-ID: fe01
serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
s-diag: 1052mm (41.43")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left model: LG
(GoldStar) FHD serial: <filter> built: 2021 res: 1920x1080 hz: 75
dpi: 102 gamma: 1.2 size: 480x270mm (18.9x10.63") diag: 551mm (21.7")
ratio: 16:9 modes: max: 1920x1080 min: 720x400
Monitor-2: eDP-1 mapped: eDP pos: primary,right model: LG Display 0x062e
built: 2019 res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2
size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.47 5.19.7-zen2-1-zen)
v: 4.6 Mesa 22.1.7 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
driver: snd_rn_pci_acp3x v: kernel
alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_sof_amd_renoir
pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound Server-1: ALSA v: k5.19.7-zen2-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8822ce v: N/A modules: rtw88_8822ce
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 01:00.0
chip-ID: 10ec:c822 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-4:4 chip-ID: 0bda:b00c class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 715.41 GiB used: 19.06 GiB (2.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
SDBPNPZ-512G-1006 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: HPS2 temp: 33.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: GOODRAM
model: SSDPR-HL100-256 size: 238.47 GiB block-size: physical: 4096 B
logical: 512 B type: SSD serial: <filter> rev: 1101 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 150 GiB size: 150 GiB (100.00%) used: 19 GiB (12.7%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 62.5 MiB
(24.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 150 GiB size: 150 GiB (100.00%) used: 19 GiB
(12.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 150 GiB size: 150 GiB (100.00%) used: 19 GiB
(12.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 150 GiB size: 150 GiB (100.00%) used: 19 GiB
(12.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 14.97 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 58.8 C mobo: N/A gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): fan-1: 0 fan-2: 0
Info:
Processes: 310 Uptime: 3h 44m wakeups: 6565 Memory: 14.98 GiB used: 4.11
GiB (27.5%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pacman: 1929 lib: 524
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20
Garuda (2.6.7-1):
System install date:     2022-09-08
Last full system update: 2022-09-09 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Hi there, welcome to the forum.
I think it has just been fixed here (garuda-fish-config), although showing up in a different context

3 Likes

Checked

System is updated.
I have the same (newest) config.
I also tried to reset Fish config via Garuda Assistant.

Issue persist

What does line 107 say?

1 Like

lines 107-108:

# Replace some more things with better alternatives
alias cat='bat --style header--style snip --style changes --style header'
[ ! -x /usr/bin/yay ] && [ -x /usr/bin/paru ] && alias yay='paru'

Try system reboot.

1 Like

What is the error message that leads you to believe line 107 is the problem? Please paste the error message exactly as it appears.

1 Like

When typing sudo pacman -S <pcg_name> and pressing tab

╭─[email protected] in ~ took 1s
╰─λ sudo pacman -S asderror: Invalid value "header--style" for '--style <components>': Unknown style, 'header
--style'

For more information try --help
lasdpa-plugins

It looks like there is a missing space:

image

Try to add in the space in your ~/.config/fish/config.fish file like this and see if it helps:

alias cat='bat --style header --style snip --style changes --style header'

Edit: @dr460nf1r3 it looks like this is actually a typo in the commit:

7 Likes

Fixed, thanks :slight_smile:

3 Likes

I just built all the ISOs on this broken version :smiling_face_with_tear:

2 Likes

@SGS you forgot to update the sha256sums by the way

3 Likes

Thanks! Multiple eyes always have a better view! :hugs:

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.