Issue after installation,no dual boot option and it doesnt boot into garuda

am trying to install garuda linux with dual boot windows and facing issue with installation more precisely after installing it when pc reboots,after it gets installed and gets rebooted,then there's no dual boot option appearing to choose between windows 10 and was first installed.
i have 3 drives,nvme sn570 where my windows is,wd hard drive where some files are stored and wd ssd 120gb where am trying to install garuda,and bootloader is also being installed on this drive.i have created partitions for home,root,boot even 8mb unformatted but unsuccessful,i have tried installing it multiple time and same issue persists as it doesnt provide any option for selecting between windows and bios doesnt have garuda linux option for boot option as if bootloader not being recognized by bios or installing.
tried multiple times with both open sources and drivers,secure boot and fastboot is disabled.
below i have provided garuda-inxi from garuda live,if you know fix pls let me know

 ╭─garuda@garuda in ~ as 🧙
╰─λ garuda-inxi
Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda root=miso:LABEL=GARUDA_DR460NIZED_RAPTOR quiet
systemd.show_status=1 ibt=off driver=nonfree nouveau.modeset=0
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Gigabyte model: B360M GAMING HD
serial: <superuser required> UEFI-[Legacy]: American Megatrends v: F15b
date: 09/16/2020
Info: model: Intel Core i5-9400F bits: 64 type: MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 1150 high: 2900 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 2900 bogomips: 34798
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Gigabyte driver: nvidia
v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-03) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:2182 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 91 s-size: 535x301mm (21.06x11.85")
s-diag: 614mm (24.17")
Monitor-1: DP-4 pos: primary res: 1920x1080 dpi: 90
size: 544x303mm (21.42x11.93") diag: 623mm (24.52") modes: N/A
Monitor-2: HDMI-0 size-res: N/A modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX 1660
Ti/PCIe/SSE2 direct-render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
API: ALSA v: k6.2.13-zen-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: 5020
bus-ID: 00:17.0 chip-ID: 8086:2822 rev: N/A class-ID: 0104
Local Storage: total: 1.48 TiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WD Blue SN570 500GB size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 234110WD temp: 33.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WDS120G2G0A-00JH30 size: 111.8 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0000
scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10PURZ-85U8XY0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: Cruzer Blade
size: 7.45 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.26 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.55 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 40.0 C pch: 57.0 C mobo: N/A gpu: nvidia
temp: 49 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 191 Uptime: 7m wakeups: 0 Memory: 15.55 GiB
used: 3.72 GiB (23.9%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1223
libs: 322 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.16-1):
System install date:     2023-09-04
Last full system update: 2023-09-04
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       <superuser required>
Failed units:

Have you tried pressing the boot order key on post ?
Mine is f8 ?
then choose the drive you installed garuda on?
Or make garuda your default boot drive in your bios


thing is am not getting other drives in boot order like am only getting windows boot manager and the drive in boot order windows installed on,other drives are not showing up there though they are accessible in windows

chroot from live ISO and fix grub.

You have a UEFI board but you are installing in legacy BIOS mode. Unless Windows has been installed in legacy BIOS mode, you will not be able to get them onto the same boot menu.

It is unlikely Windows has been installed in legacy BIOS mode since your disks are GPT. An easy way to know for certain is just check if you have an EFI partition.

Try installing in UEFI mode instead, and share the EFI partition with Windows.


i have installed windows in c drive and disk management is showing an efi partition of c drive,so am assuming that its in uefi mode,how can i specifically target uefi mode for garuda as am booting via selecting usb drive from boot menu by f12

You should have both a UEFI option and a BIOS option for booting the USB drive in the boot menu. If you don’t, double-check these considerations from the downloads page:

  • Disable fastboot and secure boot. It may not be possible to disable the latter explicitly - try clearing the secure boot keys instead. Check the manual of your device/motherboard for further info.
  • Make sure that your device’s SATA controller is set to AHCI mode in your device’s setup utility. Otherwise, the Linux kernel may not be able to detect your drive.
  • If your firmware supports UEFI then configure your device to use UEFI only in its setup utility. UEFI is much preferred over BIOS whenever possible.

i didn't had ahci mode enabled,i just enabled now,do i have to reinstall garuda to check because i didn't got any dual boot option during boot after enabling it

If you want Windows and Garuda to show up together on a boot menu, you will need to reinstall Garuda in UEFI mode.

It may be necessary to boot Windows once in recovery mode to download the AHCI drivers if they were not included in your Windows installation. My understanding is it is a very simple process.

1 Like

i just checked now the boot menu and now am getting all drives in boot menu which i wasnt before,and when i selected my ssd 120gb one where garuda is installed,i got booted into garuda

to install garuda in specifically in uefi mode,do i have to disable CSM from motherboard because other parameters are all set to uefi

disabling this may cause you to require to reinstall windows, as in looking it up it looks to me like a ‘legacy bios’ emulator specifically for Windows 11.

these new nvme SCSI drive systems may require a certain setup for the needed hardware drivers to use them as boot devices.
i know nothing about WIndows 11 other than if i had it i would delete it outright immediately.

if CSM is not absolutely needed by windows 11 (which i highly doubt) then i’d backup all my user data and fully wipe my SSD’s reinstall both OS’s with all the BIOS parameters correctly set for my system’s hardware setup and not just leave everything set to ‘automatic’ - as this is where you are going to find, by far, the most issues when running a multi-OS system.

always correctly set up your hardware BIOS/UEFI before running a dual-boot system.

edit: according to this thread, disabling CSM may cause issues with legacy USB mouse and keyboards, you’ll need to research your specific hardware setup to determine whether or not you need it enabled.

1 Like

thx for helping me out,i installed garuda via uefi now,it seems like my pen drive had some issue and it was just not getting fully mounted,i used my second pen drive and got option for uefi boot which i wasn't before,i now have dual boot screen and i didn't had to disable csm,enabling ahci helped alot.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.