Is there a solution to Time in fire Dragon?

WhatsApp Web always shows GMT of all messages, which is quite confusing.
Not only WhatsApp but everywhere in Firedragon.

Same as here, I guess...

3 Likes

Yeah, I had checked out this one, but then you mean there is no solution?
It is not convenient to browse the internet, with all the timings wrong

Maybe you could check those settings and see if there is one that can be turned off.
For sure I'd not remove the entire anti-fingerprinting off for this...

2 Likes

I don't know exactly all about this....
Maybe this is an issue which is to be addressed by the developer, otherwise one can't translate all the timings in mails, messages and other websites every time.

I don't know exactly how it works.
For sure, you can use your own settings using ~/.firedragon/firedragon.overrides.cfg which overrides default settings shipped in /usr/lib/firedragon/firedragon.cfg.
Maybe you could start checking the latter.

3 Likes

:grimacing:
Maybe it would be convenient for everyone if this is taken care of at the development level.
And everyone would agree with this?

I am kind of busy now-a-days, I will check it out later.

Solution.
Just use Firefox.

4 Likes

I think that the feature is inherited from Firefox...
Again, I think it is a privacy cost/benefit decision.
https://support.mozilla.org/en-US/kb/firefox-protection-against-fingerprinting
Fingerprinting Detection changes how you are detected online:

  • Your timezone is reported to be UTC
  • ...
3 Likes

But I didn't have this problem in Firefox

I guess it depends on setting "privacy.resistFingerprinting" (and maybe some others in that section).
Of course, I base my assumptions only further to that forum post, the thread on Firedragon and a very quick Internet search. I have no idea what else could possibly be behind it...
Edit: I can confirm:

  • On my work (Windows) Firefox privacy.resistFingerprinting was True and Whatsapp Web showed my messages as UTC. Setting it off, the time was changed to my local time.
  • On my Firedragon privacy.resistFingerprinting was True and Whatsapp Web showed my messages as UTC. Setting it off, Whatsapp Web didn't let me in, for having an unsupported browser :slight_smile:
4 Likes

Yeah, you are right, same results with me, so after all it's a Firefox inherited feature, and I should let it be.

1 Like

In Firefox privacy.resistFingerprinting in false by default

Very true. As outlined already this is a cost/benefit measure, if you feel like you don't need antifingerprinting measures simply put the

(following the formatting of course) in this file:

Thats why it exists, to make own settings easy. :slight_smile:

4 Likes

But I think this can be done from about:config webpage too, and I tried to make it false, and it resulted that WhatsApp web didn’t work and some other web pages looked odd,
I am thinking of giving a try to Brave Browser,
Don’t worry I really liked Fire Dragon, but the time issue really was a problem with messages coming in my school group.
I will return to it in future, cause a really love Firefox and therefore fire dragon

1 Like

Yes, sure, I did my tests in that way.
Initially I mentioned the config files to do things in a more "formal" way, especially if you need to make many changes, and in that way you track them all in the same point.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.