Is my laptop too old for Garuda

Kernel: 6.9.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=fb882244-25fa-425e-8fc7-9f1831ffda47 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.1.1 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Medion product: X6815 v: 1.0
serial: <superuser required>
Mobo: Medion model: X6815 v: 1.0 serial: <superuser required>
uuid: <superuser required> BIOS: American Megatrends v: 207 date: 11/23/2012
ID-1: BAT0 charge: 52.2 Wh (97.8%) condition: 53.4/48.4 Wh (110.2%)
volts: 12.5 min: 10.8 model: A25 A15--22 type: Li-ion serial: N/A
status: full
Info: model: Intel Core i7-2630QM bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 1566 high: 2900 min/max: 800/2900 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 2900 2: 800 3: 800
4: 1327 5: 798 6: 2900 7: 800 8: 2208 bogomips: 31927
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Pegatron driver: i915 v: kernel arch: Gen-6 code: Sandybridge
process: Intel 32nm built: 2011 ports: active: LVDS-1
empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0116
class-ID: 0300
Device-2: NVIDIA GF106M [GeForce GT 555M] vendor: Pegatron driver: nvidia
v: 390.157 alternate: nouveau,nvidia_drm non-free: series: 390.xx+
status: legacy (EOL~2022-11-22) last: release: 390.157 kernel: 6.0
xorg: 1.21 arch: Fermi code: GF1xx process: 40/28nm built: 2010-2016 pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 link-max: lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:0dce class-ID: 0300
Device-3: Cheng Uei Precision Industry (Foxlink) USB2.0 UVC 1.3M Webcam
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-1.1:3 chip-ID: 05c8:030d class-ID: 0e02 serial: <filter>
Display: wayland server: v: with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia dri: crocus
gpu: i915,nvidia display-ID: 0
Monitor-1: LVDS-1 res: 1536x864 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel crocus platforms: surfaceless: drv: swrast
wayland: drv: crocus x11: drv: crocus inactive: gbm
API: OpenGL v: 4.5 compat-v: 3.3 vendor: intel mesa v: 24.1.2-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 3000 (SNB
GT2) device-ID: 8086:0116 memory: 1.46 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 5 device: 0 type: cpu name: llvmpipe (LLVM
17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.2-arch1.1 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Pegatron driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Device-2: NVIDIA GF106 High Definition Audio vendor: Pegatron
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0be9 class-ID: 0403
API: ALSA v: k6.9.7-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.2.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
chip-ID: 8086:008a class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Pegatron driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 9000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Intel Centrino Advanced-N 6230 Bluetooth adapter driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.2:4
chip-ID: 8086:0189 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 3.0 lmp-v: 5
status: discoverable: no pairing: no
Local Storage: total: 1.59 TiB used: 25.33 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD7500BPVT-22HXZT3 size: 698.64 GiB block-size: physical: 4096 B
logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 1A01 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3U0 scheme: MBR
ID-1: / raw-size: 698.63 GiB size: 698.63 GiB (100.00%)
used: 25.33 GiB (3.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 698.63 GiB size: 698.63 GiB (100.00%)
used: 25.33 GiB (3.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 698.63 GiB size: 698.63 GiB (100.00%)
used: 25.33 GiB (3.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 698.63 GiB size: 698.63 GiB (100.00%)
used: 25.33 GiB (3.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
System Temperatures: cpu: 57.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB available: 15.53 GiB used: 3.45 GiB (22.2%)
Processes: 256 Power: uptime: 27m states: freeze,standby,mem,disk
suspend: deep avail: s2idle,shallow wakeups: 0 hibernate: platform
avail: shutdown, reboot, suspend, test_resume image: 6.2 GiB
services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd
v: 256 default: graphical tool: systemctl
Packages: pm: pacman pkgs: 1454 libs: 473 tools: octopi,paru Compilers:
gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole
inxi: 3.3.35
Garuda (2.6.26-1):
System install date:     2024-06-29
Last full system update: 2024-06-30
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:

I’m trying to make my dGPU work for 3 days now and I am out of options. It looks like Garuda just can’t support my hardware. From what I’ve tried, optimus and envy were able to change the dGPU in use “on paper”, they both show NVIDIA, however, glxinfo confirms it’s still Intell as well as the games I’ve tried to install - they see only Intel. I cannot use drivers above 390, which are required for other alternatives. I read Arch and Garuda’s wikis, but I can’t see what else I can try. Maybe Wayland has something to do with it? nvidia smi output:

| NVIDIA-SMI 390.157                Driver Version: 390.157                   |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GT 555M     On   | 00000000:01:00.0 N/A |                  N/A |
| N/A   49C   P12    N/A /  N/A |     15MiB /  1985MiB |     N/A      Default |

| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|    0                    Not Supported                                       |

Probably so…if I remember my old HP laptop, there isn’t a valid driver from Nvidia for these any more. Could be wrong, but the model number looked to be what I remembered.
This was a model made in 2010, so it wouldn’t be unreasonable to assume most of them are now out of service.

Mine is from 2011. Was running Win10, but I needed its SSD, so it was left with HDD only which is too slow for anything above Win7. Thus I decided to try Linux and Garuda as a distro for gaming and this laptop is quite capable for older games. In fact, I liked Garuda very much, I’ve tried numerous distros before on another laptop and this one is SO much better. Except the one and only problem - I cannot use this distro for gaming :frowning:

Ok, I’ve tried to log in to X session. And now it works solely on dGPU! I can’t change my resolution to native though

Ok, I kinda solved the problem with the resolution.

However, the whole system feels… sluggish? Everything related to windows management, moving, maximizing, minimizing… Thought dGPU should be more powerful for this :smiley: I’ll test the game tomorrow.

Strangely enough, I don’t feel any real difference between Intel and Nvidia GPUs. FPS counter would help, but it’s so hard to get working on Linux, especially for the older games under Wine with no Steam or other launcher. But I will try some more.

UPDATE. Rebuilt the game’s Wine prefix and now I clearly see the difference. Thus everything works. I’m pretty satisfied with this method of switching GPU (i.e. login in to X11 for gaming and to Wayland for everything else). It’s fast and convenient enough for me.

Problem solved :slight_smile: Thanks to me, I guess :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.