Is it safe to install W11 in a flash drive USB to use it sometimes? (My SSD has full Garuda installed)

Hello, I'm new to Linux, I just installed Garuda on my PC a few days ago (And I love it!) I have a little problem that is just I can't use a certain game on Linux, so I was thinking that since is just one game it would be useful to use a USB flash drive (256GB) to install W11 in it and play sometimes.
Would that be safe or it could cause some problems? As I said I just entered the Linux world a few days ago so I don't know a lot.

(Sorry if my english is bad)

Is there some reason you cannot run a virtual machine?

Yes, I think. I don't know much about virtual machines yet, but as far as I have read I can't put more GPU resources into it, It would probably run but with lag.

What specifically do you want to run on Windows? Running it through a flash drive is very painful. Many Windows programs can run natively via Wine, so hopefully you can avoid Windows entirely. 256mb video memory with hardware acceleration is plenty enough for a lot of common situations.

Well, it is not a game, but a patch for a game. The game (Is a VIsual novel) runs fine on Garuda but I have tried to install the patch many times without success. It appears it is outdated + that a different patch is coming for another game and it appears it will not be available for linux in a while. The patch is basically because the game has a terrible translation.
The game is Chaos;Head Noah and I tried to install "The committee of Zero patch" but it did not work :frowning:

1 Like

I would recommend using either a dedicated second drive in the computer or external SSD or HD drive. Why? flash drives aren't really designed to run operating systems and have a tendency to fail more often than SSD's or hard drives. You may also get better performance from an SSD or HD drive than a USB flash drive. Ultimately you are free to do whatever you want.

2 Likes

I was thinking of using a flash drive since the game size is less than 30GB and I'm probably not going to use it for more than 3 months. I'm not worried about the flash drive with W11, I'm more worried about thinking that if installing W11 in a flash drive in the same computer could cause damage to Garuda.

Unfortunately that may be due in part to the fact that the patch is a "work in progress" in the words of the developer. (from Guides)

People reviewing the game mention to wait for the patch before you play:

Otherwise, it should be fine to play normally via Steam according to ProtonDB: https://www.protondb.com/app/1961950

You should keep an eye on this to see when it's complete: GitHub - CommitteeOfZero/nitrosharp: Open-source N2System reimplementation

NitroSharp is close to being feature-complete

2 Likes

Oh sorry I mean i tried to install the Chaos;Child patch not Chaos;Head. I'm very sleepy due to exams so I'm not writing correctly. (Yes, I'm waiting for C;H Patch) and I'm also worried for the waiting for the C;H patch for Linux since I haven't heard anything about it for Linux.

Windows will on occasion kill grub. There is a general expectation that you are going to fix most of your own issues due to a dual-boot setup, as it's not 'officially' supported. There are guides for it here on the forum, but it probably won't be a very fun time; especially if you're new.

6 Likes

Okay, thanks. I will not install W11 since it can make things go wrong

Chaos;Child patch has a well hidden Linux tutorial. Pay mind to run Steam Native not runtime, good luck!

3 Likes

I tried the steps in the tutorial but they did not work.
An user in discord told me that it's because the tutorial is outdated.
Maybe I should wait some time.

1 Like

Good ending! after trying again to install the C;C patch it worked (Using wine)

3 Likes

Great! Don't forget to mark a solution, so others don't come here looking to help.

2 Likes

Solution:
I had to install vcrun2019 & execute the following command after sudo
WINEPREFIX=~/.local/share/Steam/steamapps/compatdata/970570/pfx wine [patch installer].exe
after doing right click on the installer and opening it with the terminal.
the way I executed the command was not "sudo command" that failed, I don't know how to say it (I'm new to everything in linux) but I executed it after finishing another command with sudo, just when the terminal says [email protected] in... well I think you know.
Important: The launcher of the patch does not open anything, you have to open the game from steam with Proton experimental. Two launchers were opened after clicking on play on the first it worked.

I hope this to be useful for someone in the future.

2 Likes

I personally love Linux but due the massive anticheat problems in various games I ended up installing W10 again as dual-boot option. So now I use debloated W10 just for playing games that aren't compatible with Linux and Garuda for all other stuff.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.