Is Garuda using a customised version of Firefox?

Sure? This one makes quite a difference, cost-benefit-ratio wise

Sorry, this is the value which is probably responsible for this behaviour (dom.popup_allowed_events)
Its now commented out so once there is an update to browser-settings it should work as expected. If not it doesnt just report here :grin:

1 Like

I just ran the update for garuda browser settings and restarted firefox. It crashed a few times and then started working. However the copy paste functions still do not work. when I cut/copy it does not even show up in the kde clipboard. But when I cut the text does disapear within firefox.

I can copy/paste just fine, but Im not using the KDE clipboard.
When you cut the text, does pasting insert the text?

1 Like

When I cut the text from firefox I cannot paste in firefox or even to kate. When I cut text from kate I can paste in firefox. I tested this on my cloud9 docker image as well as the qnap container station and it failed both times. However it did work on garuda's private bin.

I wonder if it has something to do with tls. The cloud9 is running in http and the reverse proxy forward to https only. The qnap is behind firewalls and runs on a private cert for https.

EDIT:
when I cut from the qnap text. it dissapears and will not past on garuda's private bin. When I cut from garuda's private bin. I can paste into qnap text. Weird

are you on wayland ?

1 Like

yes I am running wayland kde dr460nized.

these issues are related to kde having incomplete and unstable wayland support

only wlroots based compositer are better for ex wayfire,sway

do not use gnome and kde on wayland

2 Likes

I wonder how this is possible, did you already do a

sudo pacman -Syu

After installing? (this will force uninstalling wayland session)

1 Like

I am mistaken, perhaps wayland is gone.
I changed my login screen from breeze to sweet. I cannot change to wayland anymore. In fact I cannot change back to breeze to see if I can switch to wayland anymore. After hitting apply and logging out or rebooting I am still on sweet login sddm.

Firefox allows me to cut and paste even on this forum but not on other sites as mentioned above.

I used pacman -Syyu to make sure that I update all repositores.

1 Like

You have no snapshot's?

Its possible that you updated which removed the wayland session (thus not being selectable anymore) when you looked for what session is running. Since the session is still in RAM after uninstalling :slight_smile:
Breeze is the theme and has nothing to do with the session used. Its only a visual thing.

I disabled all firefox plugins. Same problem.

EDIT:
ungoogled chromium works well with all websites.

Did you try this already?

1 Like

I just tried your answer to creating a new profile. The qnap landing page is stuck on loading and will not proceed even when forced refresh. Cloud9 will load but the copy paste still doesn't work. When I close firefox and choose the default-.... profile. I can again load the qnap landing page.

Alright. The next step you could take it making Firefox completely vanilla. This can be done by removing the distribution.ini which is responsible for the settings.

sudo mv /usr/lib/firefox/distribution.ini /usr/lib/firefox/distribution.ini.bak

or

sudo mv /usr/lib/firefox/distribution/distribution.ini /usr/lib/firefox/distribution/distribution.ini.bak

depending on if you are using firefox-appmenu (dr460nized) or firefox (the rest). First one is the location for regular Firefox. Then restart Firefox.
You can restore it by using the command in reverse.

4 Likes

This did the trick! Fantastic! I am using firefox--appmenu

2 Likes

I do have to jump in here. I have also experienced most of the problems as well. I am a Firefox user since 1994. I use Craigslist a lot. Furniture, computers, and such. It has been cleaned up. Right now I want to buy a refrigerator, simple huh. I found one, clicked on the reply bottom and clicked to get the phone number, then captucha, runs and crashes with an error code.

Thank you @dr460nf1r3

2 Likes

This fixed my problems. I renamed distribution.ini and "vanilla" firefox now allows access to my ebay & godaddy accounts. Many thanks.

Followup on this, the browser settings which were potentially breaking things were removed so it should all work ootb now :slightly_smiling_face:
For those who prefer the hardened (safer) version, there is now

garuda-browser-settings-hardened

To install, which replaces the regular browser settings. The difference is only the Firefox configuration :blush:

6 Likes