Iranian here & Garuda-Update is unable to downlaod Garuda.db & Chaotic-AUR.db even tho I am both able to ping and open the address of Servers in Chaotic-mirrorlist! Any help is appreciated!

Hi there!
I'm from Iran, and thanks to the recent blockages in our Internet connections, I was virtually unable to Update Garuda; However, recently I found out that Hostiran.ir has Arch linux mirrors which include all mirrors except for Garuda & Chaotic-AUR which have their own seperate mirrors; Now, my problem is that even though I'm able to ping the websites in Chaotic-Mirrorlist & even open up their websites in Firedragon, no downlaods from these databases occur without a Proxy which limits my spped to 40kb/s that would take decades to downlaod stuff! Any better solutions?

Wow, why is the proxy so slow? Is it throttled?

Although not known for being fast by any means, it might be worth checking if you have better luck taking the update over Tor (if it is available). Hopefully that would at least let you get off of the proxy.

https://wiki.archlinux.org/title/tor#Pacman

Seems like something that could potentially be legally questionable in a country like Iran, probably not a smart idea for us to recommend that as a solution :sweat_smile:

2 Likes

:man_shrugging: It is a resource that is either available or not available, I do not know. I assume the OP knows better than I do what options are feasible in their current situation.

If Iran is blocking Tor you would have to use a Tor bridge, which obfuscates the fact that you are connecting to a relay. Again, I don't know the risks that might be involved with that; this thread might be helpful: Iran: Circumventing Censorship with Tor - Censorship Circumvention - Tor Project Forum

Another option would be to connect with a VPN to another country, although good VPN services are not free. If the whole country has this issue, my guess would be an international VPN will be either expensive or banned. Or both!

2 Likes

Chinese people had to resort to few paid VPN options for years, services are hit-or-miss. You might have to do like them.

But they can get in trouble for it too if they get caught.

Hello Everyone

To give some context, I've been using Garuda for the past month and I've loved it but I'm in Iran and with the current situation at hand, a lot of things are blocked by the government.

When I try to update the packages, all databases update except garuda and chaotic-aur and I can't find a way around it so I wanted to ask if there's anything I can do to get around it.

I have tried updating mirrors that didn't help.

Thanks in advance

Hi @MAST1999, this came up recently in another thread: Iranian here & Garuda-Update is unable to downlaod Garuda.db & Chaotic-AUR.db even tho I am both able to ping and open the address of Servers in Chaotic-mirrorlist! Any help is appreciated!

I'm afraid the community doesn't appear have a great solution for this particular issue. You can use Snowflake or request access to a Tor bridge (the regular Tor network is blocked in Iran), but those resources are being stretched pretty thin in Iran due to demand (see this thread: Iran: Circumventing Censorship with Tor - Censorship Circumvention - Tor Project Forum).

Obviously you will need to do your own research and decide if that is a reasonable path to go down to begin with.

5 Likes

I'll look into it.

Thanks for the reply.

Another Post Merged here: Legit Riddle me this: How is it that I'm able to both ping the US Chaotic-AUR's IP Adress & even downlaod archives from it using FireDragon, while Wget & Pacman fail to downlaod the exact same files?

Image:
KCDOQs.png

(I live in Iran if it helps, but this was actually the exact same before the blockages, & It's my 5th reinstall)

Garuda-inxi:

System:
Kernel: 5.19.7-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZED_TALON quiet
systemd.show_status=1 driver=nonfree nouveau.modeset=0 i915.modeset=1
radeon.modeset=1
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Aspire A715-71G v: V1.21
serial: <superuser required>
Mobo: KBL model: Charmeleon_KLS v: V1.21 serial: <superuser required>
UEFI: Insyde v: 1.21 date: 11/02/2018
Battery:
ID-1: BAT1 charge: 35.9 Wh (99.7%) condition: 36.0/48.9 Wh (73.6%)
volts: 16.8 min: 15.2 model: LG 004B384234314341 type: Li-ion
serial: <filter> status: not charging
CPU:
Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
gen: core 7 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
stepping: 9 microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 2300 high: 2800 min/max: 800/3800 scaling:
driver: intel_pstate governor: powersave cores: 1: 2800 2: 2800 3: 800
4: 2800 5: 2800 6: 800 7: 2800 8: 2800 bogomips: 44798
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 630 vendor: Acer Incorporated ALI driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:591b
class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Acer
Incorporated ALI driver: nvidia v: 515.65.01
alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
2022-07) arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie:
gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300
Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-9:3
chip-ID: 04f2:b5f7 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x15d5 built: 2015 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.1.7
direct render: Yes
Audio:
Device-1: Intel CM238 HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171
class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio vendor: Acer Incorporated
ALI driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
chip-ID: 10de:0fb9 class-ID: 0403
Sound Server-1: ALSA v: k5.19.7-zen2-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
vendor: Lite-On driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:003e class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.1 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0f1 state: down mac: <filter>
Bluetooth:
Device-1: Lite-On type: USB driver: btusb v: 0.8 bus-ID: 1-7:2
chip-ID: 04ca:3016 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 1.05 TiB used: 10.6 GiB (1.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: RBUSNS8180S3128GI
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 60B9 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10SPZX-21Z10T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A02 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Lexar model: USB Flash
Drive size: 28.91 GiB block-size: physical: 512 B logical: 512 B
type: SSD serial: <filter> rev: 1100 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
Message: No partition data found.
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.51 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 51.0 C pch: 50.5 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 235 Uptime: 1h 36m wakeups: 1 Memory: 15.51 GiB used: 5.42 GiB
(35.0%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1227 lib: 308 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.7-1):
System install date:     2022-10-20
Last full system update: 2022-10-20 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            snapper-cleanup.service

I feel like your connection is just fundamentally insecure, maybe subject to DPI or just straight up subject to a MITM attack.

What happens if you use for example this UAE mirror instead of the standard chaotic mirrorlist entries? (/etc/pacman.d/chaotic-mirrorlist)

Server = https://dxb.ae.mirror.silky.network/chaotic-aur/$repo/$arch

Also, @KingSadraLinux, you are booted into the live ISO and not into the system. Unplug your USB drive and boot into the OS.

Also tagging @MAST1999.

2 Likes

Well actually about the DPI thing, Im aware that our government is currently implementing DPI for detecting VPNs, but everything else virtually works exactly like before, so 99% not that;

About he link, I actually tried it, and I could see that this linkw as actually banned here in iran as I couldn't also open it with FireDragon or even ping it!

And also about the USB Live environment, I'm actually just using the live entertainment to test out different settings so i can easily later applyit to my real installation without worring for mis-configueing stm of having to reinstall!

Cheers!

Can you show the full output of the ping command? I'm not sure why the UAE mirror would be blocked in Iran, that seems rather odd.

Here's the results:

garuda.db failed to download
core                                  156.6 KiB  29.4 KiB/s 00:05 [------------------------------------] 100%
extra                                1721.6 KiB   126 KiB/s 00:14 [------------------------------------] 100%
community                               7.1 MiB   327 KiB/s 00:22 [------------------------------------] 100%
multilib                              168.7 KiB  31.7 KiB/s 00:05 [------------------------------------] 100%
chaotic-aur.db failed to download
error: failed retrieving file 'garuda.db' from dxb.ae.mirror.silky.network : SSL connection timeout
error: failed retrieving file 'chaotic-aur.db' from dxb.ae.mirror.silky.network : SSL connection timeout
error: failed to synchronize all databases (unexpected error)

Also, I was actually really wondering how much data was inside the Chaotic-AUR Repository so maybe I could downlaod the entire piece and host a local kind of mirror for myslef? I mean like it more or less is the best way?

Dear @MAST1999, I also live in iran, and after days of searching, I finally found a way of updating garuda, and wrote it as an article at my Github!

Please consider trying this method, and just tag me to amrk the question as answered if this works!

10 Likes

Maybe you can edit in github

##Step6:
##### Open `Pacman.conf`

to

##Step6:
#### Open `/etc/pacman.conf`

You described it correctly above, but it would make things easier for beginners. :slight_smile:

4 Likes

I know this probably might be asking for way too much, but would there be any way the Garuda Team could setup the Installer in a way that if Tehran/Iran was elected as the default timeline it could auto-apply these settings so all Iranians could access the updates more easily? Even a simple inclusion of Aria2c & C-ares by default in the installation could help with yhe process a lot!

I don't know if that would be possible, but the effort is probably relatively high for the few users from Iran who can find a solution here now.
We all hope that circumstances will change for the good and these blocks will be lifted soon.
Especially since Linux and Garuda are not pursuing any political goals.

5 Likes

Approximately 90GB right now. It should not go to 120GB for the foreseeable future: GitHub - chaotic-aur/docker-mirror: Scripted setup of a working Chaotic-AUR mirror using Docker 🐳

4 Likes

We can't go much higher anyways :sweat_smile:

2 Likes