Invalid snapshot '--type' when downgrading an app

I tried to downgrade Qbittorent because a website i use only whitelisted qbit up to 4.3.7 and when i tried to downgrade it i got the invalid snapshot '--type' when i checked the version of the app it still is 4.3.8 any idea what to do?

(1/1) checking keys in keyring                                     [------------------------------------] 100%
(1/1) checking package integrity                                   [------------------------------------] 100%
(1/1) loading package files                                        [------------------------------------] 100%
(1/1) checking for file conflicts                                  [------------------------------------] 100%
(1/1) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
IO Error (.snapshots must not be world-writable).
==> root: 
:: Processing package changes...
(1/1) reinstalling qbittorrent                                     [------------------------------------] 100%
:: Running post-transaction hooks...
( 1/10) Arming ConditionNeedsUpdate...
( 2/10) Foreign/AUR package notification
cpupower-gui 1.0.0-3
downgrader-git 2.0.0.r158.f346695-3
gnome-shell-extension-gsconnect 48-1
ksuperkey 0.4-2
makepkg-meta r18.97242c5-1
opentabletdriver 0.5.3.3-1
package-query 1.12-1
pkgbuilder 4.3.1-1
protonvpn 1.0.0-2
protonvpn-cli 3.9.1-1
python-condconfigparser 1.0.5-1
python-osrparse 5.0.0-2
python-pillow-simd 1:7.0.0.post3-3
vpn-unlimited 8.5-3
( 3/10) Updating icon theme caches...
( 4/10) Orphaned package notification...
fontforge 20201107-1
go 2:1.17.1-1
hdparm 9.62-1
libimagequant 2.16.0-1
meson 0.59.2-1
python-pytest 6.2.5-1
( 5/10) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/pamac.conf.pacnew
/etc/retroarch.cfg.pacnew
Please check and merge
( 6/10) Updating pkgfile database...
( 7/10) Checking which packages need to be rebuilt
( 8/10) Updating the desktop file MIME type cache...
( 9/10) Performing snapper post snapshots for the following configurations...
Invalid snapshot '--type'.
==> root:
(10/10) Syncing all file systems...
System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=8043ca71-0be4-4533-939d-aa93e0996b5f rw  
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 amd_iommu=on
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux  
base: Arch Linux  
Machine:   Type: Desktop System: Gigabyte product: B450M DS3H v: N/A serial: <filter>  
Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <filter> UEFI: American Megatrends v: F51 date: 07/29/2020  
CPU:       Info: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2  
microcode: 800820D cache: L2: 3 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86229  
Speed: 2191 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 2191 2: 2195 3: 2195 4: 2195 5: 2194  
6: 2195 7: 2194 8: 2194 9: 2193 10: 2195 11: 2195 12: 2195  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]  
vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 06:00.0 chip-ID: 1002:67df class-ID: 0300  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting  
alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.0x12.5") s-diag: 599mm (23.6")  
Monitor-1: HDMI-A-0 res: 1920x1200 hz: 60 dpi: 94 size: 518x324mm (20.4x12.8") diag: 611mm (24.1")  
OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.42.0 5.14.12-zen1-1-zen LLVM 12.0.1) v: 4.6 Mesa 21.2.3  
direct render: Yes  
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Micro-Star MSI driver: snd_hda_intel  
v: kernel bus-ID: 06:00.1 chip-ID: 1002:aaf0 class-ID: 0403  
Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel  
bus-ID: 08:00.3 chip-ID: 1022:1457 class-ID: 0403  
Device-3: Razer USA RC30-026902 Gaming Headset [Nari Essential Wireless Receiver] type: USB  
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:2 chip-ID: 1532:051e class-ID: 0300  
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.38 running: yes  
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel  
port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200  
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 1.58 TiB used: 610.58 GiB (37.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: SATA3 240GB SSD size: 223.57 GiB block-size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 8B0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD5000AAKS-07A7B2 size: 465.76 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 3B01 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC43 scheme: GPT
Partition: ID-1: / raw-size: 222.95 GiB size: 222.95 GiB (100.00%) used: 145.35 GiB (65.2%) fs: btrfs dev: /dev/sda5
maj-min: 8:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 25.9 MiB (26.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 222.95 GiB size: 222.95 GiB (100.00%) used: 145.35 GiB (65.2%) fs: btrfs dev: /dev/sda5
maj-min: 8:5
ID-4: /var/log raw-size: 222.95 GiB size: 222.95 GiB (100.00%) used: 145.35 GiB (65.2%) fs: btrfs dev: /dev/sda5
maj-min: 8:5
ID-5: /var/tmp raw-size: 222.95 GiB size: 222.95 GiB (100.00%) used: 145.35 GiB (65.2%) fs: btrfs dev: /dev/sda5
maj-min: 8:5
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.58 GiB used: 2.75 GiB (17.7%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 46.0 C mobo: 16.8 C gpu: amdgpu temp: 55.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 818
Info:      Processes: 433 Uptime: 5h 40m wakeups: 0 Memory: 15.58 GiB used: 9.57 GiB (61.5%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1930 lib: 545 Shell: fish v: 3.3.1
default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

Apparently the .snapshots directory is world-writable, which apparently it shouldn't be. Did you alter some permissions?

This sounds like a weird situation.

3 Likes

Yes, this seems to be the issue.
I think it will disappear adjusting the permissions.

3 Likes

not really private torrents have a whitelist for clients.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.