Invalid or Corrupted Package (after following the FAQ)

After following the detailed and well explained FAQ, I'm still having issues with one particular package while trying to update.


Terminal:


Errors occurred, no packages were upgraded.

╭─[email protected] in ~ took 1m35s
[🔴] × sudo pacman -Sy archlinux-keyring chaotic-keyring
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                          1053.3 KiB   445 KiB/s 00:02 [------------------------------------] 100%
warning: archlinux-keyring-20210110-1 is up to date -- reinstalling
warning: chaotic-keyring-20210406-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (2) archlinux-keyring-20210110-1  chaotic-keyring-20210406-1

Total Installed Size:  1.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(2/2) checking keys in keyring                                     [------------------------------------] 100%
(2/2) checking package integrity                                   [------------------------------------] 100%
(2/2) loading package files                                        [------------------------------------] 100%
(2/2) checking for file conflicts                                  [------------------------------------] 100%
(2/2) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
First run mode (config file not found)
Selected default snapshot type: BTRFS
Using system disk as snapshot device for creating snapshots in BTRFS mode

/dev/nvme1n1p2 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/

Creating new backup...(BTRFS)
Saving to device: /dev/nvme1n1p2, mounted at path: /run/timeshift/backup
Created directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-05-24_09-12-40
Created subvolume snapshot: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-05-24_09-12-40/@
Created control file: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-05-24_09-12-40/info.json
BTRFS Snapshot saved successfully (0s)
Tagged snapshot '2021-05-24_09-12-40': ondemand
------------------------------------------------------------------------------
First run mode (config file not found)
Selected default snapshot type: BTRFS

/dev/nvme1n1p2 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/

Selected default snapshot device: /dev/nvme1n1p2
------------------------------------------------------------------------------
Removing snapshot: 2021-05-24_07-45-30
Deleting subvolume: @ (Id:285)
Deleted subvolume: @ (Id:285)

Destroying qgroup: 0/285
Destroyed qgroup: 0/285

Deleted directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-05-24_07-45-30
Removed snapshot: 2021-05-24_07-45-30
------------------------------------------------------------------------------
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot: initramfs-linux-zen-fallback.img
Found Windows Boot Manager on /dev/[email protected]/efi/Microsoft/Boot/bootmgfw.efi
Detecting snapshots ...
Info: Separate boot partition not detected 
Found snapshot: 2021-05-24 09:12:40 | timeshift-btrfs/snapshots/2021-05-24_09-12-40/@
Found snapshot: 2021-05-24 09:10:15 | timeshift-btrfs/snapshots/2021-05-24_09-10-15/@
Found snapshot: 2021-05-24 09:06:31 | timeshift-btrfs/snapshots/2021-05-24_09-06-31/@
Found snapshot: 2021-05-24 08:57:49 | timeshift-btrfs/snapshots/2021-05-24_08-57-49/@
Found snapshot: 2021-05-24 08:49:28 | timeshift-btrfs/snapshots/2021-05-24_08-49-28/@
Found 5 snapshot(s)
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme1n1.
done
:: Processing package changes...
(1/2) reinstalling archlinux-keyring                               [------------------------------------] 100%
==> Appending keys from archlinux.gpg...
==> Locally signing trusted keys in keyring...
-> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
-> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
-> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
-> Locally signing key D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C...
-> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
==> Importing owner trust values...
==> Disabling revoked keys in keyring...
-> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
-> Disabling key 684148BB25B49E986A4944C55184252D824B18E8...
-> Disabling key 5357F3B111688D88C1D88119FCF2CB179205AC90...
-> Disabling key 50F33E2E5B0C3D900424ABE89BDCF497A4BBCC7F...
-> Disabling key 39F880E50E49A4D11341E8F939E4F17F295AFBF4...
-> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
-> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
-> Disabling key FB871F0131FEA4FB5A9192B4C8880A6406361833...
-> Disabling key 487EACC08557AD082088DABA1EB2638FF56C0C53...
-> Disabling key 76B4192E902C0A52642C63C273B8ED52F1D357C1...
-> Disabling key 40776A5221EF5AD468A4906D42A1DB15EC133BAD...
-> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
-> Disabling key 07DFD3A0BC213FA12EDC217559B3122E2FA915EC...
-> Disabling key 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5...
-> Disabling key B1F2C889CB2CCB2ADA36D963097D629E437520BD...
-> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
-> Disabling key 44D4A033AC140143927397D47EFD567D4C7EA887...
-> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
-> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
-> Disabling key 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD...
-> Disabling key 5A2257D19FF7E1E0E415968CE62F853100F0D0F0...
-> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
-> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
-> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
-> Disabling key 5559BC1A32B8F76B3FCCD9555FA5E5544F010D48...
-> Disabling key BFA1ECFEF1524EE4099CDE971F0CD4921ECAA030...
-> Disabling key 4D913AECD81726D9A6C74F0ADA6426DD215B37AD...
-> Disabling key 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA...
-> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
-> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
-> Disabling key 779CD2942629B7FA04AB8F172E89012331361F01...
-> Disabling key D921CABED130A5690EF1896E81AF739EC0711BF1...
-> Disabling key 5696C003B0854206450C8E5BE613C09CB4440678...
-> Disabling key 8CF934E339CAD8ABF342E822E711306E3C4F88BC...
-> Disabling key 1A60DC44245D06FEF90623D6EEEEE2EEEE2EEEEE...
-> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
-> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
-> Disabling key 65EEFE022108E2B708CBFCF7F9E712E59AF5F22A...
-> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
==> Updating trust database...
gpg: next trustdb check due at 2021-08-02
(2/2) reinstalling chaotic-keyring                                 [------------------------------------] 100%
==> Appending keys from chaotic.gpg...
==> Locally signing trusted keys in keyring...
-> Locally signing key 3FFA0B5E092ED4095E26F69B8ADB4AEC585061CF...
-> Locally signing key 1949E60D299007430C94DC0657F3D9CC660431DD...
-> Locally signing key EF925EA60F33D0CB85C44AD13056513887B78AEB...
==> Importing owner trust values...
==> Updating trust database...
gpg: next trustdb check due at 2021-08-02
==> Updating trust database...
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: public key DB323392796CA067 is 3037 days newer than the signature
gpg: key 1EB2638FF56C0C53: no user ID for key signature packet of class 10
gpg: key 1EB2638FF56C0C53: no user ID for key signature packet of class 10
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:   8  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   8  signed:  81  trust: 0-, 0q, 0n, 8m, 0f, 0u
gpg: depth: 2  valid:  76  signed:  26  trust: 76-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2021-08-02
:: Running post-transaction hooks...
(1/8) Syncing all file systems...
(2/8) Arming ConditionNeedsUpdate...
(3/8) Foreign/AUR package notification
ebtables 2.0.10_4-8
firedragon-stable 87.0-1
libappletdecoration 0.8.1-3
(4/8) Orphaned package notification...
=> No orphans found.
(5/8) Checking for .pacnew and .pacsave files...
(6/8) Updating pkgfile database...
(7/8) Checking which packages need to be rebuilt
(8/8) Syncing all file systems...

╭─[email protected] in ~ took 20s
╰─λ sudo pacman -Syu
:: Synchronizing package databases...

core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
:: Starting full system upgrade...
:: Replace firedragon-stable with chaotic-aur/firedragon? [Y/n] y
:: Replace libappletdecoration with community/plasma5-applets-window-buttons? [Y/n] y
y:: Replace sweet-theme-dark with chaotic-aur/sweet-gtk-theme-dark? [Y/n] 
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: smbclient will be installed before its cifs-utils dependency
warning: dependency cycle detected:
warning: lib32-mesa will be installed before its lib32-libglvnd dependency
warning: dependency cycle detected:
warning: rubygems will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-irb will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-reline will be installed before its ruby dependency

Packages (581) 0ad-a24.b-4  adwaita-icon-theme-40.1.1-1  alacritty-0.8.0-1  alsa-card-profiles-1:0.3.28-1
android-tools-31.0.0-3  android-udev-20210501-1  aom-3.1.0-1
archlinux-appstream-data-20210423-1  ark-21.04.1-1  at-spi2-core-2.40.1-1  attica-5.82.0-1
avahi-0.8+20+gd1e71b3-1  baloo-5.82.0-1  baloo-widgets-21.04.1-1  bash-5.1.008-1
bash-completion-2.11-2  bat-0.18.1-1  beautyline-20210510-1  bind-9.16.16-1  binutils-2.36.1-3
bluedevil-1:5.21.5-1  bluez-qt-5.82.0-1  boost-libs-1.75.0-3  botan-2.18.1-1  breeze-5.21.5-1
breeze-icons-5.82.0-1  brltty-6.3-2  btrfs-progs-5.12.1-1  bubblewrap-0.4.1-2
ca-certificates-mozilla-3.65-1  candy-icons-git-r595.7a29005-1  chaotic-mirrorlist-20210516-1
cht.sh-git-r865.6d83c4d-1  cifs-utils-6.13-2  corectrl-1.1.3-1  crda-4.14-4
cryptsetup-2.3.5-4  curl-7.76.1-1  dav1d-0.9.0-1  dbus-glib-0.112-1  ddcutil-1.1.0-1
device-mapper-2.03.12-1  djvulibre-3.5.28-3  dnsmasq-2.85-1  dolphin-21.04.1-1
dolphin-plugins-21.04.1-1  downgrade-10.0.0-1  dxvk-mingw-git-1.8.1.r85.g94674ac4-1
elfutils-0.184-1  encfs-1.9.5-4  enchant-2.2.15-2  ethtool-1:5.12-1  exa-0.10.1-1
exfatprogs-1.1.2-1  expat-2.3.0-1  faudio-21.05-1  ffmpeg-2:4.4-3  ffmpegthumbs-21.04.1-1
file-5.40-3  firedragon-88.0.1-4  firedragon-stable-87.0-1 [removal]  fish-3.2.2-2
fish-systemd-git-r9.6b55727-1  flac-1.3.3-3  frameworkintegration-5.82.0-1
fuse-common-3.10.3-1  fuse3-3.10.3-1  fwupd-1.6.0-3  fwupd-efi-1.0-1  fzf-0.27.1-1
game-devices-udev-0.13-3  garuda-assistant-1.0.2-1  garuda-browser-settings-1.1.0-1
garuda-common-settings-1.2.8-1  garuda-dr460nized-1.4.3-1  garuda-fish-config-1.3.2-1
garuda-hooks-1.0.3-1  garuda-network-assistant-1.1.0-1
garuda-settings-manager-git-r25.eb0ea49-1  garuda-settings-manager-kcm-git-r25.eb0ea49-1
garuda-settings-manager-knotifier-git-r25.eb0ea49-1  garuda-setup-assistant-1.0.4-1
garuda-starship-prompt-1.0.1-1  garuda-wallpapers-r53.0c098b8-1  garuda-welcome-1.0.4-1
garuda-zsh-config-1.1.0-1  gcc-11.1.0-1  gcc-libs-11.1.0-1  gdk-pixbuf2-2.42.6-1
geoclue-2.5.7-3  geoip-database-20210427-1  glib-networking-1:2.68.1-1  glib2-2.68.2-1
glibc-2.33-5  glibmm-2.66.1-1  glslang-11.4.0-1  gnome-desktop-1:40.1-1  gnuchess-6.2.8-1
gnustep-base-1.28.0-1  goverlay-git-0.5.r8.gc9a48ef-1  gpsd-3.22-2  graphene-1.10.6-1
grpc-1.36.4-2  grub-btrfs-4.9-1  gsettings-desktop-schemas-40.0-3  gspell-1.8.4-1
gst-plugins-bad-1.18.4-7  gst-plugins-bad-libs-1.18.4-7  gtk-update-icon-cache-1:4.2.1-1
gtk-vnc-1.2.0-1  gtk3-1:3.24.29-1  guile-2.2.7-1  gwenview-21.04.1-1  harfbuzz-2.8.1-1
harfbuzz-icu-2.8.1-1  haskell-conduit-1.3.4.1-19  haskell-hashable-1.3.2.0-3
haskell-hslogger-1.3.1.0-111  haskell-mono-traversable-1.0.15.1-132
haskell-network-3.1.2.1-53  haskell-network-bsd-2.8.1.0-91  haskell-primitive-0.7.1.0-130
haskell-random-1.2.0-218  haskell-resourcet-1.2.4.2-83  haskell-sandi-0.5-225
haskell-split-0.2.3.4-133  haskell-splitmix-0.1.0.3-108
haskell-unordered-containers-0.2.13.0-64  haskell-utf8-string-1.0.2-38
haskell-vector-0.12.3.0-14  haskell-vector-algorithms-0.8.0.4-53  hblock-3.2.2-1
hdparm-9.61-1  hedgewars-1.0.0-186  heroic-games-launcher-bin-1.6.1-1  hwinfo-21.73-1
hwloc-2.4.1-1  icu-69.1-1  imagemagick-7.0.11.13-2  imath-3.0.3-1  inetutils-1.9.4-9
inxi-3.3.04.1-1  iproute2-5.12.0-1  iputils-20210202-1  irqbalance-1.8.0-1  itch-1:1.26.0-1
jasper-2.0.28-1  js78-78.10.1-1  kaccounts-integration-21.04.1-1
kaccounts-providers-21.04.1-1  kactivities-5.82.0-1  kactivities-stats-5.82.0-1
kactivitymanagerd-5.21.5-1  kamera-21.04.1-1  kapman-21.04.1-1  karchive-5.82.0-1
kate-21.04.1-1  kauth-5.82.0-1  kbookmarks-5.82.0-1  kcalc-21.04.1-1  kcalendarcore-5.82.0-1
kcmutils-5.82.0-1  kcodecs-5.82.0-1  kcompletion-5.82.0-1  kconfig-5.82.0-1
kconfigwidgets-5.82.0-1  kcontacts-1:5.82.0-1  kcoreaddons-5.82.0-1  kcrash-5.82.0-1
kdbusaddons-5.82.0-1  kde-cli-tools-5.21.5-1  kde-gtk-config-5.21.5-1  kdeclarative-5.82.0-1
kdeconnect-21.04.1-1  kdecoration-5.21.5-1  kded-5.82.0-1  kdegraphics-thumbnailers-21.04.1-1
kdelibs4support-5.82.0-1  kdeplasma-addons-5.21.5-1  kdesu-5.82.0-1  kdialog-21.04.1-1
kdnssd-5.82.0-1  kemoticons-5.82.0-1  keyboard-visualizer-git-release_4.00.r26.gb50cc50-1
kfilemetadata-5.82.0-1  kfiredragonhelper-5.0.6-1  kget-21.04.1-1  kglobalaccel-5.82.0-1
kguiaddons-5.82.0-1  kholidays-1:5.82.0-1  khotkeys-5.21.5-1  ki18n-5.82.0-1
kiconthemes-5.82.0-1  kidletime-5.82.0-1  kimageformats-5.82.0-2  kinfocenter-5.21.5-1
kinit-5.82.0-1  kio-5.82.0-1  kio-extras-21.04.1-2  kio-gdrive-21.04.1-1
kipi-plugins-21.04.1-1  kirigami2-5.82.0-1  kitemmodels-5.82.0-1  kitemviews-5.82.0-1
kjobwidgets-5.82.0-1  kjs-5.82.0-1  kmahjongg-21.04.1-1  kmenuedit-5.21.5-1  kmod-29-1
knewstuff-5.82.0-1  knights-21.04.1-1  knotifications-5.82.0-1  knotifyconfig-5.82.0-1
konsole-21.04.1-1  kpackage-5.82.0-1  kparts-5.82.0-1  kpeople-5.82.0-1  kplotting-5.82.0-1
kpmcore-21.04.1-1  kpty-5.82.0-1  kquickcharts-5.82.0-1  krdc-21.04.1-1  krfb-21.04.1-1
kross-5.82.0-1  krunner-5.82.0-1  kscreen-5.21.5-1  kscreenlocker-5.21.5-1  kservice-5.82.0-1
ksysguard-5.21.5-1  ktexteditor-5.82.0-2  ktextwidgets-5.82.0-1  ktorrent-21.04.1-1
kunitconversion-5.82.0-1  kvantum-theme-sweet-git-r189.9b123a4-1  kwallet-5.82.0-1
kwallet-pam-5.21.5-1  kwayland-5.82.0-1  kwayland-integration-5.21.5-1
kwayland-server-5.21.5-1  kwidgetsaddons-5.82.0-1  kwin-5.21.5-1  kwindowsystem-5.82.0-1
kxmlgui-5.82.0-1  latte-dock-git-r5474.a03dca9d-1  less-1:581.2-1  leveldb-1.23-3
lib32-at-spi2-core-2.40.1-1  lib32-curl-7.76.1-1  lib32-dbus-glib-0.112-1  lib32-expat-2.3.0-2
lib32-faudio-21.05-1  lib32-gcc-libs-11.1.0-1  lib32-gdk-pixbuf2-2.42.6-1
lib32-glib-networking-2.68.1-1  lib32-glib2-2.68.2-1  lib32-glibc-2.33-5  lib32-gtk3-3.24.29-1
lib32-harfbuzz-2.8.1-1  lib32-icu-69.1-1  lib32-libcaca-0.99.beta19-5
lib32-libcurl-compat-7.76.1-1  lib32-libcurl-gnutls-7.76.1-1  lib32-libdrm-2.4.105-1
lib32-libelf-0.184-1  lib32-libepoxy-1.5.8-1  lib32-libgcrypt-1.9.3-1  lib32-libglvnd-1.3.3-1
lib32-libgpg-error-1.42-1  lib32-libidn2-2.3.1-1  lib32-libjpeg-turbo-2.1.0-1
lib32-libnsl-1.3.0-2  lib32-librsvg-2.50.5-1  lib32-libtiff-4.3.0-1
lib32-libva-mesa-driver-21.1.1-1  lib32-libx11-1.7.1-1  lib32-libxcrypt-4.4.20-1
lib32-libxkbcommon-1.3.0-1  lib32-libxml2-2.9.10-4  lib32-mesa-21.1.1-1
lib32-mesa-vdpau-21.1.1-1  lib32-mpg123-1.27.2-1  lib32-nss-3.65-1  lib32-opencl-mesa-21.1.1-1
lib32-pango-1:1.48.5-1  lib32-portaudio-1:19.7.0-1  lib32-readline-8.1.001-1
lib32-sqlite-3.35.5-1  lib32-systemd-248.3-1  lib32-vulkan-icd-loader-1.2.176-1
lib32-vulkan-intel-21.1.1-1  lib32-vulkan-mesa-layers-21.1.1-1  lib32-vulkan-radeon-21.1.1-1
libappletdecoration-0.8.1-3 [removal]  libass-0.15.1-1  libavif-0.9.0-2  libbluray-1.3.0-1
libcaca-0.99.beta19-5  libcups-1:2.3.3op2-3  libcurl-compat-7.76.1-1  libcurl-gnutls-7.76.1-1
libdrm-2.4.105-1  libdvdcss-1.4.3-1  libdvdnav-6.1.1-1  libdvdread-6.1.2-1
libedit-20210419_3.1-1  libelf-0.184-1  libepoxy-1.5.8-1  libfdk-aac-2.0.2-1
libgcrypt-1.9.3-1  libglvnd-1.3.3-1  libhandy-1.2.2-1  libheif-1.12.0-1  libical-3.0.10-1
libidn-1.37-1  libidn2-2.3.1-1  libimagequant-2.15.1-1  libinput-1.17.2-2
libinput-gestures-2.64-1  libjpeg-turbo-2.1.0-1  libkdcraw-21.04.1-1  libkdegames-21.04.1-1
libkexiv2-21.04.1-1  libkgapi-21.04.1-1  libkipi-21.04.1-1  libkmahjongg-21.04.1-1
libkscreen-5.21.5-1  libksysguard-5.21.5-1  libktorrent-21.04.1-1  libldap-2.4.58-2
libmanette-0.2.6-2  libmaxminddb-1.6.0-1  libmfx-21.1.3-2  libmicrohttpd-0.9.73-1
libmm-glib-1.16.4-1  libndp-1.8-1  libnm-1.30.4-3  libnsl-1.3.0-2  libplacebo-3.120.3-1
libqalculate-3.18.0-2  libqmi-1.28.4-1  libretro-beetle-pce-1080-1  libretro-beetle-psx-2527-1
libretro-beetle-psx-hw-2527-1  libretro-beetle-supergrafx-923-1  libretro-blastem-2042-1
libretro-bsnes-1:1226-1  libretro-bsnes-hd-44-1  libretro-citra-6978-1
libretro-core-info-1.9.2-1  libretro-dolphin-32989-1  libretro-flycast-4454-1
libretro-gambatte-892-1  libretro-mame-git-78607.98b0ba18a91-1  libretro-mgba-7841-1
libretro-overlays-204-1  libretro-parallel-n64-5223-1  libretro-play-6463-1
libretro-ppsspp-29742-1  libretro-scummvm-93193-1  libretro-shaders-slang-802-1
libretro-stella2014-git-264.7be8138-1  libretro-yabause-3311-1  librsvg-2:2.50.5-1
libsigc++-2.10.7-1  libslirp-4.5.0-1  libsynctex-2021.58686-3  libtasn1-4.17.0-1
libteam-1.31-3  libtiff-4.3.0-1  libtirpc-1.3.2-1  libtool-2.4.6+42+gb88cebd5-16
libva-mesa-driver-21.1.1-1  libvirt-1:7.3.0-1  libvirt-python-1:7.3.0-1  libwacom-1.10-1
libx11-1.7.1-1  libxcrypt-4.4.20-1  libxfixes-6.0.0-1  libxkbcommon-1.3.0-1
libxkbcommon-x11-1.3.0-1  libxml2-2.9.10-9  linux-api-headers-5.12.3-1
linux-firmware-20210511.7685cf4-1  linux-zen-5.12.6.zen1-1  linux-zen-headers-5.12.6.zen1-1
lvm2-2.03.12-1  lz4-1:1.9.3-2  mailcap-2.1.53-1  md4c-0.4.8-1  mercurial-5.8-2  mesa-21.1.1-1
mesa-vdpau-21.1.1-1  mhwd-db-garuda-git-r53.ebdadd1-1  mhwd-nvidia-465.27-1
mhwd-nvidia-390xx-390.143-1  micro-2.0.9-1  milou-5.21.5-1  minetest-5.4.1-1
minetest-common-5.4.1-1  minetest-server-5.4.1-1  mjpegtools-2.2.0-1
mlocate-0.26.git.20170220-7  modemmanager-1.16.4-1  modemmanager-qt-5.82.0-1  mpfr-4.1.0-2
mpg123-1.27.2-1  mpv-1:0.33.1-2  mtools-4.0.27-1  mujs-1.1.2-1  mumble-1.3.4-5  murmur-1.3.4-5
ncurses-6.2-2  network-manager-sstp-1.2.6-4  networkmanager-1.30.4-3
networkmanager-fortisslvpn-1.4rc1-4  networkmanager-openconnect-1.2.7dev+65+gca4187c-1
networkmanager-pptp-1.2.9dev+10+gb41b0d0-4  networkmanager-qt-5.82.0-1
nextcloud-client-3.2.1-1  nm-cloud-setup-1.30.4-3  nm-connection-editor-1.22.0-1
noisetorch-bin-0.11.2-1  nss-3.65-1  okular-21.04.1-1  opencl-mesa-21.1.1-1  openexr-3.0.3-1
openldap-2.4.58-2  openrgb-0.5-7  openssh-8.6p1-1  openvpn-2.5.2-1  osinfo-db-20210426-1
oversteer-0.6.0-1  pacman-5.2.2-4  pacman-mirrorlist-20210509-1  pahole-1.21-1
pamac-aur-10.1.2-1  pango-1:1.48.5-1  partitionmanager-21.04.1-1  paru-1.6.1-1
perl-http-message-6.32-1  perl-libwww-6.54-1  pipewire-1:0.3.28-1
plasma-browser-integration-5.21.5-1  plasma-desktop-5.21.5-1  plasma-disks-5.21.5-1
plasma-firewall-5.21.5-1  plasma-framework-5.82.0-1  plasma-integration-5.21.5-1
plasma-nm-5.21.5-1  plasma-pa-5.21.5-1  plasma-systemmonitor-5.21.5-1
plasma-thunderbolt-5.21.5-1  plasma-vault-5.21.5-1  plasma-workspace-5.21.5-1
plasma5-applets-window-buttons-0.9.0-1  plasma5-theme-sweet-git-r16.5d68e25-1
plymouth-git-0.9.5.r84.ge554475-3  plymouth-theme-garuda-purple-r5.16806d2-1
polkit-kde-agent-5.21.5-1  poppler-21.05.0-1  poppler-qt5-21.05.0-1  portaudio-1:19.7.0-1
postgresql-libs-13.2-2  powerdevil-5.21.5-1  powertop-2.14-1  ppp-2.4.9-1  pps-tools-1.0.2-1
prison-5.82.0-1  protobuf-3.16.0-1  proton-ge-custom-bin-6.9_GE_1-1  protontricks-git-1.5.1-1
purpose-5.82.0-1  python-3.9.5-2  python-chardet-4.0.0-2  python-dateutil-2.8.1-6
python-jinja-3.0.1-1  python-markupsafe-2.0.1-1  python-numpy-1.20.2-1  python-pillow-8.2.0-2
python-pypresence-4.2.0-1  python-pyqt5-sip-12.9.0-1  python-scipy-1.6.3-1
python-setuptools-1:56.1.0-1  python-six-1.16.0-1  python-websocket-client-0.59.0-1
python-yaml-5.4.1.1-2  qca-2.3.2-2  qemu-6.0.0-3  qemu-arch-extra-6.0.0-3
qqc2-desktop-style-5.82.0-1  qt5-base-5.15.2+kde+r195-1  qt5-declarative-5.15.2+kde+r26-1
qt5-location-5.15.2-3  qt5-svg-5.15.2+kde+r7-1  qt5-tools-5.15.2+kde+r17-1
qt5-wayland-5.15.2+kde+r23-1  qt5-webengine-5.15.3-5  raptor-2.0.15-16
rare-git-1.5_beta.r3.gacf1b2d-1  readline-8.1.001-1  rebuild-detector-4.1.6-2
reflector-2021.4-1  retroarch-1.9.3-1  retroarch-assets-glui-1:376-1
retroarch-assets-ozone-1:376-1  retroarch-assets-xmb-1:376-1
retroarch-autoconfig-udev-git-r1899.b8557bf-1  rp-pppoe-3.15-2  ruby-3.0.1-1  ruby-irb-1.3.5-1
ruby-reline-0.2.5-1  rubygems-3.2.15-1  sddm-0.19.0-6  sddm-kcm-5.21.5-1  sdl_mixer-1.2.12-10
shaderc-2021.0-1  signon-kwallet-extension-21.04.1-1  smbclient-4.14.4-1  sof-firmware-1.7-2
solid-5.82.0-1  sonnet-5.82.0-1  spectacle-21.04.1-1  spirv-tools-2021.1-1  sqlite-3.35.5-1
srt-1.4.3-1  sstp-client-1:1.0.13-1  starship-0.54.0-1  steam-1.0.0.70-1
steamtinkerlaunch-6.8-1  subversion-1.14.1-2  sudo-1.9.7-1  svt-av1-0.8.7-1  svt-hevc-1.5.1-1
sweet-gtk-theme-dark-2.0-2  sweet-kde-git-r189.9b123a4-1  sweet-theme-dark-1.10.5-1 [removal]
syntax-highlighting-5.82.0-1  systemd-248.3-2  systemd-libs-248.3-2
systemd-sysvcompat-248.3-2  systemsettings-5.21.5-1  telegram-desktop-2.7.4-2
texlive-bin-2021.58686-3  threadweaver-5.82.0-1  thunderbird-appmenu-78.10.1-1
tpm2-tss-3.1.0-1  ttf-liberation-2.1.4-1  unarchiver-1.10.7-4  unrar-1:6.0.6-1
usbredir-0.9.0-1  virglrenderer-0.9.1-1  virt-manager-meta-2-1  vte-common-0.64.1-1
vte3-0.64.1-1  vulkan-icd-loader-1.2.176-1  vulkan-intel-21.1.1-1  vulkan-mesa-layers-21.1.1-1
vulkan-radeon-21.1.1-1  vulkan-swrast-21.1.1-1  wayland-protocols-1.21-1  webkit2gtk-2.32.1-1
whoogle-git-0.5.0_r362.g39ed13f-1  wildmidi-0.4.4-1  wine-installer-5.0.3-2  wine-mono-6.1.1-1
wine-nine-0.8-1  wine-staging-6.9-1  wireguard-tools-1.0.20210424-1  wpebackend-fdo-1.9.92-1
xdg-dbus-proxy-0.1.2-3  xdg-desktop-portal-1.8.1-1  xdg-desktop-portal-kde-5.21.5-1
xf86-input-libinput-1.0.1-1  xfsprogs-5.11.0-2  xorg-server-1.20.11-1
xorg-server-common-1.20.11-1  xorg-xwayland-21.1.1-1  xorgproto-2021.4-1  yad-10.1-1
zsh-completions-0.33.0-1  zstd-1.5.0-1

Total Installed Size:  8670.61 MiB
Net Upgrade Size:       340.89 MiB

:: Proceed with installation? [Y/n] y
(578/578) checking keys in keyring                                 [------------------------------------] 100%
(578/578) checking package integrity                               [------------------------------------] 100%
error: libretro-stella2014-git: signature from "Pedro Henrique Lara Campos <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/libretro-stella2014-git-264.7be8138-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

I really appreciate the help, and this particular distro to be honest, i've tried to rectify this on my own with no luck. Anything else and I'll be happy to give additional information.

1 Like

Are you sure you went through all the four steps of this guide?
I seem to see only the first One.

2 Likes

This sort of thing happens regularly with the ChaoticAUR builds of -git packages. For example, the package signature on disk and those in the database are out-of-sync (for whatever reason).

If you have already tried re-downloading the package then you can probably --ignore this package for the moment, or switch it to libretro-stella2014 instead.

3 Likes

yes, i believe i did. I'll post the entire terminal, but was trying to avoid overkill cause it's a lot

I'll try this, I've hit y to redownload the package probably a thousand times

1 Like

how would one switch it to the other package as the second option you suggested?

This update all packages but ignore one package:

sudo pacman -Syu --ignore libretro-stella2014-git

This will update all packages and install a package:

sudo pacman -Syu libretro-stella2014

libretro-stella2014 and libretro-stella2014-git should conflict, and therefore pacman will prompt you to remove libretro-stella2014-git; by doing it this way pacman can take into account that it's a replacement so other packages that might depend on libretro-stella2014 or libretro-stella2014-git won't be removed.

4 Likes

oh...my....YESSSS!!
it motherf&^[email protected]# WORKED!!

jon, and the rest of you guys. THANK YOU so much.

...I believe my distro hoping could be at an end. The best. OMG thanks
:laughing:

1 Like

ok, sorry but it's not finding the second package libretro-stella2014, to replace libretro-stella2014-git

.%;888:8898898:              [email protected]
x;XxXB%89b8:b8%b88:            ------------------------
.8Xxd                8X:.         OS: Garuda Linux x86_64
.8Xx;                    8x:.       Kernel: 5.11.11-zen1-1-zen
.tt8x          .d            x88;     Uptime: 42 mins
[email protected];          .db:              [email protected];   
,tSXX°          [email protected];  Packages: 1637 (pacman)
.SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;  Shell: zsh
,888S                                     pd!  Resolution: 1920x1080
8X88/                                       q   Terminal: konsole
GBB.                                            
x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.        CPU: Intel i7-4790K (8) @ 4.7GHz
dxXd    dB8b8b8B8B08bB88b998888b88x.         Memory: 2137MiB / 31972MiB (6%)
dxx8o                      [email protected]@;.            
dx88                   [email protected]                                      
d:[email protected]                                        
.d988999889889899dd.                  

[WARN] - (starship::configs::starship_root): Unknown config key 'docker'
[WARN] - (starship::configs::starship_root): Did you mean 'docker_context'?
[WARN] - (starship::configs::starship_root): Unknown config key 'haskell'
[WARN] - (starship::configs::starship_root): Did you mean 'shell'?
[WARN] - (starship::configs::starship_root): Unknown config key 'docker'
[WARN] - (starship::configs::starship_root): Did you mean 'docker_context'?
[WARN] - (starship::configs::starship_root): Unknown config key 'haskell'
[WARN] - (starship::configs::starship_root): Did you mean 'shell'?
[WARN] - (starship::configs::starship_root): Unknown config key 'docker'
[WARN] - (starship::configs::starship_root): Did you mean 'docker_context'?
[WARN] - (starship::configs::starship_root): Unknown config key 'haskell'
[WARN] - (starship::configs::starship_root): Did you mean 'shell'?
[WARN] - (starship::configs::character): Unknown config key 'use_symbol_for_status'

╭─[email protected] in ~ 
╰─λ sudo pacman -Syu --ignore libretro-stella2014-git
[sudo] password for theheart:     
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
:: Starting full system upgrade...
warning: libretro-stella2014-git: ignoring package upgrade (262.f843da4-1 => 264.7be8138-1)
there is nothing to do

╭─[email protected] in ~ took 4s
╰─λ sudo pacman -Syu libretro-stella-git
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
error: target not found: libretro-stella-git

╭─[email protected] in ~ took 1s
[🔴] × sudo pacman -Syu libretro-stella2014
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
error: target not found: libretro-stella2014

╭─[email protected] in ~ took 3s
[🔴] ×

It's stopping me from adding anything else as well because it tries to reinstall that bad package or I wouldn't care, but seeing as how I don't have a clue now, lol, thanks again

I assumed there would be a package available - normally there are both plain and -git packages, but not in this case:

$ yay -Ss libretro stella
aur/libretro-stella-git 1:6.2.r153.g67db826bc-1 (+0 0.00) 
    A multi-platform Atari 2600 Emulator
aur/libretro-stella2014-git 260.26cca8d-1 (+5 0.00) 
    libretro implementation of Stella. (Atari 2600)

Looks like you'll have to --ignore it until it is fixed in ChaoticAUR. :man_shrugging:

2 Likes

how do i ignore it globally? or whatever the term would be for the "add/remove software" application

You can add it to IgnorePkg within /etc/pacman.conf (which will work with pacman, yay, paru, etc.).

Not sure if that works with Pamac, because Pamac is weird.

4 Likes

https://wiki.archlinux.org/title/Pacman

1 Like

In Pamac's Preferences there's an area for this, where you can add an app by pressing '+' button.

2 Likes

Alright, the issue is most likely fixed on Chaotic side now as well :slight_smile:

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.