[Intervention potentially required] Python 3.10 and you

If you have reinstalled or used 'garuda-update' in terminal, and it still doesn't work, then you have to track down the maintainers of the package, usually a git page, and open an issue with them. Site the python 3.10 links, etc. and your output from terminal running the app or any info you can give them....then wait. :upside_down_face:


welp, someone else already posted it... the dev is already working on it


When I try and run garuda-update or update it just says error: target not found: garuda-update anyone know why?

pacman -Qi garuda-update

If empty than

sudo pacman -Syu garuda-update

Thank you for the help! Somehow chaotic aur disappeared when I readded it everything seemed to work.

1 Like

I ran pacman -Syu and garuda-update. However mpv aborts with the following error:

mpv: error while loading shared libraries: libpython3.9.so.1.0: cannot open shared object file: No such file or directory

My mpv is provided by the package "mpv-full", version 0.34.0-1

Am I missing a step?

The error occurs, when mpv is run after updates are finished. Not during the update process.

I fixed this by downloading the latest python39 package and telling pacman to install it: sudo pacman -U python-3.9.9-1-x86_64.pkg.tar.zst
The 3.10 version is used by default, but some applications (az, for instance) still require 3.9 dependencies, which will now be present.

1 Like

Aaaaaaah don't do this! Every other package will behave this way then. Seems like we didn't catch mpv-full while rebuilding :eyes: (or is this a compatibility package?)


I don't know where to find the info of it being an compatibility package. Here is the information pacman provides:

╭─[email protected] in ~ took 8s
╰─λ pacman -Qi mpv
Name                     : mpv-full
Version                  : 0.34.0-1
Beschreibung             : A free, open source, and cross-platform media player (with all possible libs)
Architektur              : x86_64
URL                      : https://mpv.io/
Lizenzen                 : GPL
Gruppen                  : Nichts
Stellt bereit            : mpv
Hängt ab von             : cmocka  ffmpeg  lcms2  libcdio-paranoia  libgl  libxss  libxinerama  libxv
libxkbcommon  libva  wayland  libcaca  desktop-file-utils  hicolor-icon-theme
xdg-utils  lua52  mujs  libdvdnav  libxrandr  jack  rubberband  uchardet
libarchive  zlib  vapoursynth  openal  vulkan-icd-loader  shaderc  libplacebo
zimg  spirv-cross  libsixel
Optionale Abhängigkeiten : youtube-dl: for video-sharing websites playback
nvidia-utils: for hardware accelerated video decoding with CUDA [Installiert]
Benötigt von             : olivia
Optional für             : Nichts
In Konflikt mit          : mpv
Ersetzt                  : Nichts
Installationsgröße       : 5,25 MiB
Packer                   : UFSCar HPC Builder <[email protected]>
Erstellt am              : Di 02 Nov 2021 14:03:12 CET
Installiert am           : Di 14 Dez 2021 20:49:10 CET
Installationsgrund       : Ausdrücklich installiert
Installations-Skript     : Nein
Verifiziert durch        : Signatur
1 Like

Yup, this needs a rebuild. I was actually on it right now, it does seem like a source can't be downloaded due to the server which its downloading from being offline (https://waf.io). It will automatically be built once its working again though, so it should show up once the people fixed their website :slight_smile:


As @guybrush pointed out, az is also affected.
I'm not familiar with this binary, but it seems to be provided by the package "azure-cli".

Maybe pactree -rus python helps in finding affected packages.

1 Like

Is Whoogle still affected by this? I've added the below if it helps. I have already posted on their github and AUR pages.

╭─[email protected] in ~
╰─λ pacman -Qi whoogle
Name            : whoogle
Version         : 0.6.0-5
Description     : A self-hosted, ad-free, privacy-respecting metasearch engine
Architecture    : x86_64
URL             : https://github.com/benbusby/whoogle-search
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : python
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : whoogle-git
Replaces        : None
Installed Size  : 34.78 MiB
Packager        : Chaotic-AUR Wild Bear Node <[email protected]>
Build Date      : Thu 21 Oct 2021 04:17:31 AM PDT
Install Date    : Sun 12 Dec 2021 06:12:04 PM PST
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature
─λ sudo systemctl status whoogle
● whoogle.service - Whoogle
Loaded: loaded (/usr/lib/systemd/system/whoogle.service; enabled; vendor preset: disabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2021-12-15 05:59:20 PST; 2s ago
Process: 592975 ExecStart=/opt/whoogle-search/venv/bin/python -um app --host $BIND_ADDRESS --port $LISTEN>
Main PID: 592975 (code=exited, status=1/FAILURE)


Never mind just got your reply on github.


For those that don't want to wait for the Whoogle fix use the whoogle-git version in the Chaotic-AUR. It builds without any issues. You will need to restart the Whoogleservice once built.

whoogle-git work again for me.

Useless without link or answer here in forum :wink:


That's weird, I coined Eicar by putting together random letters from my name.

1 Like

╭─[email protected] in ~ took 39s
╰─λ pacman -Qi jellyfin-mpv-shim
Name : jellyfin-mpv-shim
Version : 2.0.1-1
Description : Cast media from Jellyfin Mobile and Web apps to MPV
Architecture : any
URL : GitHub - jellyfin/jellyfin-mpv-shim: MPV Cast Client for Jellyfin
Licenses : MIT
Groups : None
Provides : None
Depends On : mpv python>=3.6 python-mpv python-mpv-jsonipc>=1.1.9 python-jellyfin-apiclient>=1.7.2 tk
Optional Deps : python-pystray: systray support
python-jinja: display mirroring support [installed]
python-pywebview>=3.3.1: display mirroring support
svp: SmoothVideo Project server [installed]
mpv-shim-default-shaders: default shader pack
python-pypresence: Discord Rich Presence integration [installed]
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 826,12 KiB
Packager : Unknown Packager
Build Date : wo 15 dec 2021 18:32:51
Install Date : wo 15 dec 2021 18:32:55
Install Reason : Explicitly installed
Install Script : Yes
Validated By : None

The packages python-mpv-jsonipc and python-jellyfin-apiclient still need a rebuild. I also had to rebuild jellyfin-mpv-shim I think, but I don't quite remember.

Hey, been using bauh to help me manage flatpaks and other updates not otherwise captured by update. However, since the last update, running bauh errors out with this:

bauh terminal output with error
❯ bauh
Icon theme "gnome" not found.
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/bauh/view/qt/window.py", line 702, in _finish_refresh_packages
    if self.update_pkgs(res['installed'], as_installed=as_installed, types=res['types']):
  File "/usr/lib/python3.10/site-packages/bauh/view/qt/window.py", line 964, in update_pkgs
  File "/usr/lib/python3.10/site-packages/bauh/view/qt/window.py", line 842, in _update_table
    self._resize(accept_lower_width=len(self.pkgs) > 0)
  File "/usr/lib/python3.10/site-packages/bauh/view/qt/window.py", line 1079, in _resize
    self.resize(new_width, self.height())
TypeError: arguments did not match any overloaded call:
  resize(self, QSize): argument 1 has unexpected type 'float'
  resize(self, int, int): argument 1 has unexpected type 'float'
Fatal Python error: Aborted

Thread 0x00007f9863fff640 (most recent call first):
  File "/usr/lib/python3.10/site-packages/bauh/view/qt/thread.py", line 822 in run

Thread 0x00007f98827fc640 (most recent call first):
  File "/usr/lib/python3.10/site-packages/bauh/view/qt/prepare.py", line 140 in run

Thread 0x00007f98837fe640 (most recent call first):
  File "/usr/lib/python3.10/site-packages/bauh/view/util/cache.py", line 96 in run
  File "/usr/lib/python3.10/threading.py", line 1009 in _bootstrap_inner
  File "/usr/lib/python3.10/threading.py", line 966 in _bootstrap

Current thread 0x00007f98bbcfa740 (most recent call first):
  File "/usr/lib/python3.10/site-packages/bauh/app.py", line 57 in main
  File "/usr/bin/bauh", line 33 in <module>

Extension modules: PyQt5.QtCore, yaml._yaml, PyQt5.QtGui, PyQt5.QtWidgets, PyQt5.QtNetwork, lxml._elementpath, lxml.etree (total: 7)
[1]    36441 abort (core dumped)  bauh

Honestly not sure how to go about resolving this....anyone have any insights? Thank you!!!

EDIT: Never mind, found this: Problem with the new bauh - #3 by RodneyCK

1 Like

Install bauh-staging for now. That's what was suggested to me and it works perfectly.

1 Like

This is broken:

$ syncthing-gtk

Traceback (most recent call last):
  File "/usr/bin/syncthing-gtk", line 21, in <module>
    from syncthing_gtk.tools import init_logging, init_locale
ModuleNotFoundError: No module named 'syncthing_gtk'

I keep reading about rebuilding packages in the comments, but I am unaware of how to do this… is there any tutorial or wiki that I could read?

Thanks in advance. Kudos to a great distro. I love opinionated when they agree with my opinions :wink:

The terms rebuilding and reinstalling are pretty much synonymous.


That is what I assumed. Thanks... Anyway, I have already reinstalled the application from AUR. The same error message during import is there. I thought of doing some 'ln -s' in the python site packages... but even if that solves the issue for me it would be a mess to maintain. I am puzzled about how should I treat each python minor version upgrade. Not only that, but I guessed the Python article on Archwiki should mention some tip, or give any clue...

I hate it when my problems turn to be so obvious that I don't find my way around them.

How shall I proceed?

PS. Also, I see no helpful tips on AUR (en) - syncthing-gtk-python3

1 Like