Internet drops to zero for a few seconds every minute or so

It was noticeable during video streaming and VNC connection. The cable is fine. The speed drops to zero sometimes for a second, sometimes for a few.

System:
  Kernel: 5.17.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen
    root=UUID=b1d19ba0-d1ef-4640-8b83-51d3d5c0c767 rw quiet quiet splash
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20236 v: Lenovo G500
    serial: <superuser required> Chassis: type: 10 v: Lenovo G500
    serial: <superuser required>
  Mobo: LENOVO model: INVALID v: 00000000Not Defined
    serial: <superuser required> UEFI: LENOVO v: 78CN19WW(V1.07)
    date: 07/04/2013
Battery:
  ID-1: BAT1 charge: 9.6 Wh (32.5%) condition: 29.5/40.4 Wh (73.0%)
    volts: 10.7 min: 10.8 model: LENOVO PABAS0241231 type: Li-ion
    serial: <filter> status: discharging
CPU:
  Info: model: Intel Core i5-3230M bits: 64 type: MT MCP arch: Ivy Bridge
    family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1555 high: 1753 min/max: 1200/3200 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1753 2: 1563 3: 1567
    4: 1337 bogomips: 20753
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915
    v: kernel ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0166 class-ID: 0300
  Device-2: AMD Sun PRO [Radeon HD 8570A/8570M] vendor: Lenovo
    driver: radeon v: kernel alternate: amdgpu pcie: gen: 3 speed: 8 GT/s
    lanes: 8 bus-ID: 01:00.0 chip-ID: 1002:6663 class-ID: 0380
  Device-3: Acer Lenovo Integrated Webcam type: USB driver: uvcvideo
    bus-ID: 3-4:2 chip-ID: 5986:0295 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting,radeon alternate: fbdev,intel,vesa gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 model: LG Display 0x033a built: 2011 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.17.9-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Qualcomm Atheros QCA8172 Fast Ethernet vendor: Lenovo driver: alx
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0
    chip-ID: 1969:10a0 class-ID: 0200
  IF: enp2s0 state: up speed: 10 Mbps duplex: full mac: <filter>
  Device-2: Broadcom BCM43142 802.11b/g/n vendor: Lenovo driver: N/A pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 14e4:4365
    class-ID: 0280
  IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
  Device-1: Foxconn BCM43142A0 Bluetooth module type: USB driver: btusb
    v: 0.8 bus-ID: 1-1.3:4 chip-ID: 105b:e065 class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: N/A
Drives:
  Local Storage: total: 223.57 GiB used: 35.33 GiB (15.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: AMD Radeon model: R3SL240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2C scheme: GPT
Partition:
  ID-1: / raw-size: 86.33 GiB size: 84.42 GiB (97.79%)
    used: 35.33 GiB (41.9%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 330 MiB size: 329.3 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sda3 maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.49 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: radeon temp: 44.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 227 Uptime: 1h 8m wakeups: 1 Memory: 15.49 GiB
  used: 2.55 GiB (16.5%) Init: systemd v: 251 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: 1681 apt: 1 pacman: 1680 lib: 403
  flatpak: 0 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.16
Garuda (2.6.3-2):
  System install date:     2022-05-22
  Last full system update: 2022-05-23 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            snapper-cleanup.service systemd-networkd-wait-online.service

Just reboot and test again

Check if this persists after reboot, too.

1 Like

The first step in troubleshooting any LAN issue should always be rebooting both the router and computer, have you done this?

Have you tested different ports on the switch/router?

Have you tried resetting your router to the factory default?

Is there a firmware update available for your router?

Do you have an alternate router you could borrow to test out?

Have you tested your laptop on an alternate network, such as at a friends or neighbors?

Have you tested other Garuda live boot disks, or boot disks from other distros for comparison?

Have you tried installing and testing different kernels?

Is your bios up to date?

How do you know this?

Cabling is the #1 source of Ethernet problems, have you tested different/better grades of network cables?

Cabling can still be the cause, even if working properly in Windows. Try a Cat6e (or preferably Cat7e) cable, especially if you are using only cat5 grade of cable. Linux can be very finicky about the quality of the cables in use.

Is this problem strictly when using ethernet?

Does your connection disconnect using wifi as well?


Disable IPv6 in your router and (or) in Network Manager.


Try assigning your computer a static IP address via MAC address association through your router configuration settings.


There is an alternate alx driver available in the AUR. Try installing the alx-wol-dkms driver package and then reboot.


Please answer all questions and provide detailed feedback on anything you test out. Your initial post is woefully lacking in details, please start providing more information if you desire to find a solution.


6 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.