Intel Wireless 7265 - Network manager not working after upgrade

When I upgraded Plasma to 5.22, network manager stopped working on my laptop. When checking in terminal, the Wi-Fi hardware seemed to be up and running, but I did not have a connection. I ended up with a corrupted system and was not able to recover with Timeshift. I choose to reinstall the system. After the initial update, I got the same issue. This time I was able to recover the system to its original state and excluded Network manager from my upgrade list. This worked.

Has anyone experienced the same issue?

Side note: I did not experience this on my desktop. Only my laptop.

System:
  Kernel: 5.10.43-1-lts x86_64 bits: 64
  compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
  root=UUID=355a9e98-853f-4627-a61b-91a49ba87cb4
  rw [email protected] quiet splash
  rd.udev.log_priority=3
  vt.global_cursor_default=0
  systemd.unified_cgroup_hierarchy=1 loglevel=3
  Console: tty pts/0 wm: kwin_x11 DM: SDDM
  Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: N/A model: N/A serial: N/A
  UEFI: American Megatrends
  v: E.G140J.D8.E1.016.bin date: 11/29/2019
Battery:
  ID-1: BAT0 charge: 24.1 Wh (85.2%)
  condition: 28.3/38.0 Wh (74.5%) volts: 7.6
  min: N/A model: GLK MRD Li-ion Battery
  type: Li-ion serial: <filter>
  status: Discharging
CPU:
  Info: Quad Core model: Intel Celeron N4100
  bits: 64 type: MCP arch: Goldmont Plus
  family: 6 model-id: 7A (122) stepping: 1
  microcode: 36 cache: L1: 224 KiB L2: 4 MiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2
  ssse3 vmx
  bogomips: 8755
  Speed: 2288 MHz min/max: 800/2400 MHz
  base/boost: 1100/2700 volts: 1.2 V
  ext-clock: 100 MHz Core speeds (MHz): 1: 2288
  2: 2288 3: 2288 4: 2288
  Vulnerabilities: Type: itlb_multihit
  status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass mitigation: Speculative
  Store Bypass disabled via prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs
  barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS,
  IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel UHD Graphics 605 driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:3185
  class-ID: 0300
  Device-2: Microdia Webcam Vitade AF type: USB
  driver: uvcvideo bus-ID: 1-7:4
  chip-ID: 0c45:6366 class-ID: 0e02
  Display: server: X.Org 1.20.11
  compositor: kwin_x11 driver: loaded: intel
  unloaded: modesetting alternate: fbdev,vesa
  display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157
  size: 310x170mm (12.2x6.7")
  diag: 354mm (13.9")
  OpenGL:
  renderer: Mesa Intel UHD Graphics 600 (GLK 2)
  v: 4.6 Mesa 21.1.2 direct render: Yes
Audio:
  Device-1: Intel Celeron/Pentium Silver
  Processor High Definition Audio
  vendor: Realtek driver: snd_hda_intel
  v: kernel alternate: snd_soc_skl,snd_sof_pci
  bus-ID: 00:0e.0 chip-ID: 8086:3198
  class-ID: 0403
  Sound Server-1: ALSA v: k5.10.43-1-lts
  running: yes
  Sound Server-2: JACK v: 0.125.0 running: no
  Sound Server-3: PulseAudio v: 14.2 running: no
  Sound Server-4: PipeWire v: 0.3.30
  running: yes
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi
  v: kernel port: f040 bus-ID: 01:00.0
  chip-ID: 8086:095a class-ID: 0280
  IF: wlp1s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface
  type: USB driver: btusb v: 0.8 bus-ID: 1-4:2
  chip-ID: 8087:0a2a class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0
  state: up address: <filter>
Drives:
  Local Storage: total: 238.47 GiB
  used: 95.02 GiB (39.8%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Netac
  model: SSD 256GB size: 238.47 GiB block-size:
  physical: 512 B logical: 512 B sata: 3.2
  speed: 6.0 Gb/s rotation: SSD serial: <filter>
  rev: 2A0 temp: 40 C scheme: GPT
  SMART: yes state: enabled health: PASSED
  on: 33d 4h cycles: 850 read: 26.2 MiB
  written: 30.2 MiB
Partition:
  ID-1: / raw-size: 39.06 GiB
  size: 39.06 GiB (100.00%)
  used: 13.03 GiB (33.3%) fs: btrfs
  block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 515 MiB
  size: 514 MiB (99.80%) used: 560 KiB (0.1%)
  fs: vfat block-size: 512 B dev: /dev/sda3
  maj-min: 8:3
  ID-3: /home raw-size: 191.41 GiB
  size: 187.4 GiB (97.91%) used: 82 GiB (43.8%)
  fs: ext4 block-size: 4096 B dev: /dev/sda2
  maj-min: 8:2
  ID-4: /var/log raw-size: 39.06 GiB
  size: 39.06 GiB (100.00%)
  used: 13.03 GiB (33.3%) fs: btrfs
  block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 39.06 GiB
  size: 39.06 GiB (100.00%)
  used: 13.03 GiB (33.3%) fs: btrfs
  block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 10 (default 60)
  cache-pressure: 75 (default 100)
  ID-1: swap-1 type: partition size: 7.5 GiB
  used: 0 KiB (0.0%) priority: -2 dev: /dev/sda4
  maj-min: 8:4
  ID-2: swap-2 type: zram size: 1.9 GiB
  used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram0
  ID-3: swap-3 type: zram size: 1.9 GiB
  used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram1
  ID-4: swap-4 type: zram size: 1.9 GiB
  used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram2
  ID-5: swap-5 type: zram size: 1.9 GiB
  used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram3
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 225 Uptime: 22m wakeups: 1
  Memory: 7.59 GiB used: 3.58 GiB (47.2%)
  Init: systemd v: 248 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 12.0.0 Packages:
  pacman: 1406 lib: 344 Shell: fish (sudo)
  v: 3.2.2 default: Bash v: 5.1.8
  running-in: alacritty inxi: 3.3.04

Please, like always, post your

inxi -Faz

Check also if this can help.
https://wiki.archlinux.org/title/NetworkManager#KDE_Plasma
Plasma network manager got updated in 5.22 so maybe the widget must be re-added

2 Likes

Thanks for the reminder. added above.

Status is down ,

systemctl enable --now ???

??? driver name???
@tbg know better than me.

2 Likes

It seems the driver Is loaded iwlwifi
Probably it would help the sequence of steps that he often proposes as initial troubleshooting, eg.

nmcli networking off
sleep 1
sudo systemctl stop NetworkManager
sleep 1
sudo rmmod -v iwlwifi
sleep 1
sudo rfkill unblock wifi
sleep 1
sudo modprobe iwlwifi
sleep 3
sudo systemctl start NetworkManager
sleep 2
sudo nmcli networking on
sleep 2
nmcli r wifi off
sleep 2
nmcli r wifi on

But of course tailored for this case...

2 Likes

What if you try the following?
ip link set wlp1s0 up

1 Like

It is working now. I re-installed the nm-applet (@filo ), and ran, to be sure, the systemctl command (@SGS After reboot it worked as expected.

I am not sure if it has anything to do with the problem, but I decided to uninstall the Zen kernel and am using the lts-kernel now.

Thx a lot!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.