Intel® Wi-Fi 6E AX210 Bluetooth not working

Hello all

Fresh install of GarudaGamer edition and extremely happy with it so far. MHWD worked flawlessly (I had issues before on another machine).

Only one issue has appeared however the bluetooth unforatunately isn't working.

The chip is Intel Wi-Fi 6E AX210 which is apparently already supported in linux kernel 5.10 as per this link.

Yes, I noticed some posts about this chip some time ago, but wanted to see what the current status is as it's still fairly new. Sorry if that's against the rules.

Relevant details below as requested.

Any help much appreciated. And thank you to the devs for this amazing distro!

Operating System: Garuda Linux
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.12-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 16 × 11th Gen Intel® Core™ i9-11900KB @ 3.30GHz
Memory: 62.4 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics


System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=a5a053e3-2cb4-4077-af02-c0bba8d735bb
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Mini-pc System: Intel Client Systems product: NUC11BTMi9 v: M26263-302 serial: <filter>
Chassis: Intel Corporation type: 35 v: 2.0 serial: <filter>
Mobo: Intel model: NUC11DBBi9 v: M17026-302 serial: <filter> UEFI: Intel
v: DBTGL579.0050.2021.0802.1933 date: 08/02/2021
CPU:       Info: 8-Core model: 11th Gen Intel Core i9-11900KB bits: 64 type: MT MCP arch: Tiger Lake
family: 6 model-id: 8D (141) stepping: 1 microcode: 2C cache: L2: 24 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 105676
Speed: 3940 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 3940 2: 4483 3: 3889 4: 3142
5: 4368 6: 4739 7: 2282 8: 3133 9: 4067 10: 4401 11: 4371 12: 3741 13: 2528 14: 4153 15: 800
16: 1901
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel TigerLake-H GT1 [UHD Graphics] driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:9a60 class-ID: 0300
Device-2: NVIDIA vendor: eVga.com. driver: nvidia v: 470.74 alternate: nouveau,nvidia_drm
bus-ID: 01:00.0 chip-ID: 10de:2216 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4000x1440 s-dpi: 96 s-size: 1057x380mm (41.6x15.0") s-diag: 1123mm (44.2")
Monitor-1: HDMI-1 res: 1440x900 hz: 60 dpi: 89 size: 410x256mm (16.1x10.1") diag: 483mm (19")
Monitor-2: HDMI-1-0 res: 2560x1440 hz: 60 dpi: 103 size: 632x360mm (24.9x14.2")
diag: 727mm (28.6")
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Tiger Lake-H HD Audio driver: snd_hda_intel v: kernel
alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA GA102 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel
bus-ID: 01:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-3: Realtek USB Audio type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-11.3:6
chip-ID: 0bda:49f1 class-ID: 0300
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel bus-ID: 58:00.0
chip-ID: 8086:2725 class-ID: 0280
IF: wlp88s0 state: down mac: <filter>
Device-2: Intel Ethernet I225-LM driver: igc v: kernel port: N/A bus-ID: 59:00.0
chip-ID: 8086:15f2 class-ID: 0200
IF: enp89s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-12:5
chip-ID: 8087:0032 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: N/A
Drives:    Local Storage: total: 1.36 TiB used: 68.81 GiB (4.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 49.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
block-size: physical: 4096 B logical: 512 B type: SSD serial: <filter> scheme: MBR
Partition: ID-1: / raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 68.81 GiB (7.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 68.81 GiB (7.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 68.81 GiB (7.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 68.81 GiB (7.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.44 GiB used: 24.5 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 433 Uptime: 3h 25m wakeups: 20 Memory: 62.44 GiB used: 9.89 GiB (15.8%)
Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
pacman: 1776 lib: 546 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole
inxi: 3.3.07

Should be this bug.
Seems to be solved with a recent firmware update.
https://bugzilla.kernel.org/show_bug.cgi?id=213829
Edit: no, it is still open...
Maybe try with linux-lts...

3 Likes

Thanks, I will try that out tomorrow.

No joy with linux-lts either. Will just have to wait until the bug is sorted. Thanks

1 Like

just updated to linux-zen 5.14.16zen1-1 and bluetooth is now working :raised_hands:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.