Intel Wi-Fi 6 AX200 - MSI B550M Wifi not working

Hello dear garuda community,
best greetings, im new to the linux world and to this forum and first of all thank you a lot for this great looking and feeling distro.

My problem:
wifi is not working. I guess it is a driver issue. my mainboard: msi mortar b550m wifi - so i have a board with wifi included. (with windows everything is working fine)

what can i do to get it running? Please consider im a real noob and i need step by step instructions.
by the way, i established internet trough usb tethering -- so i can download stuff.

some extra information:
i already updated my system - didn't help
i tried following:
sudo mhwd -isudo mhwd -i pci network-r8168 pci network-r8168 - didn't help. get the error: script failed!

got the idea from here:

kind reagards and thanks already a lot for your help!!!

is there a rough aproximation how long it can take untill the driver will be ready to be installed through a system update?

just would like to now if it make sense for me to find a solution for over bridge the time

These are Ethernet drivers. We need to know your Wifi chip. Are you using an add in card or a USB Wifi dongle.

Please post:

inxi -SM; hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S"
4 Likes

System:
Host: max-neuhaus-pc Kernel: 5.10.14-119-tkg-bmq x86_64 bits: 64
Desktop: KDE Plasma 5.20.5 Distro: Garuda Linux
Machine:
Type: Desktop Mobo: Micro-Star model: MAG B550M MORTAR WIFI (MS-7C94) v: 1.0
serial: UEFI: American Megatrends LLC. v: 1.50
date: 01/13/2021
Model: "Intel Wi-Fi 6 AX200"
Driver Status: iwlwifi is active
Driver Activation Cmd: "modprobe iwlwifi"
Model: "Realtek RTL8125 2.5GbE Controller"
Driver: "r8169"
Device File: enp42s0
Link detected: no
Driver Status: r8169 is active
Driver Activation Cmd: "modprobe r8169"
Model: "Intel Bluetooth Device"
Hotplug: USB
Driver: "btusb"
Speed: 12 Mbps
Driver Status: btusb is active
Driver Activation Cmd: "modprobe btusb"
Model: "Xiaomi Mi/Redmi series (RNDIS)"
Hotplug: USB
Driver: "rndis_host"
Device File: enp45s0f3u4
Speed: 480 Mbps
Link detected: yes
Driver Status: rndis_host is active
Driver Activation Cmd: "modprobe rndis_host"

i got this as a reply from the console.

Apparently your wifi card is detected and active. What makes you say there is an issue, or that this requires an addition to the repositories?

i think the option to choose a wificonnenction is not shown. but maybe im just dont know how to do it. I add a picture, so may you can tell me if there is anything wrong

If I recall correctly from recent posts I've read on the Arch Linux forum this is a known bug. The workaround is to use the 5.4 LTS kernel. You may need to use the 2.4 GHz band as well.

Not sure if a fix can be expected anytime soon or not. You could also test the linux-mainline kernel to see if any new additions have improved things. This is a relatively new adapter and it's driver is rather a work in progress. Hopefully it's issues will be corrected soon. Unfortunately, there's very little Garuda can do about Intel's kernel module issues. The driver needs to be improved by the Intel devs.

You could try disabling MAC Address randomization to see if there is any improvement. The Garuda network utility has an easy shortcut for that (or search for instructions).

1 Like

While your wifi may be working fine in Windows, dual booting Windows often leads to problems with Linux network components.

If you are dual booting Windows I would highly suggest going through your Windows advanced Wifi driver options in the Windows device manager. Carefully go through each driver option and disable any option that relates to wifi power saving.

After you have disabled the Windows wifi power saving options and saved the changes, shutdown your computer. Once it is completely powered down unplug the power cord from your AC power supply unit.

Leave the computer unplugged from its AC power supply for a few minutes, then restart the computer. Boot into your bios setup utility. Find the setting to restore your bios to the factory defaults and then save the changes. Restart, then be sure to disable secure boot in your bios, also be sure to set it to AHCI mode in your bios.

Check online to see if your bios is up to date. If your bios is outdated then skip resetting your bios to the factory default. Instead update your bios and this will automatically reset the bios to the factory defaults during the bios update procedure. You will need to change the settings mentioned early after the update. Be sure to backup any important data before performing any bios update. This should always be done regardless, but especially so before any major alterations involving your systems hardware.

1 Like

Thread is deemed abandoned.

Thread is now closed.

PM a mod if you are the OP and wish the issue reopened.