Intel N 6200 - Wifi not working

hello guys, i really new to the Linux OS and i find it hard understanding it...
uhmm please help me,
I installed Garuda alongside my windows 10 recently and the windows is lo longer working
and also i cant connect the OS to wireless network, it says wireless deactivated please any solution?

Can you provide you


as per the forum template
even if it is from the live usb
And if its not working in windows it might be broken adapter

1 Like

okay is it possible to delete the windows OS using garuda now that i cannot access the windows?

╭─[email protected] in ~ via  v3.10.4 
╰─λ garuda-inxi
Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=78d66672-7a6b-441e-9d71-9f35b6dbc018 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 2537LB8 v: ThinkPad T410
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 2537LB8 serial: <superuser required> BIOS: LENOVO
v: 6IET65WW (1.25 ) date: 06/07/2010
ID-1: BAT0 charge: 13.1 Wh (85.6%) condition: 15.3/48.8 Wh (31.3%)
volts: 11.7 min: 11.1 model: SANYO 42T4832 type: Li-ion serial: <filter>
status: discharging
Info: model: Intel Core i5 M 520 bits: 64 type: MT MCP arch: Westmere
family: 6 model-id: 0x25 (37) stepping: 5 microcode: 0x7
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1569 high: 1708 min/max: 1199/2400 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1521 2: 1503
3: 1708 4: 1544 bogomips: 19152
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel Core Processor Integrated Graphics vendor: Lenovo
driver: i915 v: kernel ports: active: LVDS-1
empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1
bus-ID: 00:02.0 chip-ID: 8086:0046 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.00x9.37")
s-diag: 449mm (17.69")
Monitor-1: LVDS-1 model: Lenovo 0x4036 built: 2009 res: 1440x900 hz: 60
dpi: 121 gamma: 1.2 size: 303x189mm (11.93x7.44") diag: 357mm (14.1")
ratio: 16:10 modes: 1440x900
OpenGL: renderer: Mesa Intel HD Graphics (ILK) v: 2.1 Mesa 22.0.2
direct render: Yes
Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56
class-ID: 0403
Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Device-1: Intel 82577LM Gigabit Network vendor: Lenovo driver: e1000e
v: kernel port: 1820 bus-ID: 00:19.0 chip-ID: 8086:10ea class-ID: 0200
IF: enp0s25 state: down mac: <filter>
Device-2: Intel Centrino Advanced-N 6200 driver: iwlwifi v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:4239
class-ID: 0280
IF: wlp3s0 state: down mac: <filter>
IF-ID-1: ppp0 state: unknown speed: N/A duplex: N/A mac: N/A
Local Storage: total: 149.05 GiB used: 36.74 GiB (24.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD1600BEVT-60ZCT1 size: 149.05 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A13 scheme: MBR
ID-1: / raw-size: 148.51 GiB size: 148.51 GiB (100.00%)
used: 36.74 GiB (24.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /home raw-size: 148.51 GiB size: 148.51 GiB (100.00%)
used: 36.74 GiB (24.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-3: /var/log raw-size: 148.51 GiB size: 148.51 GiB (100.00%)
used: 36.74 GiB (24.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/tmp raw-size: 148.51 GiB size: 148.51 GiB (100.00%)
used: 36.74 GiB (24.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.56 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (RPM): fan-1: 3806
Processes: 230 Uptime: 53m wakeups: 1 Memory: 7.56 GiB
used: 3.19 GiB (42.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1676 lib: 507 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.2-1):
System install date:     2022-05-09
Last full system update: 2022-05-09
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service systemd-vconsole-setup.service

╭─[email protected] in ~ via  v3.10.4 took 2s

Welcome to the forums :slight_smile:

In Linux everything is possible :slight_smile: you can also try

sudo update-grub

or first


May it is better you start with a linux for new comers, like MX Linux. :slight_smile:
We do not teach new linux users and dual boot with M$ is not supported by the Garuda Team. :slight_smile:

1 Like

3 posts were split to a new topic: Garuda-inxi - Windows detection question

I would recommend disabling fast boot on Windows.

I would also recommend resetting your bios to the factory default if my prior suggestion is of no improvement. You will likely need to modify your BIOS settings for use with Linux after resetting your bios. Be sure both secure boot and fast boot are disabled in the BIOS. Also be sure your controller is set to AHCI mode in your BIOS.

I would also suggest testing out the linux-lts kernel as your hardware is rather old. Testing other kernels may also be helpful to get your wifi working.

Please run these commands:

sudo ip link set dev wlp3s0 up
rfkill list

Please post both the inputs and output of those commands.