Intel I225-V Ethernet adapter loses connection after Random amount of time (1 hour) , until restart

I recently downloaded the latest version of garuda ISO. And this issue is driving me nuts.

I am using the machine normally, suddently my internet connection dies - nothing I can do brings it up again, plugin the cable, creating a new connection. The only way is to reboot the whole machine, and voila it works. It took me 2 days to realize it was not my ISP and the machine losing connection because, it was working flawlessly before the new iso install.

One interesting bit, is that it seems to be 1hours intervals or close to.

If I ping anything, it tells me it failed to resolve the host name - changed DNS, same result, done it multiple time times, with multiple DNS.

I cant afford to do a fresh install right now, what can I do to fix this?

  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6598ddea-ecba-4898-822f-5cfb699ebea5 rw rootflags=subvol=@
    amd_iommu=on iommu=pt rd.driver.pre=vfio-pci
    vfio-pci.ids=10de:2684,10de:22ba ibt=off
  Desktop: Hyprland vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX X670E-E GAMING WIFI v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 0922
    date: 02/23/2023
  ID-1: hidpp_battery_0 charge: 85% condition: N/A volts: 4.0 min: N/A
    model: Logitech G903 LIGHTSPEED Wireless Gaming Mouse w/ HERO type: N/A
    serial: <filter> status: discharging
  Info: model: AMD Ryzen 9 7950X bits: 64 type: MT MCP arch: Zen 4 gen: 5
    level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
    model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
    L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 16 MiB desc: 16x1024 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 1090 high: 5499 min/max: 400/5881 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
    4: 400 5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 13: 4609
    14: 400 15: 400 16: 400 17: 4341 18: 5499 19: 400 20: 400 21: 400 22: 400
    23: 400 24: 400 25: 400 26: 400 27: 400 28: 5126 29: 400 30: 4532 31: 400
    32: 400 bogomips: 288003
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: NVIDIA AD102 [GeForce RTX 4090] vendor: ASUSTeK driver: vfio-pci
    v: N/A alternate: nouveau,nvidia_drm,nvidia non-free: 545.xx+
    status: current (as of 2023-10) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2684 class-ID: 0300
  Device-2: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia
    v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
    (as of 2023-10; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 05:00.0
    chip-ID: 10de:1b80 class-ID: 0300
  Device-3: AMD Raphael vendor: ASUSTeK driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1 empty: DP-1
    bus-ID: 13:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 45.0 C
  Display: wayland server: v: with: Xwayland v: 23.2.2
    compositor: Hyprland driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
    gpu: amdgpu display-ID: 1
  Monitor-1: HDMI-A-1 model: LG (GoldStar) TV SSCR2 serial: <filter>
    built: 2020 res: 3840x2160 hz: 120 dpi: 61 gamma: 1.2 scale: 1
    size: 1600x900mm (62.99x35.43") diag: 1836mm (72.3") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: Vulkan v: 1.3.269 layers: 4 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
    v: 23.2.1-arch1.2 device-ID: 1002:164e surfaces: xcb,xlib,wayland
    device: 1 type: discrete-gpu name: NVIDIA GeForce GTX 1080 driver: nvidia
    v: 535.113.01 device-ID: 10de:1b80 surfaces: xcb,xlib,wayland device: 2
    type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: NVIDIA AD102 High Definition Audio vendor: ASUSTeK
    driver: vfio-pci alternate: snd_hda_intel pcie: speed: Unknown lanes: 63
    link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.1 chip-ID: 10de:22ba
    class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4
    link-max: lanes: 16 bus-ID: 05:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Device-3: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 13:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-4: C-Media USB Advanced Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-5:2 chip-ID: 0d8c:016c class-ID: 0300
  Device-5: ASUSTek USB Audio driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:5
    chip-ID: 0b05:1a52 class-ID: 0300
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp9s0 state: down mac: <filter>
  Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 0a:00.0
    chip-ID: 8086:15f3 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:4 chip-ID: 8087:0032
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.3
    lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c0104
  Local Storage: total: 6.94 TiB used: 16.79 GiB (0.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: N/A
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: RKT303.3 temp: 28.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:6 vendor: Kingston model: SNV2S1000G
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: SBM02103 temp: 37.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDHP256G
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 6RL scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD3200BPVT-80JJ5T0 size: 298.09 GiB block-size: physical: 4096 B
    logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  ID-5: /dev/sdc maj-min: 8:32 vendor: Samsung model: HD103UI
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: N/A serial: <filter> fw-rev: 1113 scheme: MBR
  ID-6: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST3000DM001-1ER166
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC43 scheme: GPT
  ID-1: / raw-size: 488.28 GiB size: 488.28 GiB (100.00%)
    used: 16.79 GiB (3.4%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:8
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:7
  ID-3: /home raw-size: 488.28 GiB size: 488.28 GiB (100.00%)
    used: 16.79 GiB (3.4%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:8
  ID-4: /var/log raw-size: 488.28 GiB size: 488.28 GiB (100.00%)
    used: 16.79 GiB (3.4%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:8
  ID-5: /var/tmp raw-size: 488.28 GiB size: 488.28 GiB (100.00%)
    used: 16.79 GiB (3.4%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:8
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 61.94 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 32 dev: /dev/zram0
  System Temperatures: cpu: 55.2 C mobo: N/A gpu: amdgpu temp: 46.0 C
  Fan Speeds (rpm): N/A
  Processes: 568 Uptime: 2m wakeups: 0 Memory: total: 64 GiB
  available: 61.94 GiB used: 4.03 GiB (6.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1369 libs: 379 tools: pamac,paru,yay Shell: fish v: 3.6.1
  running-in: alacritty inxi: 3.3.31
Garuda (2.6.17-1):
  System install date:     2023-11-01
  Last full system update: 2023-11-02
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

First, I never lost the connection on PC (WiFi/Eth) or notebooks (WiFi).

I move it to Networking Support

Same behavior on Ethernet?

Its just on ethernet, havent tried wifi yet (never used it, dont even have a antenna connected right now).

One thing I noticed , is it seems to be precisely 1 Hour intervals, and the only other thing is that I have a Windows Guest machine running - havent checked if it happens without being actively using the machine.

Check router and VM, crazy behavior.

Router works fine, VM loses connections (since host also loses the connection). Its super weird behaviour.

Sorry, but this can’t have anything to do with Garuda. I have therefore changed the title.

Can you run M$ or something else, e.g. live ISO’s, as a cross-check?

All works fine, dual booting windows connects fine, changing the ethernet cable from the machine to a laptop gets connection, but connecting it back to the desktop does not until I reboot sadly.

MIght not be 100% Garuda related - but it is from this fresh Hyprland install, I was running Hyprland for over 6 months with garuda with no issue though.

This has occured in the past for me with Garuda, and a fresh install fixed it, I just cant really do one right at this moment.

Me too, but it work longer than one hour?

Well, I’ve been using Hyprland for a long time and I don’t have this problem. I also don’t know of any function that switches off the network after an hour.
There are also no cronjobs or timers here.

If possible, try my suggestion and take any other live ISO, from whoever, and leave it on the network for a few hours.

I will be able to fresh install it tomorrow, if it sort it off I will post back.

Thanks for the help anyway :smiley:

1 Like

Try installing a different kernel first.
I’d try both linux-lts backwards and linux-mainline onwards.
Another thing you could try, if the disconnection time is regular, is to try using a static ip address (it could be a DHCP issue).


I just fresh installed, and change kernel to linux-lts. It stoped being regular (or maybe it wasnt), and it happened again.

No idea whats going on here, I cant reproduce it at all, so it makes debugging super hard.
Any ideas on things I could try once it happens again to gain more information? commands to check, and I can follow up on that myself, I just need to something to get started…

EDIT: So I decided to look into journalctl - in insight should have been my first thing, and found this igc 0000:0a:00.0 eno1: PCIe link lost, device now detached

This seems to be driver related, any ideas? ( I know its not garuda specific, but…)

EDIT2 : Reddit - Dive into anything
Seems related.

1 Like

Did you test out the pcie_port_pm=off pcie_aspm.policy=performance kernel parameter as detailed in the reddit link you posted, (below).

  • Edit /etc/default/grub
  • Add pcie_port_pm=off pcie_aspm.policy=performance to GRUB_CMDLINE_LINUX_DEFAULT
  • e.g. GRUB_CMDLINE_LINUX_DEFAULT="quiet pcie_aspm.policy=performance pcie_port_pm=off"
  • Double check file - cat /etc/defualt/grub
  • Run sudo update-grub
  • Reboot (don’t forget this part!!)
  • Check params from boot cat /proc/cmdline

If you are unfamiliar with editing kernel params then it might be a good idea to take a system snapshot beforehand.


Yeah, I was about to comeback with the report.
I added those parameters, pc has been on for 3 days. Internet still works great.
So I reckon its solved.

Thank you for your help!

Failed to write file "/sys/module/pcie_aspm/parameters/policy": Operation not permitted

i get this message during updates because i’ve disabled advanced power management in the bios - it’s set to S3 (power on suspend) sleep only.

you really don’t need your PCIe slots powering down unless you use a laptop and need to save battery life.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.