Installing WPS Office with SNAP

I'm trying to install WPS Office with snap to see if it solves the spell-checking problem.

Installed snapd from AUR.

snap install wps-2019-snap

Installed fine. No start menu entry. How do I generate start menu items? Or am I better with the Flatpack version?

I know Snap and Flatpack aren't officially supported but here there are no better options. At least worth a try.

I install from AUR you have to install the correct spelling package and fonts for it to work correctly its in aur

3 Likes

This is more for LibreOffice, but some of the same things might apply... I typed this up before realising, oops this thread is about WPS lmao ^^; reading tired is not a good idea...

Make sure that the language you have selected actually has spellchecking available. You might need dictionaries to get it to work.
Last thing to check - if you use multiple IME/language inputs, you may need to enable the 'Ignore system input language' option if it's available. Without enabling this option, LO for me would refuse to recognise any language and would default to a language which has no spellcheck.

Hope this gives you some ideas :slight_smile:

2 Likes

never try wps, it has privacy issue. I recommend LibreOffice.

2 Likes

What "privacy issues?" Do you care to share your sources for that claim or is it just FUD? We take things like privacy issues serious here in Linux Land and if you know something we don't then you need to share it, please.

4 Likes

If you create an account and use their services, they collect a lot of information. Personal details, information related to other accounts you might be logged in to, device information, location data, third party trackers are used...blah blah blah. They are pretty open about it in their privacy policy:

  1. What Information We Collect about You
    (1) Basic Subscription Information. If you create an account (“Account ” or “WPS ID ”) in connection with your use of any of the Services, either through our Sites or when you download and install our Apps and Products, we’ll collect certain information about you, such as your name, email address, postal address. If you create an Account using your login credentials from one of your accounts with third-party social networking services such as Google, Facebook, Microsoft, Dropbox or Twitter (each, an “SNS Account ”), we’ll be able to access and collect your name and email address and other information that your privacy settings on the SNS Account permit us to access. If you create an Account, we may also collect other non-personal data information (e.g., virtual device identifier).

That's only one paragraph, it goes on and on for a full page with all the details about what they actively collect.

To be fair, this type of data mining is very typical for this kind of service. Google Workspace or Microsoft O365 would absolutely collect this same data, or more if they can get their hands on it.

For someone not using the online services--that is, just installing the desktop apps and using them locally on their machine--there doesn't appear to be inbuilt telemetry. Since the software is closed-source and Chinese owned, you'd have to take their word for it I guess.

5 Likes

Where do you find this option?

There has been 2 threads on the topic and this is the only new element to it, worth a try. The last discussion led to the creation of wps-office-all-dicts-win-languages but that wasn't enough to solve the problem.

If I don't create an account?

I "could" use LibreOffice, but for me, one core criteria for an Office Suite is that I can open a Word or PowerPoint document from someone else and it opens and work as expected without issues. I've tried various suites and only WPS Office has that level of compatibility and features.

Waaaiit a second. Spellchecking WAS working after re-install... until I opened the "Set Language" window and Cancel on that window. Then it stopped working; and even closing and re-opening the app doesn't fix it. Setting language to French, spell-checking works, setting it to English (United States), it doesn't anymore... so sometimes it does, sometimes it doesn't...

So for SNAP, doesn't look like there's any simple way to get it working that way? Could be useful at least for testing.

but why

4 Likes

Sorry for the late response. When I mentioned that, I was talking about LibreOffice rather than WPS because I was having a smooth brain moment when reading your post :joy: if such a feature doesn't exist in WPS then that's a shame.

That's quite interesting... maybe English (US) doesn't have spellchecking in your version of WPS? The same thing happens to me with LibreOffice - my English (USA) doesn't do spellchecking either.
Have you tried reinstalling it yet again and going through the set language window?

I don't know much (or anything really) of installing stuff via Snap, but if you can't find a solution, you can always spellcheck in a different word processor or software. Just make sure you're not forgetting to spellcheck before you hand something to someone else.

Btw the AUR has WPS Office. Is there a specific reason why Snap is the best option for you? Mainly asking this out of curiosity more than anything, feel free to keep the answer to yourself if you'd like ^^

2 Likes

in the last thread the mod suggested trying a different version like SNAP since nothing else worked

A work-around is to use Grammerly website for typing, but that's not ideal option.

1 Like

For goodness sake just use the AUR version and language packs and be done with this snap obsession or just use ubuntu snaps are made for it explicitly after all

3 Likes

We're experimenting to try to solve the spell-checking problem.

I tried WPS Office years ago. I could never get the languages or spell check I wanted.
I contacted support and they said it was coming shortly.
Never did.
I use LibreOffice now.

H

I have been using OnlyOffice as a basic document viewer on my systems for at least 2 years now. It seems to work well and havent had any problems with it. (I use cloud services for notes, writings etc)

1 Like

Yes, this one! :+1:

I use it to write or edit documents. In both Linux & Windows.

2 Likes

I have a solution to this problem.
We should all just use Vim to view and edit documents :slight_smile: :+1:
or maybe emacs, whichever one looks more like what a 'hacker' would use :joy:

In all seriousness, all this discussion has made me curious about WPS, so I'm gonna install it via the AUR and see if spellcheck is also an issue on my end, both the international version and the cn version. In the past, the only times i used WPS were either to experiment on Windows, or on my Chinese phone where it comes as a default :smiley:

Update

I installed the international WPS and my spellcheck works OOTB after I set the language to English (United States) in the review tab - is that supposed to be the only language there by default?
Since spellcheck works with the international version, I won't bother with trying the cn version unless you would like me to.

I find it quite funny that it accepts some words spelt the British/Australian way despite the language being set to US English :slight_smile:

Is there anything I should check in case people are missing something that makes it work?
Also, there's a spell check toggle at the bottom. I know this is a dumb question but have you tried toggling it just in case you accidentally clicked it at some point?

1 Like

It seems to either work or not work based on some unknown factor.

As I said; when I opened it, it "was" working, until I touched something then I couldn't get it to work. Or it would work in one language but not another.

And yes the toggle is enabled of course.

There's a language pack package to install to have the additional language.

1 Like