Installing processing 2 and processing 3

Hello :smiley:

I have decided to switch to Linux and picked this distro as I am a gamer and about to install the OS. However, I have processing scripts that I need for making my glitch art possible.

I searched the forum for any mentions, but nobody has tried it yet. Is it possible to install Processing 2 and 3 side by side?


I believe AUR has only one version of processing which has been included in chaotic-AUR as well,

chaotic-aur/processing 4.3-2.2
    Programming environment for creating images, animations and interactions

Or if you want you can manually install (and keep it updated) processing as well. Ignoring the system wide package manager pacman and it’s benefits of updating all packages at once, removing all files associated with a package etc.


neither processing 2 or 3 are updated anymore so there is one thing from worrying about :smiley:

I managed to download it and learned to run it from a folder (yaay) is there any possibility of installing it so I don’t have to run it each from terminal and so I can run scripts from shell?

Can you share what exactly? :slight_smile:
It is always helpful to post the garuda-inxi as the template says.

processing                       4.3-2.2
sudo pacman -Syu processing
:: Paketdatenbanken werden synchronisiert …
 garuda ist aktuell
 core ist aktuell
 extra                                                  8,3 MiB  11,4 MiB/s 00:01 [-----------------------------------------------] 100%
 multilib ist aktuell
 chaotic-aur                                            2,6 MiB  3,05 MiB/s 00:01 [-----------------------------------------------] 100%
:: Vollständige Systemaktualisierung wird gestartet …
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Paket (6)                      Alte Version  Neue Version  Netto-Veränderung  Größe des Downloads

extra/java-environment-common                3-5                    0,00 MiB             0,00 MiB
extra/jdk17-openjdk                          17.0.9.u8-2          247,33 MiB           233,75 MiB
extra/jre17-openjdk                          17.0.9.u8-2            0,49 MiB             0,18 MiB
extra/jre17-openjdk-headless                 17.0.9.u8-2          171,26 MiB            38,16 MiB
extra/python-setuptools        1:68.0.0-1    1:68.1.0-1             0,01 MiB             0,75 MiB
chaotic-aur/processing                       4.3-2.2               65,67 MiB            47,33 MiB

Gesamtgröße des Downloads:             320,17 MiB
Gesamtgröße der installierten Pakete:  489,39 MiB
Größendifferenz der Aktualisierung:    484,75 MiB

:: Installation fortsetzen? [J/n] 

add the path to it’s bin directory as an environment variable for fish (the default shell we use).
In ~/.config/fish/ add the line

set -x /path/to/bin/dir

where you change /path/to/bin/dir with the actual path where your processor executable is stored close and reopen the terminal and then you can use the processor command from any directory.

1 Like

I downloaded it from processing site initially and not from pacman,
now I installed it from pacman and it works but it starts only processing 4.
I can still start processing 2 and 3 from folders I extracted initially but I have no idea how to start processing 2 and 3 from gui.

when I initially posted I haven’t installed os yet so here is

Kernel: 6.6.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4ac457e7-0183-41bb-9a21-8be613e12198 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Micro-Star model: Z370-A PRO (MS-7B48) v: 1.0
serial: <superuser required> BIOS: American Megatrends v: 2.D3
date: 11/18/2021
Info: model: Intel Core i7-9700K bits: 64 type: MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xFA
Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB
desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB L3: 12 MiB
desc: 1x12 MiB
Speed (MHz): avg: 800 min/max: 800/4900 scaling: driver: intel_pstate
governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
8: 800 bogomips: 57600
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: Gigabyte
driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 3 speed: 8 GT/s
lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0
chip-ID: 10de:2504 class-ID: 0300
Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK
driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 03:00.0
chip-ID: 10de:1c03 class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.73x11.85")
s-diag: 1102mm (43.38")
Monitor-1: DP-0 pos: left res: 1920x1080 hz: 60 dpi: 93
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
Monitor-2: DP-2 pos: primary,right res: 1920x1080 dpi: 93
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
Monitor-3: None-2-1 size-res: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 1
drv: nvidia device: 4 drv: swrast gbm: drv: kms_swrast surfaceless:
drv: nvidia x11: drv: nvidia inactive: wayland,device-2,device-3
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
memory: 11.72 GiB
API: Vulkan v: 1.3.269 layers: 11 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3060 driver: nvidia v: 545.29.06
device-ID: 10de:2504 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce GTX 1060 6GB driver: nvidia v: 545.29.06
device-ID: 10de:1c03 surfaces: N/A
Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
chip-ID: 8086:a2f0 class-ID: 0403
Device-2: NVIDIA GA106 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:228e
class-ID: 0403
Device-3: NVIDIA GP106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4
link-max: lanes: 16 bus-ID: 03:00.1 chip-ID: 10de:10f1 class-ID: 0403
Device-4: Texas Instruments PCM2902 Audio Codec
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-11:5 chip-ID: 08bb:2902 class-ID: 0300
API: ALSA v: k6.6.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.85 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 6f:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp111s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek 802.11ac NIC driver: N/A type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:2 chip-ID: 0bda:c811
class-ID: 0000 serial: <filter>
Local Storage: total: 2.75 TiB used: 401.71 GiB (14.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 2B2QEXE7 temp: 41.9 C
scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD1002FAEX-00Z3A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
fw-rev: 1A01 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: GOODRAM model: SSDPR-HL100-01T
size: 953.87 GiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
fw-rev: 1101 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 183.99 GiB (19.8%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 183.99 GiB (19.8%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 183.99 GiB (19.8%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 183.99 GiB (19.8%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.17 GiB used: 62.2 MiB (0.2%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
dev: /dev/zram0
System Temperatures: cpu: 49.0 C mobo: N/A gpu: nvidia temp: 42 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Processes: 335 Uptime: 1h 48m wakeups: 0 Memory: total: 32 GiB note: est.
available: 31.17 GiB used: 8.29 GiB (26.6%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1862 libs: 533 tools: gnome-software,octopi,pamac,paru
Shell: fish v: 3.6.1 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-24
Last full system update: 2023-11-24 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       <superuser required>
Failed units:            grub-btrfs-snapper.path grub-btrfs-snapper.service
1 Like

If the app has a .desktop file you can click on it and launch your GUI session. You can also symlink the file to any other location and use it to launch processor from there.

1 Like

ok I managed to find out I can use for installing processing 3 (Releases / but as you can guess there is no such thing for processing 2.

so I run it by
terminal in


I can just start it by typing.

. /processing

whenever chaotic-aur processing package installed I can’t find it to see if there is .desktop or anything as such

in shell when I attempt to open scripts I can see Processing (processing 4), Processing IDE (Processing 3) but no sight of processing 2.

if I add it with will it get installed like processing 4 and processing 3 and be accessible from shell?

set -x /path/to/bin/dir

I am also thinking if

sudo pacman -Syu processing

doesn’t require me to specify which version I want to install somehow but it might require to specify version and somehow lock it from updating to newest one.

to be clear I would be perfectly fine with getting rid of processing 4 and replacing it with processing 2.2.1

(I use word processing waaaay too much in this posts :skull:)

I unpacked Chaotic-AUR processing repository from and unfortunately inside there is just processing 4.3 installer and saddness so I won’t find processing 2 there :frowning:
looks like Releases / is all I got to work with

yeah I tried creating some kind of desktop shortcut to processing 2 unsuccessfully.
if someone could try and explain at least that to me it would be great because I can start the program from terminal but with how I need to jump between the 2 and 3 it’s quite inconvinient

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.