Installing Nvidia Drivers


I am new to Garuda Linux and also to Arch. i want to install navidia driver in place of nouveau because getting a lot frame drops.

When I try to install

pacman -S navidia 

and then restart i can't boot it sticks on blinking cursor with black screen. And when live boot with NVIDIA driver it stucks on "Terminate Pymouth ....". I have tried to download from navidia official website by searching drivers it was unable to install.

Here's inxi -Faz

Kernel: 5.15.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0190f785-7cc5-44bf-8d30-55b68e45fb58 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Gigabyte model: H81M-S v: x.x
serial: <superuser required> UEFI: American Megatrends v: F2
date: 08/19/2015
Info: model: Intel Core i5-4590S bits: 64 type: MCP arch: Haswell family: 6
model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 2484 high: 3678 min/max: 800/3700 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 2189 2: 1684 3: 2386
4: 3678 bogomips: 23944
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0412
class-ID: 0300
Device-2: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nouveau
v: kernel bus-ID: 01:00.0 chip-ID: 10de:128b class-ID: 0300
Display: x11 server: X.Org compositor: kwin_x11 driver:
loaded: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.0x9.4")
s-diag: 449mm (17.7")
Monitor-1: HDMI-1 res: 1440x900 hz: 60 dpi: 89
size: 409x256mm (16.1x10.1") diag: 483mm (19")
Message: Unable to show advanced data. Required tool glxinfo missing.
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c
class-ID: 0403
Device-2: Intel 8 Series/C220 Series High Definition Audio
vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:8c20 class-ID: 0403
Device-3: NVIDIA GK208 HDMI/DP Audio vendor: ZOTAC driver: snd_hda_intel
v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403
Sound Server-1: ALSA v: k5.15.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Local Storage: total: 149.05 GiB used: 7.64 GiB (5.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: HD161HJ
size: 149.05 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: N/A serial: <filter> rev: 0-07 scheme: GPT
ID-1: / raw-size: 148.75 GiB size: 148.75 GiB (100.00%)
used: 7.64 GiB (5.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 148.75 GiB size: 148.75 GiB (100.00%)
used: 7.64 GiB (5.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 148.75 GiB size: 148.75 GiB (100.00%)
used: 7.64 GiB (5.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 148.75 GiB size: 148.75 GiB (100.00%)
used: 7.64 GiB (5.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.66 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 33.0 C
Fan Speeds (RPM): N/A
Processes: 190 Uptime: 17m wakeups: 0 Memory: 7.66 GiB
used: 1.6 GiB (20.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1143 lib: 293 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11

Sorry for my bad English.

There is no driver named like that.. but I will assume it's just a typo.

Your inxi -Faz tells me you got a GeForce GT 710.
From the arch wiki NVIDIA - ArchWiki

For the Kepler (NVE0) series (including GeForce 630-920) from around 2013-2014, install the nvidia-470xx-dkmsAUR package.

Garuda also comes with mhwd to auto install drivers.

You could also try that.
To start the GUI for that (note: I am on KDE the command may vary):

/usr/bin/kcmshell5 msm_mhwd

Please don't just copy paste but read the arch wiki what you can try to fix your issue.


Ok I will try that. Thanks. Half of the problem you have solved.
When i run

/usr/bin/kcmshell5 msm_mhwd

I found video-navidia-390xx-dkms under my display controller should i install that or nvidia-470xx-dkms

From the arch wiki I would go with the 470xx
Again, does it really say navidia?! :thinking: some bootleg video card? :smiley:


Oh I forgot, since this is your first post here.

Welcome to the Garuda Community :heart:



Now, i have successfully install NVIDIA but how set this as my default driver?

I think you can only have one installed anyway? :thinking: arch wiki will know more.

i didn't get you.

I believe you can only have one installed, so that one is default anyway.

I got this command from web

sudo lspci | grep ' VGA ' | cut -d" " -f 1 | xargs -i lspci -v -s {}

And when i run it:

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
  Subsystem: Gigabyte Technology Co., Ltd Device d000
  Flags: bus master, fast devsel, latency 0, IRQ 31
  Memory at f7400000 (64-bit, non-prefetchable) [size=4M]
  Memory at d0000000 (64-bit, prefetchable) [size=256M]
  I/O ports at f000 [size=64]
  Capabilities: <access denied>
  Kernel driver in use: i915
  Kernel modules: i915

01:00.0 VGA compatible controller: NVIDIA Corporation GK208B [GeForce GT 710] (rev a1) (prog-if 00 [VGA controller])
  Subsystem: ZOTAC International (MCO) Ltd. Device 7326
  Flags: bus master, fast devsel, latency 0, IRQ 30
  Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
  Memory at e0000000 (64-bit, prefetchable) [size=128M]
  Memory at e8000000 (64-bit, prefetchable) [size=32M]
  I/O ports at e000 [size=128]
  Expansion ROM at 000c0000 [disabled] [size=128K]
  Capabilities: <access denied>
  Kernel driver in use: nouveau
  Kernel modules: nouveau, nvidia_drm, nvidia

In Kernel Modules of Navidia there are three.
If i can't set as default. Can i remove them which are not required?

nvidia-smi Running this getting error

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

If you want to install nvidia drivers, I suggest you take a look at Linux-TKG's git.

I am using this for a long time and it has been totally flawless. You do have to update the drivers yourself once in a while as it isn't automated.

Please take the time to read carefully that page so you follow proper instructions, if you choose to try it out.

I'd recommend using the packages in the repos rather than a third-party installer. :man_shrugging:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.